summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2010-02-05 21:08:29 +0000
committerUlrich Müller <ulm@gentoo.org>2010-02-05 21:08:29 +0000
commitc5c8e84c5b92597c779bc6cdd6ac3565a886117e (patch)
tree1a3b1958b7b67f400d5c3cef0e6984f1bb6df603 /sys-auth
parentold (diff)
downloadgentoo-2-c5c8e84c5b92597c779bc6cdd6ac3565a886117e.tar.gz
gentoo-2-c5c8e84c5b92597c779bc6cdd6ac3565a886117e.tar.bz2
gentoo-2-c5c8e84c5b92597c779bc6cdd6ac3565a886117e.zip
Add NULL pointer check in mod_talk_touser, fixes bug 301467.
(Portage version: 2.2_rc62/cvs/Linux i686)
Diffstat (limited to 'sys-auth')
-rw-r--r--sys-auth/pam_skey/ChangeLog9
-rw-r--r--sys-auth/pam_skey/pam_skey-1.1.5-r1.ebuild51
2 files changed, 58 insertions, 2 deletions
diff --git a/sys-auth/pam_skey/ChangeLog b/sys-auth/pam_skey/ChangeLog
index c3149af18383..1f45891b80fb 100644
--- a/sys-auth/pam_skey/ChangeLog
+++ b/sys-auth/pam_skey/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-auth/pam_skey
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-auth/pam_skey/ChangeLog,v 1.8 2008/05/11 13:11:27 ulm Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/pam_skey/ChangeLog,v 1.9 2010/02/05 21:08:29 ulm Exp $
+
+*pam_skey-1.1.5-r1 (05 Feb 2010)
+
+ 05 Feb 2010; Ulrich Mueller <ulm@gentoo.org> +pam_skey-1.1.5-r1.ebuild:
+ Add NULL pointer check in mod_talk_touser, fixes bug 301467.
11 May 2008; Ulrich Mueller <ulm@gentoo.org> pam_skey-1.1.5.ebuild:
Fix dependency: app-admin/skey moved to sys-auth/skey.
diff --git a/sys-auth/pam_skey/pam_skey-1.1.5-r1.ebuild b/sys-auth/pam_skey/pam_skey-1.1.5-r1.ebuild
new file mode 100644
index 000000000000..808efd825d8e
--- /dev/null
+++ b/sys-auth/pam_skey/pam_skey-1.1.5-r1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/pam_skey/pam_skey-1.1.5-r1.ebuild,v 1.1 2010/02/05 21:08:29 ulm Exp $
+
+inherit eutils pam autotools multilib
+
+DESCRIPTION="PAM interface for the S/Key authentication system"
+HOMEPAGE="http://freshmeat.net/projects/pam_skey/"
+SRC_URI="http://dkorunic.net/tarballs/${P}.tar.gz
+ mirror://gentoo/${P}-gentoo-1.patch.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=">=sys-libs/pam-0.78-r3
+ >=sys-auth/skey-1.1.5-r4"
+RDEPEND="${DEPEND}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${WORKDIR}/${P}-gentoo-1.patch"
+
+ cd autoconf
+ eautoconf
+ eautoheader
+ mv configure defs.h.in .. || die "mv failed"
+}
+
+src_compile() {
+ econf --libdir="/$(get_libdir)" CFLAGS="${CFLAGS} -fPIC" \
+ || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "install failed"
+ dodoc README INSTALL
+}
+
+pkg_postinst() {
+ elog "To use this, you need to add something like"
+ elog
+ elog "auth [success=done ignore=ignore auth_err=die default=bad] pam_skey.so"
+ elog "auth sufficient pam_unix.so likeauth nullok try_first_pass"
+ elog
+ elog "to an appropriate place in /etc/pam.d/system-auth"
+ elog "Consult the documentation for instructions."
+}