summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2011-03-11 19:07:32 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2011-03-11 19:07:32 +0000
commite6d5e0e0209cfe12b254684c1d63d1d8d9724996 (patch)
tree3ca1f0784de1a5970eb9d8934152226c884adb77 /sys-auth
parentadd new polkit to glib mask (diff)
downloadgentoo-2-e6d5e0e0209cfe12b254684c1d63d1d8d9724996.tar.gz
gentoo-2-e6d5e0e0209cfe12b254684c1d63d1d8d9724996.tar.bz2
gentoo-2-e6d5e0e0209cfe12b254684c1d63d1d8d9724996.zip
Version bump.
(Portage version: 2.2.0_alpha26/cvs/Linux x86_64)
Diffstat (limited to 'sys-auth')
-rw-r--r--sys-auth/polkit/ChangeLog7
-rw-r--r--sys-auth/polkit/polkit-0.101.ebuild94
2 files changed, 100 insertions, 1 deletions
diff --git a/sys-auth/polkit/ChangeLog b/sys-auth/polkit/ChangeLog
index 0e06c607f7fd..6b6248edd9d7 100644
--- a/sys-auth/polkit/ChangeLog
+++ b/sys-auth/polkit/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-auth/polkit
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-auth/polkit/ChangeLog,v 1.37 2011/03/07 20:08:34 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/polkit/ChangeLog,v 1.38 2011/03/11 19:07:32 ssuominen Exp $
+
+*polkit-0.101 (11 Mar 2011)
+
+ 11 Mar 2011; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.101.ebuild:
+ Version bump.
07 Mar 2011; Jeroen Roovers <jer@gentoo.org> polkit-0.99-r1.ebuild:
Stable for HPPA (bug #354509).
diff --git a/sys-auth/polkit/polkit-0.101.ebuild b/sys-auth/polkit/polkit-0.101.ebuild
new file mode 100644
index 000000000000..a94273ba883a
--- /dev/null
+++ b/sys-auth/polkit/polkit-0.101.ebuild
@@ -0,0 +1,94 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/polkit/polkit-0.101.ebuild,v 1.1 2011/03/11 19:07:32 ssuominen Exp $
+
+EAPI=3
+inherit pam
+
+DESCRIPTION="Policy framework for controlling privileges for system-wide services"
+HOMEPAGE="http://hal.freedesktop.org/docs/polkit/"
+SRC_URI="http://hal.freedesktop.org/releases/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="debug doc examples gtk +introspection kde nls pam"
+
+RDEPEND=">=dev-libs/glib-2.28
+ dev-libs/expat
+ introspection? ( >=dev-libs/gobject-introspection-0.6.2 )
+ pam? ( virtual/pam )"
+DEPEND="${RDEPEND}
+ !!sys-auth/policykit
+ dev-libs/libxslt
+ app-text/docbook-xsl-stylesheets
+ dev-util/pkgconfig
+ >=dev-util/intltool-0.36
+ doc? ( >=dev-util/gtk-doc-1.13 )"
+PDEPEND=">=sys-auth/consolekit-0.4[policykit]
+ gtk? ( || ( >=gnome-extra/polkit-gnome-0.96-r1 lxde-base/lxpolkit ) )
+ kde? ( || ( sys-auth/polkit-kde-agent sys-auth/polkit-kde ) )"
+
+src_configure() {
+ local myauth="--with-authfw=shadow"
+ use pam && myauth="--with-authfw=pam --with-pam-module-dir=$(getpam_mod_dir)"
+
+ econf \
+ --localstatedir="${EPREFIX}"/var \
+ --disable-dependency-tracking \
+ --disable-static \
+ $(use_enable debug verbose-mode) \
+ --enable-man-pages \
+ $(use_enable doc gtk-doc) \
+ $(use_enable introspection) \
+ --disable-examples \
+ $(use_enable nls) \
+ --with-os-type=gentoo \
+ ${myauth}
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc docs/TODO HACKING NEWS README
+
+ find "${D}" -name '*.la' -exec rm -f {} +
+
+ # We disable example compilation above, and handle it here
+ if use examples; then
+ insinto /usr/share/doc/${PF}/examples
+ doins src/examples/{*.c,*.policy*}
+ fi
+
+ # Need to keep a few directories around...
+ diropts -m0700 -o root -g root
+ keepdir /var/run/polkit-1
+ keepdir /var/lib/polkit-1
+}
+
+pkg_postinst() {
+ # Make sure that the user has consolekit sessions working so that the
+ # 'allow_active' directive in polkit action policies works
+ if has_version 'gnome-base/gdm' && ! has_version 'gnome-base/gdm[consolekit]'; then
+ # If user has GDM installed, but USE=-consolekit, warn them
+ ewarn "You have GDM installed, but it does not have USE=consolekit"
+ ewarn "If you login using GDM, polkit authorizations will not work"
+ ewarn "unless you enable USE=consolekit"
+ einfo
+ fi
+ if has_version 'kde-base/kdm' && ! has_version 'kde-base/kdm[consolekit]'; then
+ # If user has KDM installed, but USE=-consolekit, warn them
+ ewarn "You have KDM installed, but it does not have USE=consolekit"
+ ewarn "If you login using KDM, polkit authorizations will not work"
+ ewarn "unless you enable USE=consolekit"
+ einfo
+ fi
+ if ! has_version 'gnome-base/gdm[consolekit]' && \
+ ! has_version 'kde-base/kdm[consolekit]'; then
+ # Inform user about the alternative method
+ ewarn "If you don't use GDM or KDM for logging in,"
+ ewarn "you must start your desktop environment (DE) as follows:"
+ ewarn " ck-launch-session \$STARTGUI"
+ ewarn "Where \$STARTGUI is a DE-starting command such as 'gnome-session'."
+ ewarn "You should add this to your ~/.xinitrc if you use startx."
+ fi
+}