summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2012-03-10 11:12:22 +0000
committerUlrich Müller <ulm@gentoo.org>2012-03-10 11:12:22 +0000
commitf069dfa4c694b0afb689db7131ba0c5d1a1e4d81 (patch)
tree0029d50d59f7aac1a3384cc696d7c34029046390 /sys-auth
parentinitial commit (based on ebuild by Francisco Javier, bug #223953) (diff)
downloadgentoo-2-f069dfa4c694b0afb689db7131ba0c5d1a1e4d81.tar.gz
gentoo-2-f069dfa4c694b0afb689db7131ba0c5d1a1e4d81.tar.bz2
gentoo-2-f069dfa4c694b0afb689db7131ba0c5d1a1e4d81.zip
Check for NULL pointer in response from conversation function, bug 407591.
(Portage version: 2.1.10.49/cvs/Linux x86_64)
Diffstat (limited to 'sys-auth')
-rw-r--r--sys-auth/pam_skey/ChangeLog7
-rw-r--r--sys-auth/pam_skey/pam_skey-1.1.5-r3.ebuild46
2 files changed, 52 insertions, 1 deletions
diff --git a/sys-auth/pam_skey/ChangeLog b/sys-auth/pam_skey/ChangeLog
index 3bb1e886005d..bb3dfea19a84 100644
--- a/sys-auth/pam_skey/ChangeLog
+++ b/sys-auth/pam_skey/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-auth/pam_skey
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-auth/pam_skey/ChangeLog,v 1.18 2012/01/06 21:13:27 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/pam_skey/ChangeLog,v 1.19 2012/03/10 11:12:22 ulm Exp $
+
+*pam_skey-1.1.5-r3 (10 Mar 2012)
+
+ 10 Mar 2012; Ulrich Müller <ulm@gentoo.org> +pam_skey-1.1.5-r3.ebuild:
+ Check for NULL pointer in response from conversation function, bug 407591.
06 Jan 2012; Ulrich Mueller <ulm@gentoo.org> pam_skey-1.1.5-r2.ebuild:
New patchset with long pending typo fix. Update to EAPI 4.
diff --git a/sys-auth/pam_skey/pam_skey-1.1.5-r3.ebuild b/sys-auth/pam_skey/pam_skey-1.1.5-r3.ebuild
new file mode 100644
index 000000000000..cffc3b406f5a
--- /dev/null
+++ b/sys-auth/pam_skey/pam_skey-1.1.5-r3.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/pam_skey/pam_skey-1.1.5-r3.ebuild,v 1.1 2012/03/10 11:12:22 ulm Exp $
+
+EAPI=4
+
+inherit eutils pam autotools multilib
+
+DESCRIPTION="PAM interface for the S/Key authentication system"
+HOMEPAGE="http://freshmeat.net/projects/pam_skey/"
+SRC_URI="http://dkorunic.net/tarballs/${P}.tar.gz
+ mirror://gentoo/${P}-patches-4.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=sys-libs/pam-0.78-r3
+ >=sys-auth/skey-1.1.5-r4"
+DEPEND="${RDEPEND}
+ app-arch/xz-utils"
+
+DOCS="README INSTALL"
+
+src_prepare() {
+ EPATCH_SUFFIX=patch epatch
+
+ cd autoconf
+ eautoconf
+ eautoheader
+ mv configure defs.h.in .. || die "mv failed"
+}
+
+src_configure() {
+ econf --libdir="/$(get_libdir)" CFLAGS="${CFLAGS} -fPIC"
+}
+
+pkg_postinst() {
+ elog "To use this, you need to add a line like:"
+ elog
+ elog "auth [success=done ignore=ignore auth_err=die default=bad] pam_skey.so"
+ elog
+ elog "to an appropriate place in /etc/pam.d/system-auth"
+ elog "Consult the documentation for instructions."
+}