summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHanno Böck <hanno@gentoo.org>2008-06-02 14:35:45 +0000
committerHanno Böck <hanno@gentoo.org>2008-06-02 14:35:45 +0000
commitfaaa9e399690689f688cae9191aba28962d99174 (patch)
treed8c59e09bef4821299f705679a13cb51f7a1afd8 /sys-auth
parentlibhx bump (diff)
downloadgentoo-2-faaa9e399690689f688cae9191aba28962d99174.tar.gz
gentoo-2-faaa9e399690689f688cae9191aba28962d99174.tar.bz2
gentoo-2-faaa9e399690689f688cae9191aba28962d99174.zip
pam_mount version bump
(Portage version: 2.1.5.3)
Diffstat (limited to 'sys-auth')
-rw-r--r--sys-auth/pam_mount/ChangeLog7
-rw-r--r--sys-auth/pam_mount/pam_mount-0.39.ebuild36
2 files changed, 42 insertions, 1 deletions
diff --git a/sys-auth/pam_mount/ChangeLog b/sys-auth/pam_mount/ChangeLog
index 5781e2344ed3..99892bc1d95e 100644
--- a/sys-auth/pam_mount/ChangeLog
+++ b/sys-auth/pam_mount/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-auth/pam_mount
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-auth/pam_mount/ChangeLog,v 1.15 2008/05/20 20:43:14 hanno Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/pam_mount/ChangeLog,v 1.16 2008/06/02 14:35:45 hanno Exp $
+
+*pam_mount-0.39 (02 Jun 2008)
+
+ 02 Jun 2008; Hanno Boeck <hanno@gentoo.org> +pam_mount-0.39.ebuild:
+ Version bump.
*pam_mount-0.38 (20 May 2008)
diff --git a/sys-auth/pam_mount/pam_mount-0.39.ebuild b/sys-auth/pam_mount/pam_mount-0.39.ebuild
new file mode 100644
index 000000000000..b577d45799ec
--- /dev/null
+++ b/sys-auth/pam_mount/pam_mount-0.39.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/pam_mount/pam_mount-0.39.ebuild,v 1.1 2008/06/02 14:35:45 hanno Exp $
+
+inherit multilib
+
+DESCRIPTION="A PAM module that can mount volumes for a user session"
+HOMEPAGE="http://pam-mount.sourceforge.net"
+SRC_URI="mirror://sourceforge/pam-mount/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+IUSE="crypt"
+DEPEND=">=sys-libs/pam-0.72
+ dev-libs/openssl
+ >=sys-libs/libhx-1.17
+ dev-libs/libxml2
+ dev-util/pkgconfig"
+RDEPEND=">=sys-libs/pam-0.72
+ dev-libs/openssl
+ >=sys-libs/libhx-1.17
+ dev-libs/libxml2
+ >=sys-fs/cryptsetup-1.0.5
+ sys-process/lsof"
+
+src_compile() {
+ econf --with-slibdir="/$(get_libdir)" || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install failed"
+ dodoc doc/*.txt || die "dodoc failed"
+}