summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2013-04-11 07:17:05 +0000
committerMatthew Thode <prometheanfire@gentoo.org>2013-04-11 07:17:05 +0000
commitfc418e18ac20226db59a105d27e2afa4693cbec1 (patch)
tree7868139bc00add9123e4a2c3d8e0953623496d8f /sys-auth
parentDependency fix for #398123 (diff)
downloadgentoo-2-fc418e18ac20226db59a105d27e2afa4693cbec1.tar.gz
gentoo-2-fc418e18ac20226db59a105d27e2afa4693cbec1.tar.bz2
gentoo-2-fc418e18ac20226db59a105d27e2afa4693cbec1.zip
updating keystone 9999 to have better deps
(Portage version: 2.1.11.55/cvs/Linux x86_64, signed Manifest commit with key 0x2471eb3e40ac5ac3)
Diffstat (limited to 'sys-auth')
-rw-r--r--sys-auth/keystone/ChangeLog5
-rw-r--r--sys-auth/keystone/keystone-9999.ebuild40
2 files changed, 27 insertions, 18 deletions
diff --git a/sys-auth/keystone/ChangeLog b/sys-auth/keystone/ChangeLog
index 68d256b4d16f..83ff0181e29f 100644
--- a/sys-auth/keystone/ChangeLog
+++ b/sys-auth/keystone/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for sys-auth/keystone
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-auth/keystone/ChangeLog,v 1.12 2013/04/10 16:12:49 prometheanfire Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/keystone/ChangeLog,v 1.13 2013/04/11 07:17:05 prometheanfire Exp $
+
+ 11 Apr 2013; Matthew Thode <prometheanfire@gentoo.org> keystone-9999.ebuild:
+ updating keystone 9999 to have better deps
*keystone-2013.1 (10 Apr 2013)
diff --git a/sys-auth/keystone/keystone-9999.ebuild b/sys-auth/keystone/keystone-9999.ebuild
index e02bad94f602..e7d91aca79f8 100644
--- a/sys-auth/keystone/keystone-9999.ebuild
+++ b/sys-auth/keystone/keystone-9999.ebuild
@@ -1,11 +1,11 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-auth/keystone/keystone-9999.ebuild,v 1.7 2013/01/18 07:34:03 prometheanfire Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/keystone/keystone-9999.ebuild,v 1.8 2013/04/11 07:17:05 prometheanfire Exp $
EAPI=5
#test restricted becaues of bad requirements given (old webob for instance)
RESTRICT="test"
-PYTHON_COMPAT=( python2_6 python2_7 )
+PYTHON_COMPAT=( python2_7 )
inherit git-2 distutils-r1
@@ -15,7 +15,7 @@ HOMEPAGE="https://launchpad.net/keystone"
EGIT_REPO_URI="https://github.com/openstack/keystone.git"
LICENSE="Apache-2.0"
-SLOT="folsom"
+SLOT="git-head"
KEYWORDS=""
IUSE="+sqlite mysql postgres ldap"
#IUSE="+sqlite mysql postgres ldap test"
@@ -24,23 +24,29 @@ REQUIRED_USE="|| ( ldap mysql postgres sqlite )"
#todo, seperate out rdepend via use flags
DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
RDEPEND="${DEPEND}
- dev-python/eventlet
- dev-python/greenlet
- dev-python/iso8601[${PYTHON_USEDEP}]
+ dev-python/eventlet[${PYTHON_USEDEP}]
+ dev-python/greenlet[${PYTHON_USEDEP}]
+ >=dev-python/iso8601-0.1.4[${PYTHON_USEDEP}]
+ >=dev-python/python-keystoneclient-0.2.1[${PYTHON_USEDEP}]
+ <=dev-python/python-keystoneclient-0.3[${PYTHON_USEDEP}]
dev-python/lxml[${PYTHON_USEDEP}]
- dev-python/passlib
- dev-python/paste
- dev-python/pastedeploy
+ >=dev-python/oslo-config-1.1.0[${PYTHON_USEDEP}]
+ dev-python/passlib[${PYTHON_USEDEP}]
+ dev-python/paste[${PYTHON_USEDEP}]
+ dev-python/pastedeploy[${PYTHON_USEDEP}]
dev-python/python-daemon
- dev-python/python-pam[${PYTHON_USEDEP}]
- dev-python/routes
- >=dev-python/sqlalchemy-migrate-0.7
- >=dev-python/webob-1.0.8
+ >=dev-python/python-pam-0.1.4[${PYTHON_USEDEP}]
+ dev-python/routes[${PYTHON_USEDEP}]
+ >=dev-python/sqlalchemy-migrate-0.7.2
+ =dev-python/webob-1.2.3-r1[${PYTHON_USEDEP}]
virtual/python-argparse[${PYTHON_USEDEP}]
- sqlite? ( dev-python/sqlalchemy[sqlite] )
- mysql? ( dev-python/sqlalchemy[mysql] )
- postgres? ( dev-python/sqlalchemy[postgres] )
- ldap? ( dev-python/python-ldap )"
+ sqlite? ( >=dev-python/sqlalchemy-0.7.8[sqlite]
+ <=dev-python/sqlalchemy-0.7.9[sqlite] )
+ mysql? ( >=dev-python/sqlalchemy-0.7.8[mysql]
+ <=dev-python/sqlalchemy-0.7.9[mysql] )
+ postgres? ( >=dev-python/sqlalchemy-0.7.8[postgres]
+ <=dev-python/sqlalchemy-0.7.9[postgres] )
+ ldap? ( dev-python/python-ldap[${PYTHON_USEDEP}] )"
# test? ( dev-python/Babel
# dev-python/decorator
# dev-python/eventlet