summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2009-06-27 13:26:10 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2009-06-27 13:26:10 +0000
commit3a16cd32ba6335c551b67c6b6c9dbb931b26f6c0 (patch)
tree1f383449007e3983fb2f2267ec58b13704bff0f5 /sys-block/unieject
parentStable on alpha, bug #274554 (diff)
downloadgentoo-2-3a16cd32ba6335c551b67c6b6c9dbb931b26f6c0.tar.gz
gentoo-2-3a16cd32ba6335c551b67c6b6c9dbb931b26f6c0.tar.bz2
gentoo-2-3a16cd32ba6335c551b67c6b6c9dbb931b26f6c0.zip
Version bump, the new version uses glib and has been slightly optimised. It also reduces warnings with GCC 4.4 and works fine on FreeBSD 7 (no more bashism in configure), closing bug #275584.
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'sys-block/unieject')
-rw-r--r--sys-block/unieject/ChangeLog11
-rw-r--r--sys-block/unieject/unieject-6.ebuild76
2 files changed, 85 insertions, 2 deletions
diff --git a/sys-block/unieject/ChangeLog b/sys-block/unieject/ChangeLog
index 5da269fa1d93..529d387d7311 100644
--- a/sys-block/unieject/ChangeLog
+++ b/sys-block/unieject/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-block/unieject
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-block/unieject/ChangeLog,v 1.45 2008/08/08 06:28:16 ulm Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-block/unieject/ChangeLog,v 1.46 2009/06/27 13:26:10 flameeyes Exp $
+
+*unieject-6 (27 Jun 2009)
+
+ 27 Jun 2009; Diego E. Pettenò <flameeyes@gentoo.org> +unieject-6.ebuild:
+ Version bump, the new version uses glib and has been slightly optimised.
+ It also reduces warnings with GCC 4.4 and works fine on FreeBSD 7 (no more
+ bashism in configure), closing bug #275584.
08 Aug 2008; Ulrich Mueller <ulm@gentoo.org> metadata.xml:
Add USE flag description to metadata wrt GLEP 56.
diff --git a/sys-block/unieject/unieject-6.ebuild b/sys-block/unieject/unieject-6.ebuild
new file mode 100644
index 000000000000..dfa564c44240
--- /dev/null
+++ b/sys-block/unieject/unieject-6.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-block/unieject/unieject-6.ebuild,v 1.1 2009/06/27 13:26:10 flameeyes Exp $
+
+inherit eutils libtool
+
+DESCRIPTION="Multiplatform command to eject and load CD-Rom drives"
+HOMEPAGE="http://www.flameeyes.eu/projects#unieject"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~sparc-fbsd ~x86-fbsd"
+IUSE="nls pmount"
+
+RDEPEND=">=dev-libs/libcdio-0.77
+ >=dev-libs/glib-2.6
+ >=dev-libs/confuse-2.5
+ nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )
+ sys-apps/sed
+ dev-util/pkgconfig"
+RDEPEND="${RDEPEND}
+ pmount? ( sys-apps/pmount )
+ !sys-apps/eject
+ !sys-block/eject-bsd"
+
+PROVIDE="virtual/eject"
+
+pkg_setup() {
+ use pmount && enewgroup plugdev
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ elibtoolize
+}
+
+src_compile() {
+ econf \
+ $(use_enable nls) \
+ --enable-lock-workaround \
+ --disable-dependency-tracking \
+ --disable-doc \
+ --htmldir=/usr/share/doc/${PF}/html \
+ --docdir=/usr/share/doc/${PF} \
+ || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ find "${D}" -name '*.la' -delete
+
+ # Symlink to eject to provide a good virtual/eject
+ dosym unieject.1 /usr/share/man/man1/eject.1 || die
+ dosym unieject /usr/bin/eject || die
+
+ # If we enable support for pmount, we need to change the installed
+ # configuration file to enable the unmount wrapper, and we also set the
+ # command setuid root but in group plugdev, so that it's inlined with pmount
+ # itself.
+ if use pmount; then
+ fowners root:plugdev /usr/bin/unieject
+ fperms 1710 /usr/bin/unieject
+ chmod +s "${D}/usr/bin/unieject"
+
+ dodir /etc
+ sed -e 's:^# \(unmount-wrapper = \):\1:' \
+ "${S}/unieject.conf.sample" \
+ > "${D}/etc/unieject.conf"
+ fi
+}