summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2006-07-22 19:51:57 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2006-07-22 19:51:57 +0000
commitd15f83e86c400a40f0674a3782bf857fa2ab1800 (patch)
treef34458a5af6958db920e968c317501b3da4650d5 /sys-block/vblade/vblade-10-r2.ebuild
parentRemove mask on PulseAudio. (diff)
downloadgentoo-2-d15f83e86c400a40f0674a3782bf857fa2ab1800.tar.gz
gentoo-2-d15f83e86c400a40f0674a3782bf857fa2ab1800.tar.bz2
gentoo-2-d15f83e86c400a40f0674a3782bf857fa2ab1800.zip
Bug 141392, fix another blip in the init script.
(Portage version: 2.1.1_pre3-r1)
Diffstat (limited to 'sys-block/vblade/vblade-10-r2.ebuild')
-rw-r--r--sys-block/vblade/vblade-10-r2.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/sys-block/vblade/vblade-10-r2.ebuild b/sys-block/vblade/vblade-10-r2.ebuild
new file mode 100644
index 000000000000..28f85f8395ed
--- /dev/null
+++ b/sys-block/vblade/vblade-10-r2.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-block/vblade/vblade-10-r2.ebuild,v 1.1 2006/07/22 19:51:57 robbat2 Exp $
+
+inherit eutils
+
+DESCRIPTION="vblade exports a block device using AoE"
+HOMEPAGE="http://sf.net/projects/aoetools/"
+SRC_URI="mirror://sourceforge/aoetools/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE=""
+DEPEND="virtual/libc"
+RDEPEND="${DEPEND}
+ sys-apps/util-linux"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ # messy tarball
+ make clean || die "Failed to clean up source"
+ sed -i 's,^CFLAGS.*,CFLAGS += -Wall,' makefile || die "Failed to clean up makefile"
+}
+src_compile() {
+ emake || die "emake failed"
+}
+
+src_install() {
+ into /usr
+ doman vblade.8
+ dodoc HACKING NEWS README
+ dosbin vblade
+ dosbin ${FILESDIR}/vbladed
+ newconfd ${FILESDIR}/conf.d-vblade vblade
+ newinitd ${FILESDIR}/init.d-vblade.vblade0 vblade.vblade0
+}
+
+pkg_postinst() {
+ einfo "We do now include an init.d script, please look in your init.d and"
+ einfo "conf.d directories for it."
+}