summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2006-01-25 06:17:55 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2006-01-25 06:17:55 +0000
commit5365a6ea04635539cec0cac0399e7d02ad3d6527 (patch)
treeea789d1b3007327b8389c10fad4a1e564cd2eeeb /sys-block/vblade/vblade-10.ebuild
parentAdd a pre version for people to play with #119734 by Matthew Schick. (diff)
downloadgentoo-2-5365a6ea04635539cec0cac0399e7d02ad3d6527.tar.gz
gentoo-2-5365a6ea04635539cec0cac0399e7d02ad3d6527.tar.bz2
gentoo-2-5365a6ea04635539cec0cac0399e7d02ad3d6527.zip
Version bump, bug #118594. Also now includes init scripts, partially based on a submission by Markus Wagner <markus1108wagner@t-online.de>.
(Portage version: 2.1_pre3-r1)
Diffstat (limited to 'sys-block/vblade/vblade-10.ebuild')
-rw-r--r--sys-block/vblade/vblade-10.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/sys-block/vblade/vblade-10.ebuild b/sys-block/vblade/vblade-10.ebuild
new file mode 100644
index 000000000000..299ed28445db
--- /dev/null
+++ b/sys-block/vblade/vblade-10.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-block/vblade/vblade-10.ebuild,v 1.1 2006/01/25 06:17:55 robbat2 Exp $
+
+inherit eutils
+
+DESCRIPTION="vblade exports a block device using AoE"
+HOMEPAGE="http://sf.net/projects/aoetools/"
+SRC_URI="mirror://sourceforge/aoetools/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+DEPEND="virtual/libc"
+RDEPEND="${DEPEND}
+ sys-apps/util-linux"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ # messy tarball
+ make clean || die "Failed to clean up source"
+ sed -i 's,^CFLAGS.*,CFLAGS += -Wall,' makefile || die "Failed to clean up makefile"
+}
+src_compile() {
+ emake || die "emake failed"
+}
+
+src_install() {
+ into /usr
+ doman vblade.8
+ dodoc HACKING NEWS README
+ dosbin vblade
+ dosbin ${FILESDIR}/vbladed
+ newconfd ${FILESDIR}/conf.d-vblade vblade
+ newinitd ${FILESDIR}/init.d-vblade.vblade0 vblade.vblade0
+}
+
+pkg_postinst() {
+ einfo "We do now include an init.d script, please look in your init.d and"
+ einfo "conf.d directories for it."
+}