summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCaleb Tennis <caleb@gentoo.org>2008-08-03 23:53:20 +0000
committerCaleb Tennis <caleb@gentoo.org>2008-08-03 23:53:20 +0000
commit3ca3b9bd1ef77f191d93cc7ec200a260b6f1daed (patch)
tree0c88f8deae2d9e498e9a9cb8f5babc7aa9446e62 /sys-block/vblade/vblade-18.ebuild
parentclean up old revisions, drop to ~mips to shut up repoman's warnings. (diff)
downloadgentoo-2-3ca3b9bd1ef77f191d93cc7ec200a260b6f1daed.tar.gz
gentoo-2-3ca3b9bd1ef77f191d93cc7ec200a260b6f1daed.tar.bz2
gentoo-2-3ca3b9bd1ef77f191d93cc7ec200a260b6f1daed.zip
version bump
(Portage version: 2.1.5.2)
Diffstat (limited to 'sys-block/vblade/vblade-18.ebuild')
-rw-r--r--sys-block/vblade/vblade-18.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/sys-block/vblade/vblade-18.ebuild b/sys-block/vblade/vblade-18.ebuild
new file mode 100644
index 000000000000..dcbea3cd3814
--- /dev/null
+++ b/sys-block/vblade/vblade-18.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-block/vblade/vblade-18.ebuild,v 1.1 2008/08/03 23:53:19 caleb Exp $
+
+inherit eutils
+
+DESCRIPTION="vblade exports a block device using AoE"
+HOMEPAGE="http://sf.net/projects/aoetools/"
+#SRC_URI="mirror://sourceforge/aoetools/${P}.tar.gz"
+SRC_URI="mirror://sourceforge/aoetools/${P}.tgz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE=""
+DEPEND="virtual/libc"
+RDEPEND="${DEPEND}
+ sys-apps/util-linux"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ # messy tarball
+ make clean || die "Failed to clean up source"
+ sed -i 's,^CFLAGS.*,CFLAGS += -Wall,' makefile || die "Failed to clean up makefile"
+}
+src_compile() {
+ emake || die "emake failed"
+}
+
+src_install() {
+ into /usr
+ doman vblade.8
+ dodoc HACKING NEWS README
+ dosbin vblade
+ dosbin "${FILESDIR}"/vbladed
+ newconfd "${FILESDIR}"/conf.d-vblade vblade
+ newinitd "${FILESDIR}"/init.d-vblade.vblade0 vblade.vblade0
+}