summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Scherbaum <dertobi123@gentoo.org>2009-10-28 16:47:54 +0000
committerTobias Scherbaum <dertobi123@gentoo.org>2009-10-28 16:47:54 +0000
commit14ad9f3a2404cf22990d00b4d6705bc35340f8eb (patch)
tree94e83ff2059e37f359f7f387ab36c8e96c8df5bc /sys-block
parentwhitespace (diff)
downloadgentoo-2-14ad9f3a2404cf22990d00b4d6705bc35340f8eb.tar.gz
gentoo-2-14ad9f3a2404cf22990d00b4d6705bc35340f8eb.tar.bz2
gentoo-2-14ad9f3a2404cf22990d00b4d6705bc35340f8eb.zip
Bump, proxy-committing for Craig (#278589)
(Portage version: 2.2_rc46/cvs/Linux x86_64)
Diffstat (limited to 'sys-block')
-rw-r--r--sys-block/open-iscsi/ChangeLog10
-rw-r--r--sys-block/open-iscsi/open-iscsi-2.0.871.ebuild110
2 files changed, 118 insertions, 2 deletions
diff --git a/sys-block/open-iscsi/ChangeLog b/sys-block/open-iscsi/ChangeLog
index 2a5f76a9a8ff..1a4a9c61bf54 100644
--- a/sys-block/open-iscsi/ChangeLog
+++ b/sys-block/open-iscsi/ChangeLog
@@ -1,13 +1,19 @@
# ChangeLog for sys-block/open-iscsi
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-block/open-iscsi/ChangeLog,v 1.22 2009/10/27 19:47:34 dertobi123 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-block/open-iscsi/ChangeLog,v 1.23 2009/10/28 16:47:54 dertobi123 Exp $
+
+*open-iscsi-2.0.871 (28 Oct 2009)
+
+ 28 Oct 2009; Tobias Scherbaum <dertobi123@gentoo.org>
+ +open-iscsi-2.0.871.ebuild:
+ Bump, proxy-committing for Craig (#278589)
*open-iscsi-2.0.870.3-r1 (27 Oct 2009)
27 Oct 2009; Tobias Scherbaum <dertobi123@gentoo.org>
-open-iscsi-2.0.870.3.ebuild, +open-iscsi-2.0.870.3-r1.ebuild,
+files/CVE-2009-1297.patch:
- Revbump, proxy-commiting for Craig (security bug #290631)
+ Revbump, proxy-committing for Craig (security bug #290631)
23 Sep 2009; Patrick Lauer <patrick@gentoo.org>
open-iscsi-2.0.870.3.ebuild:
diff --git a/sys-block/open-iscsi/open-iscsi-2.0.871.ebuild b/sys-block/open-iscsi/open-iscsi-2.0.871.ebuild
new file mode 100644
index 000000000000..7fd785bd7a81
--- /dev/null
+++ b/sys-block/open-iscsi/open-iscsi-2.0.871.ebuild
@@ -0,0 +1,110 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-block/open-iscsi/open-iscsi-2.0.871.ebuild,v 1.1 2009/10/28 16:47:54 dertobi123 Exp $
+
+inherit versionator linux-mod eutils flag-o-matic
+
+DESCRIPTION="Open-iSCSI is a high performance, transport independent, multi-platform implementation of RFC3720"
+HOMEPAGE="http://www.open-iscsi.org/"
+MY_PV="${PN}-$(replace_version_separator 2 "-" $MY_PV)"
+SRC_URI="http://www.open-iscsi.org/bits/${MY_PV}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64 ~ppc ~mips"
+IUSE="utils debug"
+DEPEND="virtual/linux-sources"
+RDEPEND="${DEPEND}
+ sys-apps/util-linux"
+
+S="${WORKDIR}/${MY_PV}"
+
+MODULE_NAMES_ARG="kernel/drivers/scsi:${S}/kernel"
+MODULE_NAMES="iscsi_tcp(${MODULE_NAMES_ARG}) scsi_transport_iscsi(${MODULE_NAMES_ARG}) libiscsi(${MODULE_NAMES_ARG})"
+BUILD_TARGETS="all"
+CONFIG_CHECK="CRYPTO_CRC32C"
+CONFIG_CHECK_MODULES="SCSI_ISCSI_ATTRS ISCSI_TCP"
+ERROR_CFG="open-iscsi needs CRC32C support in your kernel."
+
+pkg_setup() {
+ linux-info_pkg_setup
+ linux-mod_pkg_setup
+
+ # Needs to be done, as iscsid currently only starts, when having the iSCSI
+ # support loaded as module. Kernel builtion options don't work. See this for
+ # more information:
+ # http://groups.google.com/group/open-iscsi/browse_thread/thread/cc10498655b40507/fd6a4ba0c8e91966
+ # If there's a new release, check whether this is still valid!
+
+ for module in ${CONFIG_CHECK_MODULES}; do
+ linux_chkconfig_module ${module} || die "${module} needs to be built as module (builtin doesn't work)"
+ done
+}
+
+src_unpack() {
+ unpack ${A}
+ export EPATCH_OPTS="-d${S}"
+ if [ $KV_PATCH -lt 15 ]; then
+ die "Sorry, your kernel must be 2.6.16-rc5 or newer!"
+ fi
+ epatch "${FILESDIR}"/CVE-2009-1297.patch
+}
+
+src_compile() {
+ use debug && append-flags -DDEBUG_TCP -DDEBUG_SCSI
+
+ einfo "Building userspace"
+ cd "${S}" && \
+ CFLAGS="" emake OPTFLAGS="${CFLAGS}" user \
+ || die "emake failed"
+}
+
+src_install() {
+ einfo "Installing userspace"
+ dosbin usr/iscsid usr/iscsiadm usr/iscsistart
+
+ if use utils; then
+ einfo "Installing utilities"
+ dosbin utils/iscsi-iname utils/iscsi_discovery
+ fi
+
+ einfo "Installing docs"
+ doman doc/*[1-8]
+ dodoc README THANKS
+ docinto test
+ dodoc test/*
+
+ einfo "Installing configuration"
+ insinto /etc/iscsi
+ doins etc/iscsid.conf
+ insinto /etc/iscsi/ifaces
+ doins etc/iface.example
+
+ # only contains iscsi initiatorname, no need to update
+ if [ ! -e /etc/iscsi/initiatorname.iscsi ]; then
+ doins "${FILESDIR}"/initiatorname.iscsi
+ fi
+
+ # if there is a special conf.d for this version, use it
+ # otherwise, use the default: iscsid-conf.d
+ insinto /etc/conf.d
+ if [ -e "${FILESDIR}"/iscsid-${PV}.conf.d ]; then
+ newins "${FILESDIR}"/iscsid-${PV}.conf.d iscsid
+ else
+ newins "${FILESDIR}"/iscsid-conf.d iscsid
+ fi
+
+ # same for init.d
+ if [ -e "${FILESDIR}"/iscsid-${PV}.init.d ]; then
+ newinitd "${FILESDIR}"/iscsid-${PV}.init.d iscsid
+ else
+ newinitd "${FILESDIR}"/iscsid-init.d iscsid
+ fi
+
+ keepdir /var/db/iscsi
+ fperms 700 /var/db/iscsi
+ fperms 600 /etc/iscsi/iscsid.conf
+}
+
+pkg_postinst() {
+ linux-mod_pkg_postinst
+}