summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2010-01-10 14:11:34 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2010-01-10 14:11:34 +0000
commit9e353b3ce87048d09c71d5a91e155063efb8323e (patch)
treea73cbc28249fc0b83718c5c32d838bfef4bc6c6f /sys-block
parentRevision bump for Prefix fix and transfer of Prefix keywords, bug #294758 (diff)
downloadgentoo-2-9e353b3ce87048d09c71d5a91e155063efb8323e.tar.gz
gentoo-2-9e353b3ce87048d09c71d5a91e155063efb8323e.tar.bz2
gentoo-2-9e353b3ce87048d09c71d5a91e155063efb8323e.zip
Version bump; fix building when portage shell is set to /bin/false (bug #268605).
(Portage version: 2.2_rc61/cvs/Linux x86_64)
Diffstat (limited to 'sys-block')
-rw-r--r--sys-block/di/ChangeLog11
-rw-r--r--sys-block/di/di-4.13.ebuild9
-rw-r--r--sys-block/di/di-4.18.ebuild32
3 files changed, 47 insertions, 5 deletions
diff --git a/sys-block/di/ChangeLog b/sys-block/di/ChangeLog
index 20fec1cf47f9..c9aa059232db 100644
--- a/sys-block/di/ChangeLog
+++ b/sys-block/di/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-block/di
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-block/di/ChangeLog,v 1.22 2009/04/23 19:36:43 maekke Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-block/di/ChangeLog,v 1.23 2010/01/10 14:11:34 flameeyes Exp $
+
+*di-4.18 (10 Jan 2010)
+
+ 10 Jan 2010; Diego E. Pettenò <flameeyes@gentoo.org> di-4.13.ebuild,
+ +di-4.18.ebuild:
+ Version bump; fix building when portage shell is set to /bin/false (bug
+ #268605).
23 Apr 2009; Markus Meier <maekke@gentoo.org> di-4.13:
amd64 stable, bug #264123
diff --git a/sys-block/di/di-4.13.ebuild b/sys-block/di/di-4.13.ebuild
index 560c6d2a2403..2d889b504b6b 100644
--- a/sys-block/di/di-4.13.ebuild
+++ b/sys-block/di/di-4.13.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-block/di/di-4.13.ebuild,v 1.5 2009/04/23 19:36:43 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-block/di/di-4.13.ebuild,v 1.6 2010/01/10 14:11:34 flameeyes Exp $
inherit toolchain-funcs
@@ -18,7 +18,10 @@ RDEPEND=""
src_compile() {
tc-export CC
- SHELL=/bin/bash prefix="${D}" ${SHELL} ./Build || die
+ # execute it _with bash_; setting SHELL=/bin/bash ${SHELL} won't
+ # work because the command is interpreted _before_ the SHELL is
+ # set. And this does not work properly as a standard sh script.
+ SHELL=/bin/bash prefix="${D}" bash ./Build || die
}
src_install() {
diff --git a/sys-block/di/di-4.18.ebuild b/sys-block/di/di-4.18.ebuild
new file mode 100644
index 000000000000..e8c999f3fcb1
--- /dev/null
+++ b/sys-block/di/di-4.18.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-block/di/di-4.18.ebuild,v 1.1 2010/01/10 14:11:34 flameeyes Exp $
+
+inherit toolchain-funcs
+
+DESCRIPTION="Disk Information Utility"
+HOMEPAGE="http://www.gentoo.com/di/"
+SRC_URI="http://www.gentoo.com/di/${P}.tar.gz"
+
+LICENSE="ZLIB"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~x86 ~x86-fbsd"
+IUSE=""
+
+DEPEND="app-shells/bash"
+RDEPEND=""
+
+src_compile() {
+ tc-export CC
+ # execute it _with bash_; setting SHELL=/bin/bash ${SHELL} won't
+ # work because the command is interpreted _before_ the SHELL is
+ # set. And this does not work properly as a standard sh script.
+ SHELL=/bin/bash prefix="${D}" bash ./Build || die
+}
+
+src_install() {
+ doman di.1
+ dobin di || die
+ dosym di /usr/bin/mi
+ dodoc README
+}