summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2006-11-23 11:10:24 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2006-11-23 11:10:24 +0000
commitb37b8f0e43c9348b6d0d289c2d62b53790f25260 (patch)
tree23823e1614b3011c3a77a3d4ee3353a36143fe9e /sys-block
parentStable on hppa. (diff)
downloadgentoo-2-b37b8f0e43c9348b6d0d289c2d62b53790f25260.tar.gz
gentoo-2-b37b8f0e43c9348b6d0d289c2d62b53790f25260.tar.bz2
gentoo-2-b37b8f0e43c9348b6d0d289c2d62b53790f25260.zip
New major version from upstream to support 9650SE hardware.
(Portage version: 2.1.2_rc1-r7)
Diffstat (limited to 'sys-block')
-rw-r--r--sys-block/tw_cli/ChangeLog7
-rw-r--r--sys-block/tw_cli/files/digest-tw_cli-9.4.06
-rw-r--r--sys-block/tw_cli/tw_cli-9.4.0.ebuild72
3 files changed, 84 insertions, 1 deletions
diff --git a/sys-block/tw_cli/ChangeLog b/sys-block/tw_cli/ChangeLog
index a3e7638f4917..2e27867deceb 100644
--- a/sys-block/tw_cli/ChangeLog
+++ b/sys-block/tw_cli/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-block/tw_cli
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-block/tw_cli/ChangeLog,v 1.10 2006/09/13 00:13:07 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-block/tw_cli/ChangeLog,v 1.11 2006/11/23 11:10:24 robbat2 Exp $
+
+*tw_cli-9.4.0 (23 Nov 2006)
+
+ 23 Nov 2006; Robin H. Johnson <robbat2@gentoo.org> +tw_cli-9.4.0.ebuild:
+ New major version from upstream to support 9650SE hardware.
*tw_cli-9.3.0.4 (13 Sep 2006)
diff --git a/sys-block/tw_cli/files/digest-tw_cli-9.4.0 b/sys-block/tw_cli/files/digest-tw_cli-9.4.0
new file mode 100644
index 000000000000..421ccacf6187
--- /dev/null
+++ b/sys-block/tw_cli/files/digest-tw_cli-9.4.0
@@ -0,0 +1,6 @@
+MD5 a4953330ea917cf847405db9c059cde4 tw_cli-linux-x86-9.4.0.tgz 788856
+RMD160 51fbcd7f4981570ca1fe6f5beb7f94ff65d1afa2 tw_cli-linux-x86-9.4.0.tgz 788856
+SHA256 445899d9034076ca4665183017db587dea76208dbb066ea05ec4932950b9b086 tw_cli-linux-x86-9.4.0.tgz 788856
+MD5 b374510369d99dfe1bd7b7ee727f58c8 tw_cli-linux-x86_64-9.4.0.tgz 820535
+RMD160 56f1d4f8589aafa5f5b62bcbe2592f98a73c2272 tw_cli-linux-x86_64-9.4.0.tgz 820535
+SHA256 d91f861d447d49db97d24564f9458be2123ef20554ca2d2190e4b4c6fd2ff713 tw_cli-linux-x86_64-9.4.0.tgz 820535
diff --git a/sys-block/tw_cli/tw_cli-9.4.0.ebuild b/sys-block/tw_cli/tw_cli-9.4.0.ebuild
new file mode 100644
index 000000000000..a762ccb02a75
--- /dev/null
+++ b/sys-block/tw_cli/tw_cli-9.4.0.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-block/tw_cli/tw_cli-9.4.0.ebuild,v 1.1 2006/11/23 11:10:24 robbat2 Exp $
+
+DESCRIPTION="3ware SATA+PATA RAID controller Command Line Interface tool"
+HOMEPAGE="http://www.3ware.com/"
+LICENSE="3ware"
+SLOT="0"
+# binary packages
+KEYWORDS="-* ~x86 ~amd64"
+IUSE=""
+# stripping seems to break this sometimes
+RESTRICT="fetch nostrip nomirror"
+# binary packages
+DEPEND=""
+RDEPEND="virtual/libc"
+MY_P="${PN}-linux-${ARCH/amd64/x86_64}-${PV}"
+# Upstream actually only releases newer versions for new hardware
+# and doesn't release new major versions for old hardware
+# however their backwards compatibility is excellent.
+# I personally test tw_cli on two cards: 6200 (amd64) and 7006-2 (x86)
+# - Robin H. Johnson <robbat2@gentoo.org> - 23 Nov 2006
+#HW_VARIANT="Escalade7000Series" - for versions 9.3.0.*
+HW_VARIANT="Escalade9650SE-Series" # for versions 9.4.0*
+# package has different tarballs for x86 and amd64
+SRC_URI_BASE="http://www.3ware.com/download/${HW_VARIANT}/${PV}"
+SRC_URI="x86? ( ${SRC_URI_BASE}/${PN}-linux-x86-${PV}.tgz )
+ amd64? ( ${SRC_URI_BASE}/${PN}-linux-x86_64-${PV}.tgz )"
+DOWNLOAD_URL="http://www.3ware.com/support/windows_agree.asp?path=/download/${HW_VARIANT}/${PV}/${MY_P}.tgz"
+S="${WORKDIR}"
+
+src_unpack() {
+ unpack ${MY_P}.tgz
+}
+
+supportedcards() {
+ einfo "This binary supports should support ALL cards, including, but not"
+ einfo "limited to the following series:"
+ einfo ""
+ einfo "PATA: 6xxx, 72xx, 74xx, 78xx, 7000, 7500, 7506"
+ einfo "SATA: 8006, 8500, 8506, 9500S, 9550SX, 9590SE"
+ einfo " 9550SXU, 9650SE"
+}
+
+pkg_setup() {
+ supportedcards
+}
+
+pkg_nofetch() {
+ einfo "Please agree to the license at URL"
+ einfo ""
+ einfo "\t${DOWNLOAD_URL}"
+ einfo ""
+ einfo "And then use the following URL to download the"
+ einfo "correct tarball into ${DISTDIR}"
+ einfo ""
+ einfo "\t${SRC_URI}"
+ einfo ""
+ supportedcards
+}
+
+src_install() {
+ into /
+ dosbin tw_cli
+ dosbin tw_sched
+ insinto /etc
+ doins tw_sched.cfg
+ into /usr
+ newman tw_cli.8.nroff tw_cli.8
+ newman tw_sched.8.nroff tw_sched.8
+ dohtml *.html
+}