summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoshua Kinard <kumba@gentoo.org>2006-02-06 05:26:41 +0000
committerJoshua Kinard <kumba@gentoo.org>2006-02-06 05:26:41 +0000
commit7f94c36e3cffdeace3a4ebe189a94e9b9ddecc36 (patch)
tree492a45dd8093dbf33bfba91ef29af58562585ae3 /sys-boot/arcload
parentMark 0.8.2 stable on ia64 (diff)
downloadgentoo-2-7f94c36e3cffdeace3a4ebe189a94e9b9ddecc36.tar.gz
gentoo-2-7f94c36e3cffdeace3a4ebe189a94e9b9ddecc36.tar.bz2
gentoo-2-7f94c36e3cffdeace3a4ebe189a94e9b9ddecc36.zip
Import newer version of ARCLoad. Now with Filesystem Support.
(Portage version: 2.1_pre3-r1)
Diffstat (limited to 'sys-boot/arcload')
-rw-r--r--sys-boot/arcload/ChangeLog7
-rw-r--r--sys-boot/arcload/Manifest4
-rw-r--r--sys-boot/arcload/arcload-0.5.ebuild69
-rw-r--r--sys-boot/arcload/files/digest-arcload-0.51
4 files changed, 79 insertions, 2 deletions
diff --git a/sys-boot/arcload/ChangeLog b/sys-boot/arcload/ChangeLog
index c86446d502a8..5ef3ff94fb5d 100644
--- a/sys-boot/arcload/ChangeLog
+++ b/sys-boot/arcload/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-boot/arcload
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/arcload/ChangeLog,v 1.4 2006/01/02 07:37:07 kumba Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/arcload/ChangeLog,v 1.5 2006/02/06 05:26:41 kumba Exp $
+
+*arcload-0.5 (10 Feb 2006)
+
+ 10 Feb 2006; Joshua Kinard <kumba@gentoo.org> +arcload-0.5.ebuild:
+ Import newer version of ARCLoad. Now with Filesystem Support.
02 Jan 2006; Joshua Kinard <kumba@gentoo.org> -arcload-0.41.ebuild,
arcload-0.43-r1.ebuild:
diff --git a/sys-boot/arcload/Manifest b/sys-boot/arcload/Manifest
index f111ec556a74..3f2dd0a850d7 100644
--- a/sys-boot/arcload/Manifest
+++ b/sys-boot/arcload/Manifest
@@ -1,5 +1,7 @@
-MD5 34f2078c8c812e202bf78cf72df1de11 ChangeLog 1088
+MD5 5acc06ca3088d39a320a87b992afab2b ChangeLog 1251
MD5 4e1d95869703346d01284102e6fe5f19 arcload-0.43-r1.ebuild 2506
+MD5 0d40a2c9b9708e709e1f22f65c28df3e arcload-0.5.ebuild 2287
MD5 4c218c8e9298938004593523435f45b6 files/arcload-0.43-tweaks1.patch 615
MD5 a95a426a82a8a6ad6249e843a4fcedff files/digest-arcload-0.43-r1 64
+MD5 d4091c7fc48b202bb0eab762e4130683 files/digest-arcload-0.5 63
MD5 58a9ae7662a7e557b27a74c70106c08d metadata.xml 366
diff --git a/sys-boot/arcload/arcload-0.5.ebuild b/sys-boot/arcload/arcload-0.5.ebuild
new file mode 100644
index 000000000000..f95002b971f9
--- /dev/null
+++ b/sys-boot/arcload/arcload-0.5.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/arcload/arcload-0.5.ebuild,v 1.1 2006/02/06 05:26:41 kumba Exp $
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="ARCLoad - SGI Multi-bootloader. Able to bootload many different SGI Systems."
+HOMEPAGE="http://www.linux-mips.org/wiki/index.php/ARCLoad"
+SRC_URI="ftp://ftp.linux-mips.org/pub/linux/mips/people/skylark/${P}.tar.bz2"
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="-* ~mips"
+IUSE=""
+DEPEND="sys-boot/dvhtool"
+RESTRICT="nostrip"
+
+
+pkg_setup() {
+ # See if we're on a cobalt system
+ if [ "${PROFILE_ARCH}" = "cobalt" ]; then
+ echo -e ""
+ eerror "This package is only intended for SGI systems. It will not work on any"
+ eerror "other types of MIPS-based systems or any other architectures"
+ echo -e ""
+ die
+ fi
+}
+
+src_compile() {
+ echo -e ""
+ einfo ">>> Building 32-bit version (sashARCS) for IP22/IP32 ..."
+ cd ${S}
+ make MODE=M32 clean || die
+ make CC=$(tc-getCC) LD=$(tc-getLD) MODE=M32 || die
+ cp ${S}/arcload.ecoff ${WORKDIR}/sashARCS
+
+ echo -e ""
+ einfo ">>> Building 64-bit version (sash64) for IP27/IP28/IP30 ..."
+ make MODE=M64 clean || die
+ make CC=$(tc-getCC) LD=$(tc-getLD) MODE=M64 || die
+ cp ${S}/arcload ${WORKDIR}/sash64
+}
+
+src_install() {
+ cd ${S}
+ dodir /usr/lib/arcload
+ cp ${WORKDIR}/sashARCS ${D}/usr/lib/arcload
+ cp ${WORKDIR}/sash64 ${D}/usr/lib/arcload
+ cp ${S}/arc.cf-bootcd ${D}/usr/lib/arcload/arc-bootcd.cf
+ cp ${S}/arc.cf-octane ${D}/usr/lib/arcload/arc-octane.cf
+}
+
+pkg_postinst() {
+ echo -e ""
+ einfo "ARCLoad binaries copied to: /usr/lib/arcload"
+ echo -e ""
+ einfo "Use of ARCLoad is relatively easy:"
+ einfo "\t1) Determine which version you need"
+ einfo "\t\tA) sashARCS for IP22/IP32"
+ einfo "\t\tB) sash64 for IP27/IP28/IP30"
+ einfo "\t2) Copy that to the volume header using 'dvhtool'"
+ einfo "\t3) Edit /usr/lib/arcload/arc-*.cf to fit your specific system"
+ einfo "\t (See ${HOMEPAGE} for"
+ einfo "\t an explanation of the format of the config file)"
+ einfo "\t4) Copy the config file to the volume header with 'dvhtool' (make sure it is copied as 'arc.cf')"
+ einfo "\t5) Copy any kernels to the volume header that you want to be bootable"
+ einfo "\t6) Reboot, and enjoy!"
+ echo -e ""
+}
diff --git a/sys-boot/arcload/files/digest-arcload-0.5 b/sys-boot/arcload/files/digest-arcload-0.5
new file mode 100644
index 000000000000..c9ffa3cb1cc9
--- /dev/null
+++ b/sys-boot/arcload/files/digest-arcload-0.5
@@ -0,0 +1 @@
+MD5 b00e1c79074a13c2de97748f56f9bd1f arcload-0.5.tar.bz2 47690