summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Weiler <pylon@gentoo.org>2007-02-10 22:19:45 +0000
committerLars Weiler <pylon@gentoo.org>2007-02-10 22:19:45 +0000
commit9c611fe3070ee3a26703738ab96e391e215f5b7c (patch)
tree8c50121679a79a9d56d8cfe54c9dd734b720db9c /sys-boot/bootcreator/bootcreator-1.2.ebuild
parentRemove udev useflag, bug 158114, remove old ebuilds (diff)
downloadgentoo-2-9c611fe3070ee3a26703738ab96e391e215f5b7c.tar.gz
gentoo-2-9c611fe3070ee3a26703738ab96e391e215f5b7c.tar.bz2
gentoo-2-9c611fe3070ee3a26703738ab96e391e215f5b7c.zip
Version bump.
(Portage version: 2.1.2-r9)
Diffstat (limited to 'sys-boot/bootcreator/bootcreator-1.2.ebuild')
-rw-r--r--sys-boot/bootcreator/bootcreator-1.2.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/sys-boot/bootcreator/bootcreator-1.2.ebuild b/sys-boot/bootcreator/bootcreator-1.2.ebuild
new file mode 100644
index 000000000000..d3a196b7657c
--- /dev/null
+++ b/sys-boot/bootcreator/bootcreator-1.2.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/bootcreator/bootcreator-1.2.ebuild,v 1.1 2007/02/10 22:19:45 pylon Exp $
+
+inherit eutils
+
+DESCRIPTION="Simple generator for Forth based BootMenu scripts for Pegasos machines"
+
+HOMEPAGE="http://tbs-software.com/morgoth/projects.html"
+SRC_URI="http://tbs-software.com/morgoth/files/bootcreator-src.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="ppc -*"
+IUSE=""
+DEPEND=""
+
+PROVIDE="virtual/bootloader"
+
+S=${WORKDIR}
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ mv examples/example.bc examples/bootmenu.example
+}
+
+src_compile() {
+ cd ${S}
+ make all || die "Can't compile bootmenu"
+}
+
+src_install() {
+ cd ${S}
+ dosbin src/bootcreator
+ insinto /etc
+ doins examples/bootmenu.example
+ dodoc doc/README doc/COPYING
+}