summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-05-06 22:34:36 +0000
committerMike Frysinger <vapier@gentoo.org>2004-05-06 22:34:36 +0000
commit1c0a975208eac124823649066be12c0d55af478a (patch)
tree9a45dab80c923e89ab84dcccfe91d7b60cbe9309 /sys-boot/grub
parentStable on ia64 (Manifest recommit) (diff)
downloadgentoo-2-1c0a975208eac124823649066be12c0d55af478a.tar.gz
gentoo-2-1c0a975208eac124823649066be12c0d55af478a.tar.bz2
gentoo-2-1c0a975208eac124823649066be12c0d55af478a.zip
add gcc-3.4 patch
Diffstat (limited to 'sys-boot/grub')
-rw-r--r--sys-boot/grub/ChangeLog6
-rw-r--r--sys-boot/grub/files/grub-0.94-gcc3.4.patch14
-rw-r--r--sys-boot/grub/grub-0.94-r1.ebuild18
3 files changed, 24 insertions, 14 deletions
diff --git a/sys-boot/grub/ChangeLog b/sys-boot/grub/ChangeLog
index 699d7b96d484..1712166cc0dd 100644
--- a/sys-boot/grub/ChangeLog
+++ b/sys-boot/grub/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-boot/grub
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/ChangeLog,v 1.12 2004/04/14 10:28:49 swtaylor Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/ChangeLog,v 1.13 2004/05/06 22:34:36 vapier Exp $
+
+ 06 May 2004; Mike Frysinger <vapier@gentoo.org>
+ +files/grub-0.94-gcc3.4.patch, grub-0.94-r1.ebuild:
+ add gcc-3.4 patch
14 Apr 2004; Scott W Taylor <swtaylor@gentoo.org> :
Cleanup checks for hardened
diff --git a/sys-boot/grub/files/grub-0.94-gcc3.4.patch b/sys-boot/grub/files/grub-0.94-gcc3.4.patch
new file mode 100644
index 000000000000..223f6544c184
--- /dev/null
+++ b/sys-boot/grub/files/grub-0.94-gcc3.4.patch
@@ -0,0 +1,14 @@
+diff -ur grub-0.94.orig/stage2/char_io.c grub-0.94/stage2/char_io.c
+--- grub-0.94.orig/stage2/char_io.c 2003-07-09 11:45:52.000000000 +0000
++++ grub-0.94/stage2/char_io.c 2004-05-04 16:08:41.983029992 +0000
+@@ -1265,3 +1265,10 @@
+ return dest;
+ }
+ #endif /* ! STAGE1_5 */
++
++#ifndef GRUB_UTIL
++# undef memcpy
++/* GCC emits references to memcpy() for struct copies etc. */
++void *memcpy (void *dest, const void *src, int n) __attribute__ ((alias ("grub_memmove")));
++#endif
++
diff --git a/sys-boot/grub/grub-0.94-r1.ebuild b/sys-boot/grub/grub-0.94-r1.ebuild
index 850d0da596ac..32727ac067c2 100644
--- a/sys-boot/grub/grub-0.94-r1.ebuild
+++ b/sys-boot/grub/grub-0.94-r1.ebuild
@@ -1,13 +1,13 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/grub-0.94-r1.ebuild,v 1.4 2004/04/14 10:28:49 swtaylor Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/grub-0.94-r1.ebuild,v 1.5 2004/05/06 22:34:36 vapier Exp $
inherit mount-boot eutils flag-o-matic gcc
DESCRIPTION="GNU GRUB boot loader"
HOMEPAGE="http://www.gnu.org/software/grub/"
SRC_URI="ftp://alpha.gnu.org/gnu/grub/${P}.tar.gz
- http://dev.gentoo.org/~spock/portage/distfiles/${P}-splash.patch.bz2"
+ mirror://gentoo/${P}-splash.patch.bz2"
LICENSE="GPL-2"
SLOT="0"
@@ -19,19 +19,11 @@ DEPEND=">=sys-libs/ncurses-5.2-r5
PROVIDE="virtual/bootloader"
src_unpack() {
- unpack ${A} || die
- cd ${S} || die
+ unpack ${A}
+ cd ${S}
epatch ${WORKDIR}/${P}-splash.patch
-
- # grub-0.93.20030118-gentoo.diff; <woodchip@gentoo.org> (18 Jan 2003)
- # -fixes from grub CVS pulled on 20030118
- # -vga16 patches; mined from Debian's grub-0.93+cvs20030102-1.diff
- # -special-raid-devices.patch
- # -addsyncs.patch
- # -splashimagehelp.patch
- # -configfile.patch
- # -installcopyonly.patch
+ epatch ${FILESDIR}/${P}-gcc3.4.patch
# This patchset is from SuSE -- hopefully fixes the acl symlink issue
# And should add some boot prettification