summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2010-07-02 21:36:41 +0000
committerChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2010-07-02 21:36:41 +0000
commita26e4f64b35527985bd4f98c6681d7423ccc3209 (patch)
treed9d465e2db57eb52fdb7f2fdc2407130287d3411 /sys-boot/syslinux
parentmedia-libs/freeverb3: Fix QA issuess reported by ssuominen (diff)
downloadgentoo-2-a26e4f64b35527985bd4f98c6681d7423ccc3209.tar.gz
gentoo-2-a26e4f64b35527985bd4f98c6681d7423ccc3209.tar.bz2
gentoo-2-a26e4f64b35527985bd4f98c6681d7423ccc3209.zip
Version bump.
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'sys-boot/syslinux')
-rw-r--r--sys-boot/syslinux/ChangeLog8
-rw-r--r--sys-boot/syslinux/syslinux-4.01.ebuild60
2 files changed, 67 insertions, 1 deletions
diff --git a/sys-boot/syslinux/ChangeLog b/sys-boot/syslinux/ChangeLog
index 77e7d37cdb27..37b786142d7f 100644
--- a/sys-boot/syslinux/ChangeLog
+++ b/sys-boot/syslinux/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-boot/syslinux
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/syslinux/ChangeLog,v 1.69 2010/06/29 21:59:46 chithanh Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/syslinux/ChangeLog,v 1.70 2010/07/02 21:36:41 chithanh Exp $
+
+*syslinux-4.01 (02 Jul 2010)
+
+ 02 Jul 2010; Chí-Thanh Christopher Nguyễn <chithanh@gentoo.org>
+ +syslinux-4.01.ebuild:
+ Version bump. Adds support for Lua scripting.
*syslinux-4.00 (29 Jun 2010)
diff --git a/sys-boot/syslinux/syslinux-4.01.ebuild b/sys-boot/syslinux/syslinux-4.01.ebuild
new file mode 100644
index 000000000000..c57aadfd6407
--- /dev/null
+++ b/sys-boot/syslinux/syslinux-4.01.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/syslinux/syslinux-4.01.ebuild,v 1.1 2010/07/02 21:36:41 chithanh Exp $
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="SYSLINUX, PXELINUX, ISOLINUX, EXTLINUX and MEMDISK bootloaders"
+HOMEPAGE="http://syslinux.zytor.com/"
+SRC_URI="mirror://kernel/linux/utils/boot/syslinux/${PV:0:1}.xx/${P/_/-}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+IUSE="custom-cflags"
+
+RDEPEND="sys-fs/mtools
+ dev-perl/Crypt-PasswdMD5
+ dev-perl/Digest-SHA1"
+DEPEND="${RDEPEND}
+ dev-lang/nasm"
+
+S=${WORKDIR}/${P/_/-}
+
+# This ebuild is a departure from the old way of rebuilding everything in syslinux
+# This departure is necessary since hpa doesn't support the rebuilding of anything other
+# than the installers.
+
+# removed all the unpack/patching stuff since we aren't rebuilding the core stuff anymore
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ # Fix building on hardened
+ epatch "${FILESDIR}"/${PN}-4.00-nopie.patch
+
+ rm -f gethostip #bug 137081
+
+ # Don't prestrip or override user LDFLAGS, bug #305783
+ local SYSLINUX_MAKEFILES="extlinux/Makefile linux/Makefile mtools/Makefile \
+ sample/Makefile utils/Makefile"
+ sed -i ${SYSLINUX_MAKEFILES} -e '/^LDFLAGS/d' || die "sed failed"
+
+ if use custom-cflags; then
+ sed -i ${SYSLINUX_MAKEFILES} \
+ -e 's|-g -Os||g' \
+ -e 's|-Os||g' \
+ -e 's|CFLAGS[[:space:]]\+=|CFLAGS +=|g' \
+ || die "sed custom-cflags failed"
+ fi
+
+}
+
+src_compile() {
+ emake CC=$(tc-getCC) installer || die
+}
+
+src_install() {
+ emake INSTALLSUBDIRS=utils INSTALLROOT="${D}" MANDIR=/usr/share/man install || die
+ dodoc README NEWS doc/* || die
+}