summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxim Koltsov <maksbotan@gentoo.org>2014-03-01 19:21:50 +0000
committerMaxim Koltsov <maksbotan@gentoo.org>2014-03-01 19:21:50 +0000
commit0d47badcf3303c8883a53d381b2c31f91b2ae1fe (patch)
treeb13f0013f384ee7244b99b4460db6a324bb516bc /sys-boot
parentVersion bump, drop old (diff)
downloadgentoo-2-0d47badcf3303c8883a53d381b2c31f91b2ae1fe.tar.gz
gentoo-2-0d47badcf3303c8883a53d381b2c31f91b2ae1fe.tar.bz2
gentoo-2-0d47badcf3303c8883a53d381b2c31f91b2ae1fe.zip
Add patch from upstream git to fix installation paths in populate-initrd, bug #499388. Thanks to Enrico Tagliavini.
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key F8DBDADE)
Diffstat (limited to 'sys-boot')
-rw-r--r--sys-boot/plymouth/ChangeLog9
-rw-r--r--sys-boot/plymouth/files/0.8.8-initrd-binaries-paths.patch32
-rw-r--r--sys-boot/plymouth/plymouth-0.8.8-r5.ebuild94
3 files changed, 134 insertions, 1 deletions
diff --git a/sys-boot/plymouth/ChangeLog b/sys-boot/plymouth/ChangeLog
index 985cce548250..443321669a2d 100644
--- a/sys-boot/plymouth/ChangeLog
+++ b/sys-boot/plymouth/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-boot/plymouth
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/plymouth/ChangeLog,v 1.50 2014/02/02 15:56:31 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/plymouth/ChangeLog,v 1.51 2014/03/01 19:21:50 maksbotan Exp $
+
+*plymouth-0.8.8-r5 (01 Mar 2014)
+
+ 01 Mar 2014; Maxim Koltsov <maksbotan@gentoo.org>
+ +files/0.8.8-initrd-binaries-paths.patch, +plymouth-0.8.8-r5.ebuild:
+ Add patch from upstream git to fix installation paths in populate-initrd, bug
+ #499388. Thanks to Enrico Tagliavini.
02 Feb 2014; Agostino Sarubbo <ago@gentoo.org> plymouth-0.8.8-r4.ebuild:
Stable for sparc, wrt bug #487674
diff --git a/sys-boot/plymouth/files/0.8.8-initrd-binaries-paths.patch b/sys-boot/plymouth/files/0.8.8-initrd-binaries-paths.patch
new file mode 100644
index 000000000000..7416527b0f31
--- /dev/null
+++ b/sys-boot/plymouth/files/0.8.8-initrd-binaries-paths.patch
@@ -0,0 +1,32 @@
+From 2d85c8d0a3ad81268718344e0e72ebeeea851422 Mon Sep 17 00:00:00 2001
+From: Enrico Tagliavini <enrico.tagliavini@gmail.com>
+Date: Wed, 29 Jan 2014 14:18:22 +0000
+Subject: populate-initrd: install binaries to their configured location
+
+If plymouth is configured --with-system-root-install=no then the
+systemd unitd files will write the paths of plymouth and plymouthd
+relative to /usr . The script currently hardcodes installing them
+to the initrd's /
+
+This commit makes sure they get placed on the same part of the of
+the initrd filesystem as systemd expects to find them.
+
+https://bugs.freedesktop.org/show_bug.cgi?id=74174
+---
+diff --git a/scripts/plymouth-populate-initrd.in b/scripts/plymouth-populate-initrd.in
+index d25ab07..43c7f22 100755
+--- a/scripts/plymouth-populate-initrd.in
++++ b/scripts/plymouth-populate-initrd.in
+@@ -373,8 +373,8 @@ done
+ [ -z "$INITRDDIR" ] && usage error
+
+ mkdir -p ${INITRDDIR}${PLYMOUTH_DATADIR}/plymouth/themes
+-inst ${PLYMOUTH_DAEMON_PATH} $INITRDDIR /sbin/plymouthd
+-inst ${PLYMOUTH_CLIENT_PATH} $INITRDDIR /bin/plymouth
++inst ${PLYMOUTH_DAEMON_PATH} $INITRDDIR
++inst ${PLYMOUTH_CLIENT_PATH} $INITRDDIR
+ inst ${PLYMOUTH_DATADIR}/plymouth/themes/text/text.plymouth $INITRDDIR
+ inst ${PLYMOUTH_PLUGIN_PATH}/text.so $INITRDDIR
+ inst ${PLYMOUTH_DATADIR}/plymouth/themes/details/details.plymouth $INITRDDIR
+--
+cgit v0.9.0.2-2-gbebe
diff --git a/sys-boot/plymouth/plymouth-0.8.8-r5.ebuild b/sys-boot/plymouth/plymouth-0.8.8-r5.ebuild
new file mode 100644
index 000000000000..5b79f70008e1
--- /dev/null
+++ b/sys-boot/plymouth/plymouth-0.8.8-r5.ebuild
@@ -0,0 +1,94 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/plymouth/plymouth-0.8.8-r5.ebuild,v 1.1 2014/03/01 19:21:50 maksbotan Exp $
+
+EAPI=5
+
+inherit autotools-utils readme.gentoo systemd toolchain-funcs
+
+DESCRIPTION="Graphical boot animation (splash) and logger"
+HOMEPAGE="http://cgit.freedesktop.org/plymouth/"
+SRC_URI="
+ http://www.freedesktop.org/software/plymouth/releases/${P}.tar.bz2
+ http://dev.gentoo.org/~aidecoe/distfiles/${CATEGORY}/${PN}/gentoo-logo.png"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE_VIDEO_CARDS="video_cards_intel video_cards_radeon"
+IUSE="${IUSE_VIDEO_CARDS} debug gdm +gtk +libkms +pango static-libs"
+
+CDEPEND="
+ >=media-libs/libpng-1.2.16
+ gtk? (
+ dev-libs/glib:2
+ >=x11-libs/gtk+-2.12:2 )
+ libkms? ( x11-libs/libdrm[libkms] )
+ pango? ( >=x11-libs/pango-1.21 )
+ video_cards_intel? ( x11-libs/libdrm[video_cards_intel] )
+ video_cards_radeon? ( x11-libs/libdrm[video_cards_radeon] )
+"
+DEPEND="${CDEPEND}
+ virtual/pkgconfig
+"
+# Block due bug #383067
+RDEPEND="${CDEPEND}
+ virtual/udev
+"
+
+DOC_CONTENTS="
+ Follow the following instructions to set up Plymouth:\n
+ http://dev.gentoo.org/~aidecoe/doc/en/plymouth.xml
+"
+
+PATCHES=(
+ "${FILESDIR}/0.8.8-initrd-binaries-paths.patch"
+)
+
+src_prepare() {
+ sed -i 's:/bin/systemd-tty-ask-password-agent:/usr/bin/systemd-tty-ask-password-agent:g' \
+ systemd-units/systemd-ask-password-plymouth.service.in || die \
+ 'ask-password sed failed'
+ sed -i 's:/bin/udevadm:/usr/bin/udevadm:g' \
+ systemd-units/plymouth-start.service.in || die 'udevadm sed failed'
+ autotools-utils_src_prepare
+}
+
+src_configure() {
+ local myeconfargs=(
+ --with-system-root-install=no
+ --localstatedir=/var
+ --without-rhgb-compat-link
+ --enable-systemd-integration
+ $(use_enable debug tracing)
+ $(use_enable gtk gtk)
+ $(use_enable libkms)
+ $(use_enable pango)
+ $(use_enable gdm gdm-transition)
+ $(use_enable video_cards_intel libdrm_intel)
+ $(use_enable video_cards_radeon libdrm_radeon)
+ )
+ autotools-utils_src_configure
+}
+
+src_install() {
+ autotools-utils_src_install
+
+ insinto /usr/share/plymouth
+ newins "${DISTDIR}"/gentoo-logo.png bizcom.png
+
+ # Install compatibility symlinks as some rdeps hardcode the paths
+ dosym /usr/bin/plymouth /bin/plymouth
+ dosym /usr/sbin/plymouth-set-default-theme /sbin/plymouth-set-default-theme
+ dosym /usr/sbin/plymouthd /sbin/plymouthd
+
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ readme.gentoo_print_elog
+ if ! has_version "sys-kernel/dracut[dracut_modules_plymouth]" && ! has_version "sys-kernel/genkernel-next[plymouth]"; then
+ ewarn "If you want initramfs builder with plymouth support, please emerge"
+ ewarn "sys-kernel/dracut[dracut_modules_plymouth] or sys-kernel/genkernel-next[plymouth]."
+ fi
+}