summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-03-19 21:05:28 +0000
committerMike Frysinger <vapier@gentoo.org>2004-03-19 21:05:28 +0000
commit0e3bf8b80949efe48d147c2ee57b708038db3d28 (patch)
tree8f615057d1976132f0c74df1089c24d0b000227b /sys-boot
parentold (diff)
downloadgentoo-2-0e3bf8b80949efe48d147c2ee57b708038db3d28.tar.gz
gentoo-2-0e3bf8b80949efe48d147c2ee57b708038db3d28.tar.bz2
gentoo-2-0e3bf8b80949efe48d147c2ee57b708038db3d28.zip
fix DEPEND #45110
Diffstat (limited to 'sys-boot')
-rw-r--r--sys-boot/palo/palo-1.2_pre20030630.ebuild17
1 files changed, 7 insertions, 10 deletions
diff --git a/sys-boot/palo/palo-1.2_pre20030630.ebuild b/sys-boot/palo/palo-1.2_pre20030630.ebuild
index bf51b83bc950..b34184126a98 100644
--- a/sys-boot/palo/palo-1.2_pre20030630.ebuild
+++ b/sys-boot/palo/palo-1.2_pre20030630.ebuild
@@ -1,23 +1,21 @@
-# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/palo/palo-1.2_pre20030630.ebuild,v 1.1 2003/12/09 08:13:02 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/palo/palo-1.2_pre20030630.ebuild,v 1.2 2004/03/19 21:05:28 vapier Exp $
MY_V=${PV/_pre/-CVS}
DESCRIPTION="PALO : PArisc Linux Loader"
HOMEPAGE="http://parisc-linux.org/"
SRC_URI="http://ftp.parisc-linux.org/cvs/palo-${MY_V}.tar.gz"
+
LICENSE="GPL-2"
SLOT="0"
-
-S=${WORKDIR}/palo
-
-#Compile only on hppa stations
KEYWORDS="hppa -*"
IUSE=""
+DEPEND="virtual/glibc"
PROVIDE="virtual/bootloader"
-DEPEND=">=glibc-2.2.4"
+S=${WORKDIR}/palo
src_compile() {
emake -C palo CFLAGS="${CFLAGS} -I../include -I../lib" || die
@@ -27,11 +25,10 @@ src_compile() {
}
src_install() {
- dosbin palo/palo
+ dosbin palo/palo || die
doman palo.8
dohtml README.html
- dodoc README
- dodoc palo.conf
+ dodoc README palo.conf
insinto /etc
doins ${FILESDIR}/palo.conf