summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoseph Jezak <josejx@gentoo.org>2005-07-12 00:55:18 +0000
committerJoseph Jezak <josejx@gentoo.org>2005-07-12 00:55:18 +0000
commit246056220342734b7f1b6c945a3b13e5bc158dd1 (patch)
tree208b20179823277f7885d0cb09a88c35ab4109df /sys-boot
parentstable on mips (diff)
downloadgentoo-2-246056220342734b7f1b6c945a3b13e5bc158dd1.tar.gz
gentoo-2-246056220342734b7f1b6c945a3b13e5bc158dd1.tar.bz2
gentoo-2-246056220342734b7f1b6c945a3b13e5bc158dd1.zip
Fixed MAKEOPTS mess for bug #98463 and removed kernel 2.6 check
(Portage version: 2.0.51.22-r1)
Diffstat (limited to 'sys-boot')
-rw-r--r--sys-boot/yaboot/ChangeLog7
-rw-r--r--sys-boot/yaboot/yaboot-1.3.11-r1.ebuild9
-rw-r--r--sys-boot/yaboot/yaboot-1.3.12-r1.ebuild20
-rw-r--r--sys-boot/yaboot/yaboot-1.3.13.ebuild22
4 files changed, 17 insertions, 41 deletions
diff --git a/sys-boot/yaboot/ChangeLog b/sys-boot/yaboot/ChangeLog
index 7dc3ad7e6b08..724a804b806a 100644
--- a/sys-boot/yaboot/ChangeLog
+++ b/sys-boot/yaboot/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-boot/yaboot
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/yaboot/ChangeLog,v 1.18 2005/07/10 18:37:29 dostrow Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/yaboot/ChangeLog,v 1.19 2005/07/12 00:55:18 josejx Exp $
+
+ 12 Jul 2005; Joseph Jezak <josejx@gentoo.org> yaboot-1.3.11-r1.ebuild,
+ yaboot-1.3.12-r1.ebuild, yaboot-1.3.13.ebuild:
+ Cleaned up MAKEOPTS mess, removed kernel 2.6.3 check as we don't have those
+ kernel versions in the tree any longer.
10 Jul 2005; Daniel Ostrow <dostrow@gentoo.org> yaboot-1.3.13.ebuild:
Add ibm use flag check for rdeps on hfs stuff.
diff --git a/sys-boot/yaboot/yaboot-1.3.11-r1.ebuild b/sys-boot/yaboot/yaboot-1.3.11-r1.ebuild
index 51e20831308d..bf67a126528a 100644
--- a/sys-boot/yaboot/yaboot-1.3.11-r1.ebuild
+++ b/sys-boot/yaboot/yaboot-1.3.11-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/yaboot/yaboot-1.3.11-r1.ebuild,v 1.7 2005/07/03 13:14:24 hansmi Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/yaboot/yaboot-1.3.11-r1.ebuild,v 1.8 2005/07/12 00:55:18 josejx Exp $
inherit eutils toolchain-funcs
@@ -19,8 +19,6 @@ DEPEND="sys-apps/powerpc-utils
PROVIDE="virtual/bootloader"
-MAKEOPTS='PREFIX=/usr MANDIR=share/man'
-
src_compile() {
export -n CFLAGS
export -n CXXFLAGS
@@ -30,12 +28,13 @@ src_compile() {
epatch ${FILESDIR}/chrpfix.patch
#took from http://penguinppc.org/~eb/files/ofpath
epatch ${FILESDIR}/${P}-ofpath-fix.patch
- emake ${MAKEOPTS} CC="$(tc-getCC)" || die
+ emake PREFIX=/usr MANDIR=share/man CC="$(tc-getCC)" || die
+
}
src_install() {
cp etc/yaboot.conf etc/yaboot.conf.bak
sed -e 's/\/local//' etc/yaboot.conf >| etc/yaboot.conf.edit
mv -f etc/yaboot.conf.edit etc/yaboot.conf
- make ROOT=${D} ${MAKEOPTS} install || die
+ make ROOT=${D} PREFIX=/usr MANDIR=share/man install || die
}
diff --git a/sys-boot/yaboot/yaboot-1.3.12-r1.ebuild b/sys-boot/yaboot/yaboot-1.3.12-r1.ebuild
index 835ca3af7dd8..45309c9b6613 100644
--- a/sys-boot/yaboot/yaboot-1.3.12-r1.ebuild
+++ b/sys-boot/yaboot/yaboot-1.3.12-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/yaboot/yaboot-1.3.12-r1.ebuild,v 1.9 2005/07/03 13:14:24 hansmi Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/yaboot/yaboot-1.3.12-r1.ebuild,v 1.10 2005/07/12 00:55:18 josejx Exp $
inherit eutils toolchain-funcs
@@ -19,20 +19,6 @@ DEPEND="sys-apps/powerpc-utils
PROVIDE="virtual/bootloader"
-MAKEOPTS='PREFIX=/usr MANDIR=share/man'
-
-pkg_setup() {
- case "$(uname -r)" in
- 2.5.*|2.6.0*|2.6.1|2.6.1-*|2.6.2|2.6.2-*)
- eerror "You are running Linux kernel `uname -r` which is not supported"
- eerror "Please note if you are running a 2.6 kernel the verison"
- eerror "of ofpath included in this revision of yaboot requires"
- eerror "that you run a kernel >= 2.6.3."
- die
- ;;
- esac
-}
-
src_compile() {
export -n CFLAGS
export -n CXXFLAGS
@@ -42,14 +28,14 @@ src_compile() {
epatch ${FILESDIR}/chrpfix.patch
epatch ${FILESDIR}/yaboot-3.4.patch
epatch ${FILESDIR}/yaboot-1.3.12-k2sata-ofpath.patch
- emake ${MAKEOPTS} CC="$(tc-getCC)" || die
+ emake PREFIX=/usr MANDIR=share/man CC="$(tc-getCC)" || die
}
src_install() {
cp etc/yaboot.conf etc/yaboot.conf.bak
sed -e 's/\/local//' etc/yaboot.conf >| etc/yaboot.conf.edit
mv -f etc/yaboot.conf.edit etc/yaboot.conf
- make ROOT=${D} ${MAKEOPTS} install || die
+ make ROOT=${D} PREFIX=/usr MANDIR=share/man install || die
}
pkg_postinst() {
diff --git a/sys-boot/yaboot/yaboot-1.3.13.ebuild b/sys-boot/yaboot/yaboot-1.3.13.ebuild
index cdef351e4c68..a7cf5499f93d 100644
--- a/sys-boot/yaboot/yaboot-1.3.13.ebuild
+++ b/sys-boot/yaboot/yaboot-1.3.13.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/yaboot/yaboot-1.3.13.ebuild,v 1.6 2005/07/10 18:37:29 dostrow Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/yaboot/yaboot-1.3.13.ebuild,v 1.7 2005/07/12 00:55:18 josejx Exp $
inherit eutils toolchain-funcs
@@ -19,20 +19,6 @@ RDEPEND="!ibm? ( sys-fs/hfsutils )
PROVIDE="virtual/bootloader"
-MAKEOPTS='PREFIX=/usr MANDIR=share/man'
-
-pkg_setup() {
- case "$(uname -r)" in
- 2.5.*|2.6.0*|2.6.1|2.6.1-*|2.6.2|2.6.2-*)
- eerror "You are running Linux kernel `uname -r` which is not supported"
- eerror "Please note if you are running a 2.6 kernel the verison"
- eerror "of ofpath included in this revision of yaboot requires"
- eerror "that you run a kernel >= 2.6.3."
- die
- ;;
- esac
-}
-
src_compile() {
export -n CFLAGS
export -n CXXFLAGS
@@ -43,18 +29,18 @@ src_compile() {
epatch ${FILESDIR}/yaboot-3.4.patch
epatch ${FILESDIR}/yaboot-${PV}-ofpath.patch
epatch ${FILESDIR}/yaboot-nopiessp.patch
- emake ${MAKEOPTS} CC="$(tc-getCC)" || die
+ emake PREFIX=/usr MANDIR=share/man CC="$(tc-getCC)" || die
}
src_install() {
cp etc/yaboot.conf etc/yaboot.conf.bak
sed -e 's/\/local//' etc/yaboot.conf >| etc/yaboot.conf.edit
mv -f etc/yaboot.conf.edit etc/yaboot.conf
- make ROOT=${D} ${MAKEOPTS} install || die
+ make ROOT=${D} PREFIX=/usr MANDIR=share/man install || die
}
pkg_postinst() {
ewarn "Please note if you are running a 2.6 kernel the verison"
ewarn "of ofpath included in this revision of yaboot requires"
- ewarn "that you run a kernel >= 2.6.3 Prior versions are unsupported."
+ ewarn "that you run a kernel >= 2.6.3, prior versions are unsupported."
}