summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSteve Dibb <beandog@gentoo.org>2009-06-27 17:42:59 +0000
committerSteve Dibb <beandog@gentoo.org>2009-06-27 17:42:59 +0000
commit446bd25276f45fe9596fb241e292733c04d82610 (patch)
treea21599ab9ee9fbb61aec50af8c4a8c6c2c7656d3 /sys-boot
parentChanging maintainer tag to scarabeus, I already said on the bug that I lost i... (diff)
downloadgentoo-2-446bd25276f45fe9596fb241e292733c04d82610.tar.gz
gentoo-2-446bd25276f45fe9596fb241e292733c04d82610.tar.bz2
gentoo-2-446bd25276f45fe9596fb241e292733c04d82610.zip
Version bump, bug 274285
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'sys-boot')
-rw-r--r--sys-boot/syslinux/ChangeLog7
-rw-r--r--sys-boot/syslinux/syslinux-3.82.ebuild45
2 files changed, 51 insertions, 1 deletions
diff --git a/sys-boot/syslinux/ChangeLog b/sys-boot/syslinux/ChangeLog
index 9aa5e79ef635..c2af0c0607c9 100644
--- a/sys-boot/syslinux/ChangeLog
+++ b/sys-boot/syslinux/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-boot/syslinux
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/syslinux/ChangeLog,v 1.45 2009/05/15 18:38:20 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/syslinux/ChangeLog,v 1.46 2009/06/27 17:42:59 beandog Exp $
+
+*syslinux-3.82 (27 Jun 2009)
+
+ 27 Jun 2009; Steve Dibb <beandog@gentoo.org> +syslinux-3.82.ebuild:
+ Version bump, bug 274285
*syslinux-3.80 (15 May 2009)
diff --git a/sys-boot/syslinux/syslinux-3.82.ebuild b/sys-boot/syslinux/syslinux-3.82.ebuild
new file mode 100644
index 000000000000..81f7e53987f7
--- /dev/null
+++ b/sys-boot/syslinux/syslinux-3.82.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/syslinux/syslinux-3.82.ebuild,v 1.1 2009/06/27 17:42:59 beandog Exp $
+
+inherit eutils
+
+DESCRIPTION="SysLinux, IsoLinux and PXELinux bootloader"
+HOMEPAGE="http://syslinux.zytor.com/"
+SRC_URI="mirror://kernel/linux/utils/boot/syslinux/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+IUSE=""
+
+RDEPEND="sys-fs/mtools
+ dev-perl/Crypt-PasswdMD5
+ dev-perl/Digest-SHA1"
+DEPEND="${RDEPEND}
+ dev-lang/nasm"
+
+# This ebuild is a departure from the old way of rebuilding everything in syslinux
+# This departure is necessary since hpa doesn't support the rebuilding of anything other
+# than the installers.
+
+# removed all the unpack/patching stuff since we aren't rebuilding the core stuff anymore
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${PN}-3.72-nopie.patch
+ # Don't prestrip, makes portage angry
+ epatch "${FILESDIR}"/${PN}-3.72-nostrip.patch
+
+ rm -f gethostip #bug 137081
+}
+
+src_compile() {
+ emake installer || die
+}
+
+src_install() {
+ emake INSTALLROOT="${D}" MANDIR=/usr/share/man local-install || die
+ dodoc README NEWS TODO doc/*
+}