summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2015-05-17 04:27:34 +0000
committerMike Frysinger <vapier@gentoo.org>2015-05-17 04:27:34 +0000
commit552d290e8d24d50600537a7d1b8a47a7424fa2e5 (patch)
treea69c8b9f74515f80179ef21ff0cb93e3a765fd27 /sys-boot
parentUpdate to EAPI=5. (diff)
downloadgentoo-2-552d290e8d24d50600537a7d1b8a47a7424fa2e5.tar.gz
gentoo-2-552d290e8d24d50600537a7d1b8a47a7424fa2e5.tar.bz2
gentoo-2-552d290e8d24d50600537a7d1b8a47a7424fa2e5.zip
Drop support for ssp found in gcc-3 and older #527974.
(Portage version: 2.2.19/cvs/Linux x86_64, signed Manifest commit with key D2E96200)
Diffstat (limited to 'sys-boot')
-rw-r--r--sys-boot/yaboot/ChangeLog6
-rw-r--r--sys-boot/yaboot/files/yaboot-nopiessp.patch51
-rw-r--r--sys-boot/yaboot/yaboot-1.3.14-r2.ebuild9
-rw-r--r--sys-boot/yaboot/yaboot-1.3.16.ebuild9
-rw-r--r--sys-boot/yaboot/yaboot-1.3.17-r2.ebuild9
5 files changed, 11 insertions, 73 deletions
diff --git a/sys-boot/yaboot/ChangeLog b/sys-boot/yaboot/ChangeLog
index 731ca6003b2d..3de0087c45d4 100644
--- a/sys-boot/yaboot/ChangeLog
+++ b/sys-boot/yaboot/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-boot/yaboot
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/yaboot/ChangeLog,v 1.50 2015/05/17 04:25:12 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/yaboot/ChangeLog,v 1.51 2015/05/17 04:27:34 vapier Exp $
+
+ 17 May 2015; Mike Frysinger <vapier@gentoo.org> -files/yaboot-nopiessp.patch,
+ yaboot-1.3.14-r2.ebuild, yaboot-1.3.16.ebuild, yaboot-1.3.17-r2.ebuild:
+ Drop support for ssp found in gcc-3 and older #527974.
17 May 2015; Mike Frysinger <vapier@gentoo.org> yaboot-1.3.14-r2.ebuild,
yaboot-1.3.16.ebuild, yaboot-1.3.17-r2.ebuild:
diff --git a/sys-boot/yaboot/files/yaboot-nopiessp.patch b/sys-boot/yaboot/files/yaboot-nopiessp.patch
deleted file mode 100644
index 32e64392b730..000000000000
--- a/sys-boot/yaboot/files/yaboot-nopiessp.patch
+++ /dev/null
@@ -1,51 +0,0 @@
-diff -Nrup yaboot-1.3.13.orig/Config.gentoo yaboot-1.3.13/Config.gentoo
---- yaboot-1.3.13.orig/Config.gentoo 1970-01-01 00:00:00.000000000 +0000
-+++ yaboot-1.3.13/Config.gentoo 2005-06-12 00:41:14.889576152 +0000
-@@ -0,0 +1,6 @@
-+check_gcc=$(shell if $(CC) $(1) -S -o /dev/null -xc /dev/null > /dev/null 2>&1; \
-+ then echo "$(1)"; else echo "$(2)"; fi)
-+
-+CFLAGS += $(call check_gcc, -fno-stack-protector)
-+CFLAGS += $(call check_gcc, --nopie)
-+
-diff -Nrup yaboot-1.3.13.orig/Makefile yaboot-1.3.13/Makefile
---- yaboot-1.3.13.orig/Makefile 2004-07-11 20:12:03.000000000 +0000
-+++ yaboot-1.3.13/Makefile 2005-06-12 00:41:14.890576000 +0000
-@@ -1,6 +1,7 @@
- ## Setup
-
- include Config
-+include Config.gentoo
-
- VERSION = 1.3.13
- # Debug mode (spam/verbose)
-@@ -79,7 +80,7 @@ HOSTCFLAGS = -O2 $(CFLAGS) -Wall -I/usr/
- OBJS = second/crt0.o second/yaboot.o second/cache.o second/prom.o second/file.o \
- second/partition.o second/fs.o second/cfg.o second/setjmp.o second/cmdline.o \
- second/fs_of.o second/fs_ext2.o second/fs_iso.o second/iso_util.o \
-- lib/nosys.o lib/string.o lib/strtol.o lib/vsprintf.o lib/ctype.o lib/malloc.o lib/strstr.o
-+ lib/nosys.o lib/string.o lib/strtol.o lib/vsprintf.o lib/ctype.o lib/malloc.o lib/strstr.o lib/ssp.o
-
- ifeq ($(USE_MD5_PASSWORDS),y)
- OBJS += second/md5.o
-diff -Nrup yaboot-1.3.13.orig/lib/ssp.c yaboot-1.3.13/lib/ssp.c
---- yaboot-1.3.13.orig/lib/ssp.c 1970-01-01 00:00:00.000000000 +0000
-+++ yaboot-1.3.13/lib/ssp.c 2005-06-12 00:42:17.087120688 +0000
-@@ -0,0 +1,17 @@
-+unsigned long __guard = 0UL;
-+static void __guard_setup (void) __attribute__ ((constructor));
-+void __stack_smash_handler (char func[], int damaged
-+ __attribute__ ((unused)));
-+static void
-+__guard_setup (void)
-+{
-+ if (__guard != 0UL)
-+ return;
-+ __guard = 0xFF0A0D00UL;
-+}
-+
-+void
-+__stack_smash_handler (char func[], int damaged)
-+{
-+ return;
-+}
diff --git a/sys-boot/yaboot/yaboot-1.3.14-r2.ebuild b/sys-boot/yaboot/yaboot-1.3.14-r2.ebuild
index e3c1320ac440..a4d702370c28 100644
--- a/sys-boot/yaboot/yaboot-1.3.14-r2.ebuild
+++ b/sys-boot/yaboot/yaboot-1.3.14-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/yaboot/yaboot-1.3.14-r2.ebuild,v 1.10 2015/05/17 04:25:12 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/yaboot/yaboot-1.3.14-r2.ebuild,v 1.11 2015/05/17 04:27:34 vapier Exp $
EAPI="5"
@@ -32,12 +32,7 @@ src_prepare() {
# dual boot patch
epatch "${FILESDIR}/yabootconfig-1.3.13.patch"
epatch "${FILESDIR}/chrpfix.patch"
- if [[ "$(gcc-major-version)" -eq "3" ]]; then
- epatch "${FILESDIR}/yaboot-nopiessp.patch"
- fi
- if [[ "$(gcc-major-version)" -eq "4" ]]; then
- epatch "${FILESDIR}/yaboot-nopiessp-gcc4.patch"
- fi
+ epatch "${FILESDIR}/yaboot-nopiessp-gcc4.patch"
epatch "${FILESDIR}/sysfs-ofpath.patch"
}
diff --git a/sys-boot/yaboot/yaboot-1.3.16.ebuild b/sys-boot/yaboot/yaboot-1.3.16.ebuild
index 53e065b8cdd4..e19c96e8da08 100644
--- a/sys-boot/yaboot/yaboot-1.3.16.ebuild
+++ b/sys-boot/yaboot/yaboot-1.3.16.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/yaboot/yaboot-1.3.16.ebuild,v 1.10 2015/05/17 04:25:12 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/yaboot/yaboot-1.3.16.ebuild,v 1.11 2015/05/17 04:27:34 vapier Exp $
EAPI="5"
@@ -38,12 +38,7 @@ src_prepare() {
# dual boot patch
epatch "${FILESDIR}/yabootconfig-1.3.13.patch"
epatch "${FILESDIR}/chrpfix.patch"
- if [[ "$(gcc-major-version)" -eq "3" ]]; then
- epatch "${FILESDIR}/yaboot-nopiessp.patch"
- fi
- if [[ "$(gcc-major-version)" -eq "4" ]]; then
- epatch "${FILESDIR}/yaboot-nopiessp-gcc4.patch"
- fi
+ epatch "${FILESDIR}/yaboot-nopiessp-gcc4.patch"
# e2fsprogs memalign patch
epatch "${FILESDIR}/${P}-memalign.patch"
diff --git a/sys-boot/yaboot/yaboot-1.3.17-r2.ebuild b/sys-boot/yaboot/yaboot-1.3.17-r2.ebuild
index 55c8883e29cd..ad93a575bbc7 100644
--- a/sys-boot/yaboot/yaboot-1.3.17-r2.ebuild
+++ b/sys-boot/yaboot/yaboot-1.3.17-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/yaboot/yaboot-1.3.17-r2.ebuild,v 1.7 2015/05/17 04:25:12 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/yaboot/yaboot-1.3.17-r2.ebuild,v 1.8 2015/05/17 04:27:34 vapier Exp $
EAPI="5"
@@ -39,12 +39,7 @@ src_prepare() {
# dual boot patch
epatch "${FILESDIR}/yabootconfig-1.3.13.patch"
epatch "${FILESDIR}/chrpfix.patch"
- if [[ "$(gcc-major-version)" -eq "3" ]]; then
- epatch "${FILESDIR}/${PN}-nopiessp.patch"
- fi
- if [[ "$(gcc-major-version)" -eq "4" ]]; then
- epatch "${FILESDIR}/${P}-nopiessp-gcc4.patch"
- fi
+ epatch "${FILESDIR}/${P}-nopiessp-gcc4.patch"
# Error only on real errors, for prom printing format compile failure
sed -i "s:-Werror:-Wno-error:g" Makefile