summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSimon Stelling <blubb@gentoo.org>2006-02-05 14:46:31 +0000
committerSimon Stelling <blubb@gentoo.org>2006-02-05 14:46:31 +0000
commit6d3c5fd3c88aeb55c77ad9187a238013a7e872f8 (patch)
treeb9c2118f8a52c7c3769f48b3bdc8d5aaf6d39d9c /sys-boot
parentremove old 2004.3 multilib checks (diff)
downloadgentoo-2-6d3c5fd3c88aeb55c77ad9187a238013a7e872f8.tar.gz
gentoo-2-6d3c5fd3c88aeb55c77ad9187a238013a7e872f8.tar.bz2
gentoo-2-6d3c5fd3c88aeb55c77ad9187a238013a7e872f8.zip
remove old 2004.3 multilib checks
(Portage version: 2.1_pre4-r1)
Diffstat (limited to 'sys-boot')
-rw-r--r--sys-boot/grub/ChangeLog5
-rw-r--r--sys-boot/grub/grub-0.96-r2.ebuild12
-rw-r--r--sys-boot/grub/grub-0.97-r2.ebuild12
-rw-r--r--sys-boot/grub/grub-1.92.ebuild10
4 files changed, 7 insertions, 32 deletions
diff --git a/sys-boot/grub/ChangeLog b/sys-boot/grub/ChangeLog
index 03a1826f018d..f551470e0995 100644
--- a/sys-boot/grub/ChangeLog
+++ b/sys-boot/grub/ChangeLog
@@ -1,9 +1,8 @@
# ChangeLog for sys-boot/grub
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/ChangeLog,v 1.57 2006/02/05 14:44:52 blubb Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/ChangeLog,v 1.58 2006/02/05 14:46:31 blubb Exp $
- 05 Feb 2006; Simon Stelling <blubb@gentoo.org> grub-0.96-r2.ebuild,
- grub-0.97-r2.ebuild:
+ 05 Feb 2006; Simon Stelling <blubb@gentoo.org> grub-1.92.ebuild:
remove old 2004.3 multilib checks
*grub-1.92 (16 Jan 2006)
diff --git a/sys-boot/grub/grub-0.96-r2.ebuild b/sys-boot/grub/grub-0.96-r2.ebuild
index f9c1d4abc2c1..f5856e36e4ab 100644
--- a/sys-boot/grub/grub-0.96-r2.ebuild
+++ b/sys-boot/grub/grub-0.96-r2.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/grub-0.96-r2.ebuild,v 1.9 2005/08/21 02:24:04 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/grub-0.96-r2.ebuild,v 1.10 2006/02/05 14:44:52 blubb Exp $
inherit mount-boot eutils flag-o-matic toolchain-funcs
@@ -29,14 +29,6 @@ PATCHDIR="${WORKDIR}/gentoo"
pkg_setup() {
if use amd64; then
- if ! has_m32; then
- eerror "Your compiler seems to be unable to compile 32bit code."
- eerror "If you are on amd64, make sure you compile gcc with:"
- echo
- eerror " USE=multilib FEATURES=-sandbox"
- die "Cannot produce 32bit objects!"
- fi
-
ABI_ALLOW="x86"
ABI="x86"
fi
diff --git a/sys-boot/grub/grub-0.97-r2.ebuild b/sys-boot/grub/grub-0.97-r2.ebuild
index f0e3d82eb809..3d91ba58157e 100644
--- a/sys-boot/grub/grub-0.97-r2.ebuild
+++ b/sys-boot/grub/grub-0.97-r2.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/grub-0.97-r2.ebuild,v 1.3 2005/11/25 19:46:43 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/grub-0.97-r2.ebuild,v 1.4 2006/02/05 14:44:52 blubb Exp $
inherit mount-boot eutils flag-o-matic toolchain-funcs
@@ -25,14 +25,6 @@ PROVIDE="virtual/bootloader"
pkg_setup() {
if use amd64 ; then
- if ! has_m32 ; then
- eerror "Your compiler seems to be unable to compile 32bit code."
- eerror "If you are on amd64, make sure you compile gcc with:"
- echo
- eerror " USE=multilib FEATURES=-sandbox"
- die "Cannot produce 32bit objects!"
- fi
-
ABI_ALLOW="x86"
ABI="x86"
fi
diff --git a/sys-boot/grub/grub-1.92.ebuild b/sys-boot/grub/grub-1.92.ebuild
index 6e3d4d7ca1b0..d90d1f305704 100644
--- a/sys-boot/grub/grub-1.92.ebuild
+++ b/sys-boot/grub/grub-1.92.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/grub-1.92.ebuild,v 1.1 2006/01/16 09:17:54 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/grub-1.92.ebuild,v 1.2 2006/02/05 14:46:31 blubb Exp $
inherit mount-boot eutils flag-o-matic toolchain-funcs
@@ -20,14 +20,6 @@ PROVIDE="virtual/bootloader"
pkg_setup() {
if use amd64 ; then
- if ! has_m32 ; then
- eerror "Your compiler seems to be unable to compile 32bit code."
- eerror "If you are on amd64, make sure you compile gcc with:"
- echo
- eerror " USE=multilib FEATURES=-sandbox"
- die "Cannot produce 32bit objects!"
- fi
-
ABI_ALLOW="x86"
ABI="x86"
fi