summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2015-05-17 03:59:27 +0000
committerMike Frysinger <vapier@gentoo.org>2015-05-17 03:59:27 +0000
commit7875309352c8eaca07585927af01247017c9f327 (patch)
tree5eae7a9ceaee4fe7dac608f099a0babe950f9c8a /sys-boot
parentAdd QA_PRESTRIPPED to quiet install warnings. (diff)
downloadgentoo-2-7875309352c8eaca07585927af01247017c9f327.tar.gz
gentoo-2-7875309352c8eaca07585927af01247017c9f327.tar.bz2
gentoo-2-7875309352c8eaca07585927af01247017c9f327.zip
Update to EAPI=5.
(Portage version: 2.2.19/cvs/Linux x86_64, signed Manifest commit with key D2E96200)
Diffstat (limited to 'sys-boot')
-rw-r--r--sys-boot/yaboot-static/ChangeLog7
-rw-r--r--sys-boot/yaboot-static/files/new-ofpath-devspec.patch8
-rw-r--r--sys-boot/yaboot-static/yaboot-static-1.3.14-r1.ebuild20
-rw-r--r--sys-boot/yaboot-static/yaboot-static-1.3.16-r1.ebuild14
-rw-r--r--sys-boot/yaboot-static/yaboot-static-1.3.17-r1.ebuild15
5 files changed, 42 insertions, 22 deletions
diff --git a/sys-boot/yaboot-static/ChangeLog b/sys-boot/yaboot-static/ChangeLog
index 4731e9dcb7bc..5270940165a3 100644
--- a/sys-boot/yaboot-static/ChangeLog
+++ b/sys-boot/yaboot-static/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-boot/yaboot-static
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/yaboot-static/ChangeLog,v 1.33 2015/05/17 03:58:17 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/yaboot-static/ChangeLog,v 1.34 2015/05/17 03:59:27 vapier Exp $
+
+ 17 May 2015; Mike Frysinger <vapier@gentoo.org>
+ files/new-ofpath-devspec.patch, yaboot-static-1.3.14-r1.ebuild,
+ yaboot-static-1.3.16-r1.ebuild, yaboot-static-1.3.17-r1.ebuild:
+ Update to EAPI=5.
17 May 2015; Mike Frysinger <vapier@gentoo.org>
yaboot-static-1.3.14-r1.ebuild, yaboot-static-1.3.16-r1.ebuild,
diff --git a/sys-boot/yaboot-static/files/new-ofpath-devspec.patch b/sys-boot/yaboot-static/files/new-ofpath-devspec.patch
index eec840ee10fe..f225e8e1bb4b 100644
--- a/sys-boot/yaboot-static/files/new-ofpath-devspec.patch
+++ b/sys-boot/yaboot-static/files/new-ofpath-devspec.patch
@@ -1,5 +1,7 @@
---- usr/sbin/ofpath.bak 2012-05-09 12:24:51.709911981 -0400
-+++ usr/sbin/ofpath 2012-05-09 12:32:19.661560544 -0400
+Fix the devspec path on newer kernels
+
+--- usr/sbin/ofpath
++++ usr/sbin/ofpath
@@ -85,11 +85,20 @@
[ "$DEBUG" = 1 ] && echo "Devpath is: $DEVPATH"
@@ -16,7 +18,7 @@
+ ### /dev/sd* on kernel <3.3
+ CONTROLLER_PATH=$(cat ${DEVPATH}/../../../devspec);
+elif [ -e "${DEVPATH}/../../../../devspec" ]; then
-+ ### /dev/sd* on kernel 3.3+
++ ### /dev/sd* on kernel 3.3+
+ CONTROLLER_PATH=$(cat ${DEVPATH}/../../../../devspec);
+else
+ ### None of the above...
diff --git a/sys-boot/yaboot-static/yaboot-static-1.3.14-r1.ebuild b/sys-boot/yaboot-static/yaboot-static-1.3.14-r1.ebuild
index c6c6ecce8dda..9a6df03362b2 100644
--- a/sys-boot/yaboot-static/yaboot-static-1.3.14-r1.ebuild
+++ b/sys-boot/yaboot-static/yaboot-static-1.3.14-r1.ebuild
@@ -1,17 +1,22 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/yaboot-static/yaboot-static-1.3.14-r1.ebuild,v 1.7 2015/05/17 03:58:17 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/yaboot-static/yaboot-static-1.3.14-r1.ebuild,v 1.8 2015/05/17 03:59:27 vapier Exp $
+
+# Generated by using quickpkg on a ppc32 machine, compiled with -O2 -pipe.
+
+EAPI="5"
inherit eutils
DESCRIPTION="Static yaboot ppc boot loader for machines with open firmware"
-
HOMEPAGE="http://yaboot.ozlabs.org/"
SRC_URI="mirror://gentoo/yaboot-static-${PV}.tbz2"
+
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="-* ppc ppc64"
IUSE="ibm"
+
DEPEND="sys-apps/powerpc-utils"
RDEPEND="!sys-boot/yaboot
!ibm? (
@@ -20,21 +25,20 @@ RDEPEND="!sys-boot/yaboot
sys-fs/mac-fdisk
)"
+S=${WORKDIR}
+
QA_PRESTRIPPED="
/usr/lib/yaboot/yaboot
/usr/lib/yaboot/yaboot.chrp
/usr/lib/yaboot/addnote
"
-src_unpack() {
- unpack ${A}
- cd "${S}"
+src_prepare() {
epatch "${FILESDIR}"/sysfs-ofpath.patch
}
src_install() {
# don't blow away the user's old conf file
- mv "${WORKDIR}/etc/yaboot.conf" "${WORKDIR}/etc/yaboot.conf.unconfigured" \
- || die "mv failed"
- cp -pPR "${WORKDIR}"/* "${D}" || die "cp failed"
+ mv "${WORKDIR}"/etc/yaboot.conf{,.sample} || die
+ cp -pPR "${WORKDIR}"/* "${D}" || die
}
diff --git a/sys-boot/yaboot-static/yaboot-static-1.3.16-r1.ebuild b/sys-boot/yaboot-static/yaboot-static-1.3.16-r1.ebuild
index 2a54cc199229..0912e6e04c56 100644
--- a/sys-boot/yaboot-static/yaboot-static-1.3.16-r1.ebuild
+++ b/sys-boot/yaboot-static/yaboot-static-1.3.16-r1.ebuild
@@ -1,18 +1,22 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/yaboot-static/yaboot-static-1.3.16-r1.ebuild,v 1.5 2015/05/17 03:58:17 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/yaboot-static/yaboot-static-1.3.16-r1.ebuild,v 1.6 2015/05/17 03:59:27 vapier Exp $
+
+# Generated by using quickpkg on a ppc32 machine, compiled with -O2 -pipe.
+
+EAPI="5"
inherit eutils
DESCRIPTION="Static yaboot ppc boot loader for machines with open firmware"
-### Generated by using quickpkg on a ppc32 machine, compiled with -O2 -pipe
-
HOMEPAGE="http://yaboot.ozlabs.org/"
SRC_URI="mirror://gentoo/yaboot-static-${PV}.tbz2"
+
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="-* ppc ppc64"
IUSE="ibm"
+
DEPEND="sys-apps/powerpc-utils"
RDEPEND="!sys-boot/yaboot
!ibm? (
@@ -21,6 +25,8 @@ RDEPEND="!sys-boot/yaboot
sys-fs/mac-fdisk
)"
+S=${WORKDIR}
+
QA_PRESTRIPPED="
/usr/lib/yaboot/yaboot
/usr/lib/yaboot/yaboot.chrp
@@ -28,5 +34,5 @@ QA_PRESTRIPPED="
"
src_install() {
- cp -pPR "${WORKDIR}"/* "${D}" || die "cp failed"
+ cp -pPR "${WORKDIR}"/* "${D}" || die
}
diff --git a/sys-boot/yaboot-static/yaboot-static-1.3.17-r1.ebuild b/sys-boot/yaboot-static/yaboot-static-1.3.17-r1.ebuild
index 83b650394146..4a5bad3c67d1 100644
--- a/sys-boot/yaboot-static/yaboot-static-1.3.17-r1.ebuild
+++ b/sys-boot/yaboot-static/yaboot-static-1.3.17-r1.ebuild
@@ -1,20 +1,22 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/yaboot-static/yaboot-static-1.3.17-r1.ebuild,v 1.6 2015/05/17 03:58:17 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/yaboot-static/yaboot-static-1.3.17-r1.ebuild,v 1.7 2015/05/17 03:59:27 vapier Exp $
-EAPI=2
+# Generated by using quickpkg on a ppc32 machine, compiled with -O2 -pipe.
+
+EAPI="5"
inherit eutils
DESCRIPTION="Static yaboot ppc boot loader for machines with open firmware"
-### Generated by using quickpkg on a ppc32 machine, compiled with -O2 -pipe
-
HOMEPAGE="http://yaboot.ozlabs.org/"
SRC_URI="mirror://gentoo/yaboot-static-${PV}.tbz2"
+
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="-* ppc ppc64"
IUSE="ibm"
+
DEPEND="sys-apps/powerpc-utils"
RDEPEND="!sys-boot/yaboot
!ibm? (
@@ -23,6 +25,8 @@ RDEPEND="!sys-boot/yaboot
sys-fs/mac-fdisk
)"
+S=${WORKDIR}
+
QA_PRESTRIPPED="
/usr/lib/yaboot/yaboot
/usr/lib/yaboot/yaboot.chrp
@@ -30,10 +34,9 @@ QA_PRESTRIPPED="
"
src_prepare() {
- # Fix the devspec path on newer kernels
epatch "${FILESDIR}/new-ofpath-devspec.patch"
}
src_install() {
- cp -pPR "${WORKDIR}"/* "${D}" || die "cp failed"
+ cp -pPR "${WORKDIR}"/* "${D}" || die
}