summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2015-03-17 02:00:07 +0000
committerMike Gilbert <floppym@gentoo.org>2015-03-17 02:00:07 +0000
commit7fbf7e04e2d3d2db69d734347f0d95d98338cd44 (patch)
tree2bc69fe6cf58771b87f651f583584543184a02fc /sys-boot
parentVersion bump. Import live git ebuild from overlay. (diff)
downloadgentoo-2-7fbf7e04e2d3d2db69d734347f0d95d98338cd44.tar.gz
gentoo-2-7fbf7e04e2d3d2db69d734347f0d95d98338cd44.tar.bz2
gentoo-2-7fbf7e04e2d3d2db69d734347f0d95d98338cd44.zip
We need to set TARGET_LDFLAGS, not LDFLAGS.
(Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key 0BBEEA1FEA4843A4)
Diffstat (limited to 'sys-boot')
-rw-r--r--sys-boot/grub/ChangeLog7
-rw-r--r--sys-boot/grub/grub-2.00_p5107-r2.ebuild5
-rw-r--r--sys-boot/grub/grub-2.02_beta2-r3.ebuild5
-rw-r--r--sys-boot/grub/grub-2.02_beta2-r6.ebuild5
-rw-r--r--sys-boot/grub/grub-2.02_beta2-r7.ebuild5
-rw-r--r--sys-boot/grub/grub-9999-r1.ebuild5
6 files changed, 26 insertions, 6 deletions
diff --git a/sys-boot/grub/ChangeLog b/sys-boot/grub/ChangeLog
index ee3f34b0b5a9..5ec0086e5910 100644
--- a/sys-boot/grub/ChangeLog
+++ b/sys-boot/grub/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-boot/grub
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/ChangeLog,v 1.349 2015/03/16 21:39:48 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/ChangeLog,v 1.350 2015/03/17 02:00:07 floppym Exp $
+
+ 17 Mar 2015; Mike Gilbert <floppym@gentoo.org> grub-2.00_p5107-r2.ebuild,
+ grub-2.02_beta2-r3.ebuild, grub-2.02_beta2-r6.ebuild,
+ grub-2.02_beta2-r7.ebuild, grub-9999-r1.ebuild:
+ We need to set TARGET_LDFLAGS, not LDFLAGS.
16 Mar 2015; Mike Frysinger <vapier@gentoo.org> grub-0.97-r14.ebuild,
grub-2.00_p5107-r2.ebuild, grub-2.02_beta2-r3.ebuild,
diff --git a/sys-boot/grub/grub-2.00_p5107-r2.ebuild b/sys-boot/grub/grub-2.00_p5107-r2.ebuild
index e94530f912da..719d25a0ed1b 100644
--- a/sys-boot/grub/grub-2.00_p5107-r2.ebuild
+++ b/sys-boot/grub/grub-2.00_p5107-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/grub-2.00_p5107-r2.ebuild,v 1.10 2015/03/16 21:39:48 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/grub-2.00_p5107-r2.ebuild,v 1.11 2015/03/17 02:00:07 floppym Exp $
EAPI=5
@@ -222,6 +222,9 @@ src_configure() {
use static && export HOST_LDFLAGS="${HOST_LDFLAGS} -static"
tc-ld-disable-gold #439082 #466536 #526348
+ export TARGET_LDFLAGS=${LDFLAGS}
+ unset LDFLAGS
+
tc-export CC NM OBJCOPY STRIP
export TARGET_CC=${TARGET_CC:-${CC}}
tc-export BUILD_CC # Bug 485592
diff --git a/sys-boot/grub/grub-2.02_beta2-r3.ebuild b/sys-boot/grub/grub-2.02_beta2-r3.ebuild
index b997b69dbfd3..93c4970113ec 100644
--- a/sys-boot/grub/grub-2.02_beta2-r3.ebuild
+++ b/sys-boot/grub/grub-2.02_beta2-r3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/grub-2.02_beta2-r3.ebuild,v 1.6 2015/03/16 21:39:48 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/grub-2.02_beta2-r3.ebuild,v 1.7 2015/03/17 02:00:07 floppym Exp $
EAPI=5
@@ -237,6 +237,9 @@ src_configure() {
use static && HOST_LDFLAGS+=" -static"
tc-ld-disable-gold #439082 #466536 #526348
+ export TARGET_LDFLAGS=${LDFLAGS}
+ unset LDFLAGS
+
tc-export CC NM OBJCOPY STRIP
export TARGET_CC=${TARGET_CC:-${CC}}
tc-export BUILD_CC # Bug 485592
diff --git a/sys-boot/grub/grub-2.02_beta2-r6.ebuild b/sys-boot/grub/grub-2.02_beta2-r6.ebuild
index afa13e0ae04c..385938949400 100644
--- a/sys-boot/grub/grub-2.02_beta2-r6.ebuild
+++ b/sys-boot/grub/grub-2.02_beta2-r6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/grub-2.02_beta2-r6.ebuild,v 1.4 2015/03/16 21:39:48 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/grub-2.02_beta2-r6.ebuild,v 1.5 2015/03/17 02:00:07 floppym Exp $
EAPI=5
@@ -237,6 +237,9 @@ src_configure() {
use static && HOST_LDFLAGS+=" -static"
tc-ld-disable-gold #439082 #466536 #526348
+ export TARGET_LDFLAGS=${LDFLAGS}
+ unset LDFLAGS
+
tc-export CC NM OBJCOPY STRIP
export TARGET_CC=${TARGET_CC:-${CC}}
tc-export BUILD_CC # Bug 485592
diff --git a/sys-boot/grub/grub-2.02_beta2-r7.ebuild b/sys-boot/grub/grub-2.02_beta2-r7.ebuild
index 93ec2a7117c7..0719627cb423 100644
--- a/sys-boot/grub/grub-2.02_beta2-r7.ebuild
+++ b/sys-boot/grub/grub-2.02_beta2-r7.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/grub-2.02_beta2-r7.ebuild,v 1.7 2015/03/16 21:39:48 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/grub-2.02_beta2-r7.ebuild,v 1.8 2015/03/17 02:00:07 floppym Exp $
EAPI=5
@@ -245,6 +245,9 @@ src_configure() {
use static && HOST_LDFLAGS+=" -static"
tc-ld-disable-gold #439082 #466536 #526348
+ export TARGET_LDFLAGS=${LDFLAGS}
+ unset LDFLAGS
+
tc-export CC NM OBJCOPY STRIP
export TARGET_CC=${TARGET_CC:-${CC}}
tc-export BUILD_CC # Bug 485592
diff --git a/sys-boot/grub/grub-9999-r1.ebuild b/sys-boot/grub/grub-9999-r1.ebuild
index 7cece259f11c..c6a79cbcc2b7 100644
--- a/sys-boot/grub/grub-9999-r1.ebuild
+++ b/sys-boot/grub/grub-9999-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/grub-9999-r1.ebuild,v 1.30 2015/03/16 21:39:48 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/grub-9999-r1.ebuild,v 1.31 2015/03/17 02:00:07 floppym Exp $
EAPI=5
@@ -245,6 +245,9 @@ src_configure() {
use static && HOST_LDFLAGS+=" -static"
tc-ld-disable-gold #439082 #466536 #526348
+ export TARGET_LDFLAGS=${LDFLAGS}
+ unset LDFLAGS
+
tc-export CC NM OBJCOPY STRIP
export TARGET_CC=${TARGET_CC:-${CC}}
tc-export BUILD_CC # Bug 485592