summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNed Ludd <solar@gentoo.org>2006-07-17 20:40:09 +0000
committerNed Ludd <solar@gentoo.org>2006-07-17 20:40:09 +0000
commit82cc4f7903a7d18b885f5c012f32822f8c76db5c (patch)
tree8828034076b631803734a38f840512e101053da0 /sys-boot
parentmissing dep (diff)
downloadgentoo-2-82cc4f7903a7d18b885f5c012f32822f8c76db5c.tar.gz
gentoo-2-82cc4f7903a7d18b885f5c012f32822f8c76db5c.tar.bz2
gentoo-2-82cc4f7903a7d18b885f5c012f32822f8c76db5c.zip
- lilo needs to the LC_ALL=C or strange things can and do happen which must not be risked on a bootloader. bug 140209
(Portage version: 2.1.1_pre2-r7)
Diffstat (limited to 'sys-boot')
-rw-r--r--sys-boot/lilo/ChangeLog7
-rw-r--r--sys-boot/lilo/lilo-22.7.1.ebuild5
-rw-r--r--sys-boot/lilo/lilo-22.7.2-r1.ebuild5
-rw-r--r--sys-boot/lilo/lilo-22.7.ebuild5
4 files changed, 18 insertions, 4 deletions
diff --git a/sys-boot/lilo/ChangeLog b/sys-boot/lilo/ChangeLog
index d14261efe311..ea5b55d734b5 100644
--- a/sys-boot/lilo/ChangeLog
+++ b/sys-boot/lilo/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-boot/lilo
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/lilo/ChangeLog,v 1.39 2006/07/13 11:47:04 chainsaw Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/lilo/ChangeLog,v 1.40 2006/07/17 20:40:09 solar Exp $
+
+ 17 Jul 2006; <solar@gentoo.org> lilo-22.7.ebuild, lilo-22.7.1.ebuild,
+ lilo-22.7.2-r1.ebuild:
+ - lilo needs to the LC_ALL=C or strange things can and do happen which must
+ not be risked on a bootloader. bug 140209
*lilo-22.7.2-r1 (13 Jul 2006)
diff --git a/sys-boot/lilo/lilo-22.7.1.ebuild b/sys-boot/lilo/lilo-22.7.1.ebuild
index 3ffb3aad2ce9..53d57b29199f 100644
--- a/sys-boot/lilo/lilo-22.7.1.ebuild
+++ b/sys-boot/lilo/lilo-22.7.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/lilo/lilo-22.7.1.ebuild,v 1.1 2006/01/07 13:42:35 chainsaw Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/lilo/lilo-22.7.1.ebuild,v 1.2 2006/07/17 20:40:09 solar Exp $
inherit eutils flag-o-matic toolchain-funcs
@@ -60,6 +60,9 @@ src_unpack() {
}
src_compile() {
+ # lilo needs this. bug 140209
+ export LC_ALL=C
+
# hardened automatic PIC plus PIE building should be suppressed
# because of assembler instructions that cannot be compiled PIC
HARDENED_CFLAGS="`test-flags-CC -fno-pic -nopie`"
diff --git a/sys-boot/lilo/lilo-22.7.2-r1.ebuild b/sys-boot/lilo/lilo-22.7.2-r1.ebuild
index 2274c6107fd8..6f381bebd24a 100644
--- a/sys-boot/lilo/lilo-22.7.2-r1.ebuild
+++ b/sys-boot/lilo/lilo-22.7.2-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/lilo/lilo-22.7.2-r1.ebuild,v 1.1 2006/07/13 11:47:04 chainsaw Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/lilo/lilo-22.7.2-r1.ebuild,v 1.2 2006/07/17 20:40:09 solar Exp $
inherit eutils flag-o-matic toolchain-funcs
@@ -60,6 +60,9 @@ src_unpack() {
}
src_compile() {
+ # lilo needs this. bug 140209
+ export LC_ALL=C
+
# hardened automatic PIC plus PIE building should be suppressed
# because of assembler instructions that cannot be compiled PIC
HARDENED_CFLAGS="`test-flags-CC -fno-pic -nopie`"
diff --git a/sys-boot/lilo/lilo-22.7.ebuild b/sys-boot/lilo/lilo-22.7.ebuild
index 5834389821c5..5ff8c6d12168 100644
--- a/sys-boot/lilo/lilo-22.7.ebuild
+++ b/sys-boot/lilo/lilo-22.7.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/lilo/lilo-22.7.ebuild,v 1.5 2006/01/07 13:42:35 chainsaw Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/lilo/lilo-22.7.ebuild,v 1.6 2006/07/17 20:40:09 solar Exp $
inherit eutils flag-o-matic toolchain-funcs
@@ -67,6 +67,9 @@ src_unpack() {
}
src_compile() {
+ # lilo needs this. bug 140209
+ export LC_ALL=C
+
# hardened automatic PIC plus PIE building should be suppressed
# because of assembler instructions that cannot be compiled PIC
HARDENED_CFLAGS="`test-flags-CC -fno-pic -nopie`"