summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2010-02-16 12:47:45 +0000
committerChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2010-02-16 12:47:45 +0000
commit9a32655dd39764390dcf18f3dcad65c81d093883 (patch)
treeaf0b7cb30976deb866ae40edca1c249414bfcb61 /sys-boot
parentAdd elog message encouraging users to read Gentoo meaningful backtrace (diff)
downloadgentoo-2-9a32655dd39764390dcf18f3dcad65c81d093883.tar.gz
gentoo-2-9a32655dd39764390dcf18f3dcad65c81d093883.tar.bz2
gentoo-2-9a32655dd39764390dcf18f3dcad65c81d093883.zip
syslinux-3.84 version bump for bug #302811
(Portage version: 2.2_rc62/cvs/Linux x86_64)
Diffstat (limited to 'sys-boot')
-rw-r--r--sys-boot/syslinux/ChangeLog10
-rw-r--r--sys-boot/syslinux/metadata.xml4
-rw-r--r--sys-boot/syslinux/syslinux-3.84.ebuild45
3 files changed, 57 insertions, 2 deletions
diff --git a/sys-boot/syslinux/ChangeLog b/sys-boot/syslinux/ChangeLog
index ff048f9b4195..0cc6b5a4365c 100644
--- a/sys-boot/syslinux/ChangeLog
+++ b/sys-boot/syslinux/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-boot/syslinux
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/syslinux/ChangeLog,v 1.48 2009/11/01 15:37:22 jer Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/syslinux/ChangeLog,v 1.49 2010/02/16 12:47:45 chithanh Exp $
+
+*syslinux-3.84 (16 Feb 2010)
+
+ 16 Feb 2010; Chí-Thanh Christopher Nguyễn <chithanh@gentoo.org>
+ +syslinux-3.84.ebuild, metadata.xml:
+ Version bump for bug #302811, assign maintainership to me
*syslinux-3.83 (01 Nov 2009)
diff --git a/sys-boot/syslinux/metadata.xml b/sys-boot/syslinux/metadata.xml
index 96a2d586367d..e73f4a697523 100644
--- a/sys-boot/syslinux/metadata.xml
+++ b/sys-boot/syslinux/metadata.xml
@@ -1,5 +1,9 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
+<maintainer>
+ <email>chithanh@gentoo.org</email>
+ <name>Chí-Thanh Christopher Nguyễn</name>
+</maintainer>
<herd>base-system</herd>
</pkgmetadata>
diff --git a/sys-boot/syslinux/syslinux-3.84.ebuild b/sys-boot/syslinux/syslinux-3.84.ebuild
new file mode 100644
index 000000000000..464dc969dc3e
--- /dev/null
+++ b/sys-boot/syslinux/syslinux-3.84.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/syslinux/syslinux-3.84.ebuild,v 1.1 2010/02/16 12:47:45 chithanh Exp $
+
+inherit eutils
+
+DESCRIPTION="SysLinux, IsoLinux and PXELinux bootloader"
+HOMEPAGE="http://syslinux.zytor.com/"
+SRC_URI="mirror://kernel/linux/utils/boot/syslinux/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+IUSE=""
+
+RDEPEND="sys-fs/mtools
+ dev-perl/Crypt-PasswdMD5
+ dev-perl/Digest-SHA1"
+DEPEND="${RDEPEND}
+ dev-lang/nasm"
+
+# This ebuild is a departure from the old way of rebuilding everything in syslinux
+# This departure is necessary since hpa doesn't support the rebuilding of anything other
+# than the installers.
+
+# removed all the unpack/patching stuff since we aren't rebuilding the core stuff anymore
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${PN}-3.72-nopie.patch
+ # Don't prestrip, makes portage angry
+ epatch "${FILESDIR}"/${PN}-3.72-nostrip.patch
+
+ rm -f gethostip #bug 137081
+}
+
+src_compile() {
+ emake installer || die
+}
+
+src_install() {
+ emake INSTALLSUBDIRS=utils INSTALLROOT="${D}" MANDIR=/usr/share/man install || die
+ dodoc README NEWS TODO doc/*
+}