summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTony Vroon <chainsaw@gentoo.org>2008-07-21 23:21:19 +0000
committerTony Vroon <chainsaw@gentoo.org>2008-07-21 23:21:19 +0000
commitab3d31fda29cb6285378217d8612298cafc14fb5 (patch)
treef3732b96dbc40991f2721bf18770a618d0cecef3 /sys-boot
parentStable for HPPA (bug #229679). (diff)
downloadgentoo-2-ab3d31fda29cb6285378217d8612298cafc14fb5.tar.gz
gentoo-2-ab3d31fda29cb6285378217d8612298cafc14fb5.tar.bz2
gentoo-2-ab3d31fda29cb6285378217d8612298cafc14fb5.zip
Version bump, closes bug #203341. Hardened uclibc compile fix by Natanael Copa <natanael.copa@gmail.com>. Inhibit pre-stripping of binaries.
(Portage version: 2.2_rc1/cvs/Linux 2.6.26-05621-g807677f x86_64)
Diffstat (limited to 'sys-boot')
-rw-r--r--sys-boot/syslinux/ChangeLog11
-rw-r--r--sys-boot/syslinux/files/syslinux-3.70-nopie.patch24
-rw-r--r--sys-boot/syslinux/files/syslinux-3.70-nostrip.patch36
-rw-r--r--sys-boot/syslinux/syslinux-1.76.ebuild6
-rw-r--r--sys-boot/syslinux/syslinux-3.70.ebuild43
5 files changed, 115 insertions, 5 deletions
diff --git a/sys-boot/syslinux/ChangeLog b/sys-boot/syslinux/ChangeLog
index 629972e33729..22f16f04f919 100644
--- a/sys-boot/syslinux/ChangeLog
+++ b/sys-boot/syslinux/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-boot/syslinux
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/syslinux/ChangeLog,v 1.33 2007/10/24 18:12:17 beandog Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/syslinux/ChangeLog,v 1.34 2008/07/21 23:21:18 chainsaw Exp $
+
+*syslinux-3.70 (21 Jul 2008)
+
+ 21 Jul 2008; <chainsaw@gentoo.org> +files/syslinux-3.70-nopie.patch,
+ +files/syslinux-3.70-nostrip.patch, +syslinux-3.70.ebuild:
+ Version bump, closes bug #203341. Hardened uclibc compile fix by Natanael
+ Copa <natanael.copa@gmail.com>. Inhibit pre-stripping of binaries.
*syslinux-3.52 (24 Oct 2007)
*syslinux-3.51 (24 Oct 2007)
diff --git a/sys-boot/syslinux/files/syslinux-3.70-nopie.patch b/sys-boot/syslinux/files/syslinux-3.70-nopie.patch
new file mode 100644
index 000000000000..5d0ccaa71715
--- /dev/null
+++ b/sys-boot/syslinux/files/syslinux-3.70-nopie.patch
@@ -0,0 +1,24 @@
+--- com32/libutil/Makefile.orig 2008-01-02 14:33:58 +0000
++++ com32/libutil/Makefile 2008-01-02 14:35:38 +0000
+@@ -34,7 +34,8 @@
+ gcc_ok = $(shell tmpf=$(TMPFILE); if gcc $(1) -c -x c /dev/null -o $$tmpf 2>/dev/null; \
+ then echo $(1); else echo $(2); fi; rm -f $$tmpf)
+
+-M32 := $(call gcc_ok,-m32,) $(call gcc_ok,-fno-stack-protector,)
++M32 := $(call gcc_ok,-m32,) $(call gcc_ok,-fno-stack-protector,) \
++ $(call gcc_ok,-nopie,) $(call gcc_ok,-fno-pie,)
+
+ CC = gcc
+ LD = ld -m elf_i386
+--- com32/modules/Makefile.orig 2008-01-02 14:42:12 +0000
++++ com32/modules/Makefile 2008-01-02 14:42:50 +0000
+@@ -19,7 +19,8 @@
+ gcc_ok = $(shell tmpf=$(TMPFILE); if gcc $(1) -c -x c /dev/null -o $$tmpf 2>/dev/null; \
+ then echo $(1); else echo $(2); fi; rm -f $$tmpf)
+
+-M32 := $(call gcc_ok,-m32,) $(call gcc_ok,-fno-stack-protector,)
++M32 := $(call gcc_ok,-m32,) $(call gcc_ok,-fno-stack-protector,) \
++ $(call gcc_ok,-nopie,) $(call gcc_ok,-fno-pie,)
+
+ CC = gcc
+ LD = ld -m elf_i386
diff --git a/sys-boot/syslinux/files/syslinux-3.70-nostrip.patch b/sys-boot/syslinux/files/syslinux-3.70-nostrip.patch
new file mode 100644
index 000000000000..22ff22057955
--- /dev/null
+++ b/sys-boot/syslinux/files/syslinux-3.70-nostrip.patch
@@ -0,0 +1,36 @@
+diff -uNr syslinux-3.70.ORIG/utils/Makefile syslinux-3.70/utils/Makefile
+--- syslinux-3.70.ORIG/utils/Makefile 2008-07-22 00:01:51.000000000 +0100
++++ syslinux-3.70/utils/Makefile 2008-07-22 00:04:33.000000000 +0100
+@@ -18,7 +18,7 @@
+ include $(topdir)/MCONFIG
+
+ CFLAGS = -W -Wall -Os -fomit-frame-pointer -D_FILE_OFFSET_BITS=64
+-LDFLAGS = -O2 -s
++LDFLAGS = -O2
+
+ TARGETS = mkdiskimage gethostip
+ ASIS = keytab-lilo lss16toppm md5pass ppmtolss16 sha1pass syslinux2ansi
+diff -uNr syslinux-3.70.ORIG/linux/Makefile syslinux-3.70/linux/Makefile
+--- syslinux-3.70.ORIG/linux/Makefile 2008-07-22 00:07:51.000000000 +0100
++++ syslinux-3.70/linux/Makefile 2008-07-22 00:10:33.000000000 +0100
+@@ -10,7 +10,7 @@
+ OPTFLAGS = -g -Os
+ INCLUDES = -I. -I.. -I../libinstaller
+ CFLAGS = -W -Wall -D_FILE_OFFSET_BITS=64 $(OPTFLAGS) $(INCLUDES)
+-LDFLAGS = $(LDHASH) -s
++LDFLAGS = $(LDHASH)
+
+ SRCS = syslinux.c \
+ ../libinstaller/syslxmod.c \
+diff -uNr syslinux-3.70.ORIG/mtools/Makefile syslinux-3.70/mtools/Makefile
+--- syslinux-3.70.ORIG/mtools/Makefile 2008-07-22 00:12:48.000000000 +0100
++++ syslinux-3.70/mtools/Makefile 2008-07-22 00:13:56.000000000 +0100
+@@ -10,7 +10,7 @@
+ OPTFLAGS = -g -Os
+ INCLUDES = -I. -I.. -I../libfat -I../libinstaller
+ CFLAGS = -W -Wall -D_FILE_OFFSET_BITS=64 $(OPTFLAGS) $(INCLUDES)
+-LDFLAGS = $(LDHASH) -s
++LDFLAGS = $(LDHASH)
+
+ SRCS = syslinux.c \
+ ../libinstaller/syslxmod.c \
diff --git a/sys-boot/syslinux/syslinux-1.76.ebuild b/sys-boot/syslinux/syslinux-1.76.ebuild
index 0c5a0a478a0e..556ce4a9c3ac 100644
--- a/sys-boot/syslinux/syslinux-1.76.ebuild
+++ b/sys-boot/syslinux/syslinux-1.76.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/syslinux/syslinux-1.76.ebuild,v 1.1 2005/01/10 00:26:54 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/syslinux/syslinux-1.76.ebuild,v 1.2 2008/07/21 23:21:18 chainsaw Exp $
DESCRIPTION="SysLinux, IsoLinux and PXELinux bootloader"
HOMEPAGE="http://syslinux.zytor.com/"
@@ -16,7 +16,7 @@ RDEPEND=""
src_unpack() {
unpack ${A}
- cd ${S}
+ cd "${S}"
sed -i '/^#/s:^#: #:' memdisk/init.S16 || die "fixing # comments"
}
diff --git a/sys-boot/syslinux/syslinux-3.70.ebuild b/sys-boot/syslinux/syslinux-3.70.ebuild
new file mode 100644
index 000000000000..2d9f9886f276
--- /dev/null
+++ b/sys-boot/syslinux/syslinux-3.70.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/syslinux/syslinux-3.70.ebuild,v 1.1 2008/07/21 23:21:18 chainsaw Exp $
+
+inherit eutils
+
+DESCRIPTION="SysLinux, IsoLinux and PXELinux bootloader"
+HOMEPAGE="http://syslinux.zytor.com/"
+SRC_URI="mirror://kernel/linux/utils/boot/syslinux/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+IUSE=""
+
+RDEPEND="sys-fs/mtools"
+DEPEND="${RDEPEND}
+ dev-lang/nasm"
+
+# This ebuild is a departure from the old way of rebuilding everything in syslinux
+# This departure is necessary since hpa doesn't support the rebuilding of anything other
+# than the installers.
+
+# removed all the unpack/patching stuff since we aren't rebuilding the core stuff anymore
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ # Actually compile on uclibc hardened
+ epatch "${FILESDIR}/${P}-nopie.patch"
+ # Don't prestrip, makes portage angry
+ epatch "${FILESDIR}/${P}-nostrip.patch"
+ rm -f gethostip #137081
+}
+
+src_compile() {
+ emake installer || die
+}
+
+src_install() {
+ emake INSTALLROOT="${D}" install || die
+ dodoc README NEWS TODO doc/*
+}