summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2006-10-21 22:46:44 +0000
committerMike Frysinger <vapier@gentoo.org>2006-10-21 22:46:44 +0000
commitf61c072f8e1fef790cad060858eb1636c62462c0 (patch)
treedc5f5cd845f407b616722f7c3db43cd12d0b2edf /sys-boot
parentold (diff)
downloadgentoo-2-f61c072f8e1fef790cad060858eb1636c62462c0.tar.gz
gentoo-2-f61c072f8e1fef790cad060858eb1636c62462c0.tar.bz2
gentoo-2-f61c072f8e1fef790cad060858eb1636c62462c0.zip
Version bump #152232 by Arthur Koziel.
(Portage version: 2.1.2_pre3-r5)
Diffstat (limited to 'sys-boot')
-rw-r--r--sys-boot/grub/ChangeLog7
-rw-r--r--sys-boot/grub/files/digest-grub-1.953
-rw-r--r--sys-boot/grub/grub-1.95.ebuild36
3 files changed, 45 insertions, 1 deletions
diff --git a/sys-boot/grub/ChangeLog b/sys-boot/grub/ChangeLog
index 8191208736f6..b41d1c20d91b 100644
--- a/sys-boot/grub/ChangeLog
+++ b/sys-boot/grub/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-boot/grub
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/ChangeLog,v 1.67 2006/09/08 06:13:23 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/ChangeLog,v 1.68 2006/10/21 22:46:43 vapier Exp $
+
+*grub-1.95 (21 Oct 2006)
+
+ 21 Oct 2006; Mike Frysinger <vapier@gentoo.org> +grub-1.95.ebuild:
+ Version bump #152232 by Arthur Koziel.
*grub-0.97-r3 (08 Sep 2006)
diff --git a/sys-boot/grub/files/digest-grub-1.95 b/sys-boot/grub/files/digest-grub-1.95
new file mode 100644
index 000000000000..c1e0de7acf69
--- /dev/null
+++ b/sys-boot/grub/files/digest-grub-1.95
@@ -0,0 +1,3 @@
+MD5 4ea234d8fc5d551f61bc65e553e51399 grub-1.95.tar.gz 519269
+RMD160 bce7d8790b47f3ce7fa4ce7ac61242cc242ad5da grub-1.95.tar.gz 519269
+SHA256 d40c88f1da2919c252500c4cae0de6e9e1a368695117a7a23c4e07d2b4b9b769 grub-1.95.tar.gz 519269
diff --git a/sys-boot/grub/grub-1.95.ebuild b/sys-boot/grub/grub-1.95.ebuild
new file mode 100644
index 000000000000..3bec7fdfe868
--- /dev/null
+++ b/sys-boot/grub/grub-1.95.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/grub-1.95.ebuild,v 1.1 2006/10/21 22:46:44 vapier Exp $
+
+inherit mount-boot eutils flag-o-matic toolchain-funcs
+
+DESCRIPTION="GNU GRUB 2 boot loader"
+HOMEPAGE="http://www.gnu.org/software/grub/"
+SRC_URI="mirror://gentoo/${P}.tar.gz
+ ftp://alpha.gnu.org/gnu/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="2"
+KEYWORDS="-*"
+IUSE="static netboot custom-cflags"
+
+DEPEND=">=sys-libs/ncurses-5.2-r5
+ dev-libs/lzo"
+PROVIDE="virtual/bootloader"
+
+src_compile() {
+ use amd64 && multilib_toolchain_setup x86
+ use custom-cflags || unset CFLAGS LDFLAGS
+ use static && append-ldflags -static
+
+ econf \
+ --prefix=/ \
+ --datadir=/usr/lib \
+ || die "econf failed"
+ emake || die "making regular stuff"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc AUTHORS ChangeLog NEWS README THANKS TODO
+}