summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2013-12-07 08:03:34 +0000
committerJustin Lecher <jlec@gentoo.org>2013-12-07 08:03:34 +0000
commit19beeebe16b08d3e1e715fe8b7b52ac33cc928d2 (patch)
tree4f46428b693957a8be7629a00393c44acb1cc440 /sys-cluster/fence-agents
parentVersion bump (diff)
downloadgentoo-2-19beeebe16b08d3e1e715fe8b7b52ac33cc928d2.tar.gz
gentoo-2-19beeebe16b08d3e1e715fe8b7b52ac33cc928d2.tar.bz2
gentoo-2-19beeebe16b08d3e1e715fe8b7b52ac33cc928d2.zip
sys-cluster/fence-agents: Add python support correctly
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key B9D4F231BD1558AB!)
Diffstat (limited to 'sys-cluster/fence-agents')
-rw-r--r--sys-cluster/fence-agents/ChangeLog8
-rw-r--r--sys-cluster/fence-agents/fence-agents-3.1.5-r2.ebuild72
-rw-r--r--sys-cluster/fence-agents/metadata.xml4
3 files changed, 81 insertions, 3 deletions
diff --git a/sys-cluster/fence-agents/ChangeLog b/sys-cluster/fence-agents/ChangeLog
index 77f96d8634eb..556510effd50 100644
--- a/sys-cluster/fence-agents/ChangeLog
+++ b/sys-cluster/fence-agents/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-cluster/fence-agents
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/fence-agents/ChangeLog,v 1.2 2013/03/11 13:58:49 ultrabug Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/fence-agents/ChangeLog,v 1.3 2013/12/07 08:03:34 jlec Exp $
+
+*fence-agents-3.1.5-r2 (07 Dec 2013)
+
+ 07 Dec 2013; Justin Lecher <jlec@gentoo.org> +fence-agents-3.1.5-r2.ebuild,
+ metadata.xml:
+ Add python support correctly
*fence-agents-3.1.5-r1 (11 Mar 2013)
diff --git a/sys-cluster/fence-agents/fence-agents-3.1.5-r2.ebuild b/sys-cluster/fence-agents/fence-agents-3.1.5-r2.ebuild
new file mode 100644
index 000000000000..8b4fecf09a41
--- /dev/null
+++ b/sys-cluster/fence-agents/fence-agents-3.1.5-r2.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/fence-agents/fence-agents-3.1.5-r2.ebuild,v 1.1 2013/12/07 08:03:34 jlec Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_6,2_7} )
+
+inherit multilib python-any-r1 versionator
+
+CLUSTER_RELEASE="${PV}"
+MY_P="cluster-${CLUSTER_RELEASE}"
+
+MAJ_PV="$(get_major_version)"
+MIN_PV="$(get_version_component_range 2-3)"
+
+DESCRIPTION="Cluster Fencing Agents"
+HOMEPAGE="https://fedorahosted.org/cluster/wiki/HomePage"
+SRC_URI="https://fedorahosted.org/releases/f/e/${PN}/${PN}-${PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="~sys-cluster/libccs-${PV}"
+DEPEND="${RDEPEND}
+ ${PYTHON_DEPS}
+ dev-libs/libxslt
+ $(python_gen_any_dep '
+ dev-python/pexpect[${PYTHON_USEDEP}]
+ dev-python/pycurl[${PYTHON_USEDEP}]
+ dev-python/suds[${PYTHON_USEDEP}]
+ ')"
+
+src_configure() {
+ econf \
+ --docdir=/usr/share/doc/${P} \
+ --libdir=/usr/$(get_libdir) \
+ --localstatedir=/var
+}
+
+src_install() {
+ default
+ # dont force /var/run creation on installation wrt #451798
+ rm -rf "${ED}"/var/run || die
+}
+
+pkg_postinst() {
+ if [[ "${EROOT}" != "/" ]] ; then
+ ewarn "You have to run 'ccs_update_schema' in the chroot-environment"
+ ewarn "to update the schema file for the cluster configuration."
+ ewarn "Otherwise you will not be able to define ressources."
+ else
+ elog "Running ccs_update_schema to update the configuration file schema"
+ ccs_update_schema -v -f
+ fi
+}
+
+pkg_postrm() {
+ if [[ "${EROOT}" != "/" ]] ; then
+ ewarn "You have to run 'ccs_update_schema' in the chroot-environment"
+ ewarn "to update the schema file for the cluster configuration."
+ ewarn "Otherwise you may be able to define ressources even though they"
+ ewarn "are not present anymore."
+ else
+ elog "Running ccs_update_schema to update the configuration file schema"
+ ccs_update_schema -v -f
+ fi
+}
diff --git a/sys-cluster/fence-agents/metadata.xml b/sys-cluster/fence-agents/metadata.xml
index b5f41de83d3a..392a5958b59d 100644
--- a/sys-cluster/fence-agents/metadata.xml
+++ b/sys-cluster/fence-agents/metadata.xml
@@ -1,6 +1,6 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <herd>cluster</herd>
- <longdescription>Cluster Fencing Agents</longdescription>
+ <herd>cluster</herd>
+ <longdescription>Cluster Fencing Agents</longdescription>
</pkgmetadata>