summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2010-02-23 00:31:17 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2010-02-23 00:31:17 +0000
commitd8446bb15d027036b0bd721a58fdf6040b2fb2f6 (patch)
treee0ad31646ca9130a90a123c0c2f8156724af3e5e /sys-cluster/gearmand
parentversion bump (diff)
downloadgentoo-2-d8446bb15d027036b0bd721a58fdf6040b2fb2f6.tar.gz
gentoo-2-d8446bb15d027036b0bd721a58fdf6040b2fb2f6.tar.bz2
gentoo-2-d8446bb15d027036b0bd721a58fdf6040b2fb2f6.zip
Version bump. Update init scripts. Proxy commit for Pavel Stratil.
(Portage version: 2.2_rc63/cvs/Linux x86_64)
Diffstat (limited to 'sys-cluster/gearmand')
-rw-r--r--sys-cluster/gearmand/ChangeLog9
-rw-r--r--sys-cluster/gearmand/files/gearmand.conf.d3
-rw-r--r--sys-cluster/gearmand/files/gearmand.init.d3
-rw-r--r--sys-cluster/gearmand/gearmand-0.12.ebuild100
-rw-r--r--sys-cluster/gearmand/metadata.xml4
5 files changed, 117 insertions, 2 deletions
diff --git a/sys-cluster/gearmand/ChangeLog b/sys-cluster/gearmand/ChangeLog
index 8228c1384c16..e0521b4f94f9 100644
--- a/sys-cluster/gearmand/ChangeLog
+++ b/sys-cluster/gearmand/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-cluster/gearmand
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/gearmand/ChangeLog,v 1.5 2010/02/09 19:18:39 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/gearmand/ChangeLog,v 1.6 2010/02/23 00:31:16 scarabeus Exp $
+
+*gearmand-0.12 (23 Feb 2010)
+
+ 23 Feb 2010; Tomáš Chvátal <scarabeus@gentoo.org>
+ +gearmand-0.12.ebuild, files/gearmand.conf.d, files/gearmand.init.d,
+ metadata.xml:
+ Version bump. Update init scripts. Proxy commit for Pavel Stratil.
09 Feb 2010; Diego E. Pettenò <flameeyes@gentoo.org>
gearmand-0.11-r2.ebuild:
diff --git a/sys-cluster/gearmand/files/gearmand.conf.d b/sys-cluster/gearmand/files/gearmand.conf.d
index 9786d2c517c4..aeb49d5c6b9e 100644
--- a/sys-cluster/gearmand/files/gearmand.conf.d
+++ b/sys-cluster/gearmand/files/gearmand.conf.d
@@ -1,7 +1,8 @@
# /etc/conf.d/gearmand: config file for /etc/init.d/gearmand
# Persistent queue store
-# The following queue stores are available: drizzle|memcache|mysql|postgre|sqlite|none
+# The following queue stores are available:
+# drizzle|memcache|mysql|postgre|sqlite|tokyocabinet|none
# If you do not wish to use persistent queues, leave this option commented out.
# Note that persistent queue mechanisms are mutally exclusive.
#PERSISTENT=""
diff --git a/sys-cluster/gearmand/files/gearmand.init.d b/sys-cluster/gearmand/files/gearmand.init.d
index 895021e11f4c..10ec883f8a35 100644
--- a/sys-cluster/gearmand/files/gearmand.init.d
+++ b/sys-cluster/gearmand/files/gearmand.init.d
@@ -49,6 +49,9 @@ start() {
[ ${PERSISTENT_TABLE} ] && ewarn "Libpq doesn't recognise 'table' parameter."
[ ${PERSISTENT_SOCKET} ] && ewarn "Libpq doesn't recognise 'socket' parameter. If no host is set, it automatically falls back to a socket."
;;
+ tokyocabinet)
+ GEARMAND_PARAMS="${GEARMAND_PARAMS} -q libtokyocabinet --libtokyocabinet-file=${PERSISTENT_FILE}"
+ ;;
sqlite)
GEARMAND_PARAMS="${GEARMAND_PARAMS} -q libsqlite3 --libsqlite3-db=${PERSISTENT_FILE}"
;;
diff --git a/sys-cluster/gearmand/gearmand-0.12.ebuild b/sys-cluster/gearmand/gearmand-0.12.ebuild
new file mode 100644
index 000000000000..123197efa679
--- /dev/null
+++ b/sys-cluster/gearmand/gearmand-0.12.ebuild
@@ -0,0 +1,100 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/gearmand/gearmand-0.12.ebuild,v 1.1 2010/02/23 00:31:16 scarabeus Exp $
+
+EAPI=2
+
+inherit flag-o-matic libtool
+
+DESCRIPTION="Generic framework to farm out work to other machines"
+HOMEPAGE="http://www.gearman.org/"
+SRC_URI="http://launchpad.net/gearmand/trunk/${PV}/+download/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="debug tcmalloc +memcache drizzle sqlite tokyocabinet" # postgres
+# postgresql support is broken right now so keep it disabled
+
+RDEPEND="dev-libs/libevent
+ || ( >=sys-apps/util-linux-2.16 <sys-libs/e2fsprogs-libs-1.41.8 )
+ tcmalloc? ( dev-util/google-perftools )
+ memcache? ( dev-libs/libmemcached )
+ drizzle? ( dev-db/libdrizzle )
+ sqlite? ( dev-db/sqlite:3 )
+ tokyocabinet? ( dev-db/tokyocabinet )"
+ #postgres? ( dev-db/postgresql-base )"
+DEPEND="${RDEPEND}"
+
+pkg_setup() {
+ enewuser gearmand -1 -1 /dev/null nogroup
+}
+
+src_prepare() {
+ elibtoolize
+}
+
+src_configure() {
+ # Don't ever use --enable-assert since configure.ac is broken, and
+ # only does --disable-assert correctly.
+ if use debug; then
+ # Since --with-debug would turn off optimisations as well as
+ # enabling debug, we just enable debug through the
+ # preprocessor then.
+ append-flags -DDEBUG
+
+ else
+ myconf="${myconf} --disable-assert"
+ fi
+
+ #$(use_enable postgres libpq)
+ econf \
+ --disable-static \
+ --disable-dependency-tracking \
+ --disable-mtmalloc \
+ --disable-libpq \
+ $(use_enable tcmalloc) \
+ $(use_enable memcache libmemcached) \
+ $(use_enable drizzle libdrizzle) \
+ $(use_enable sqlite libsqlite3) \
+ $(use_enable tokyocabinet libtokyocabinet)
+}
+
+src_test() {
+ # Since libtool is stupid and doesn't discard /usr/lib64 from the
+ # load path, we'd end up testing against the installed copy of
+ # gearmand (bad).
+ #
+ # We thus cheat and "fix" the scripts by hand.
+ sed -i -e '/LD_LIBRARY_PATH=/s|/usr/lib64:||' "${S}"/tests/*_test \
+ || die "test fixing failed"
+
+ emake check || die "tests failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "install failed"
+
+ dodoc README AUTHORS ChangeLog || die "dodoc failed"
+
+ newinitd "${FILESDIR}"/gearmand.init.d gearmand || die
+ newconfd "${FILESDIR}"/gearmand.conf.d gearmand || die
+
+ keepdir /var/run/gearmand || die
+ fperms 0755 /var/run/gearmand || die
+ fowners gearmand:nogroup /var/run/gearmand || die
+
+ keepdir /var/log/gearmand || die
+ fperms 0755 /var/log/gearmand || die
+ fowners gearmand /var/log/gearmand || die
+
+ find "${D}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ elog ""
+ elog "Unless you set the PERSISTENT_TABLE option in"
+ elog "/etc/conf.d/gearmand, Gearmand will use table 'queue'."
+ elog "If such table doesn't exist, Gearmand will create it for you"
+ elog ""
+}
diff --git a/sys-cluster/gearmand/metadata.xml b/sys-cluster/gearmand/metadata.xml
index 1a3565061d04..3a668c81443d 100644
--- a/sys-cluster/gearmand/metadata.xml
+++ b/sys-cluster/gearmand/metadata.xml
@@ -25,5 +25,9 @@
Support <pkg>dev-db/libdrizzle</pkg> for the queue storage. This
also adds support for MySQL storage.
</flag>
+ <flag name="tokyocabinet">
+ Support <pkg>dev-db/tokyocabinet</pkg> for the queue storage.
+ </flag>
+
</use>
</pkgmetadata>