summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonnie Berkholz <spyderous@gentoo.org>2004-09-23 09:07:40 +0000
committerDonnie Berkholz <spyderous@gentoo.org>2004-09-23 09:07:40 +0000
commit0ca3b12b4de7756440af447f1f5f424e6205d90f (patch)
tree51572cf1b732ea3f2da082ba2fdca44435dabe0c /sys-cluster/lam-mpi
parentclean older ebuild (Manifest recommit) (diff)
downloadgentoo-2-0ca3b12b4de7756440af447f1f5f424e6205d90f.tar.gz
gentoo-2-0ca3b12b4de7756440af447f1f5f424e6205d90f.tar.bz2
gentoo-2-0ca3b12b4de7756440af447f1f5f424e6205d90f.zip
Bump. See HISTORY in source tarball for changes.
Diffstat (limited to 'sys-cluster/lam-mpi')
-rw-r--r--sys-cluster/lam-mpi/ChangeLog7
-rw-r--r--sys-cluster/lam-mpi/files/digest-lam-mpi-7.11
-rw-r--r--sys-cluster/lam-mpi/lam-mpi-7.1.ebuild73
3 files changed, 80 insertions, 1 deletions
diff --git a/sys-cluster/lam-mpi/ChangeLog b/sys-cluster/lam-mpi/ChangeLog
index cde703989010..4aafe6397291 100644
--- a/sys-cluster/lam-mpi/ChangeLog
+++ b/sys-cluster/lam-mpi/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-cluster/lam-mpi
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/lam-mpi/ChangeLog,v 1.22 2004/09/19 21:44:21 tantive Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/lam-mpi/ChangeLog,v 1.23 2004/09/23 09:07:40 spyderous Exp $
+
+*lam-mpi-7.1 (23 Sep 2004)
+
+ 23 Sep 2004; Donnie Berkholz <spyderous@gentoo.org>; +lam-mpi-7.1.ebuild:
+ Bump. See HISTORY in source tarball for changes.
19 Sep 2004; Michael Imhof <tantive@gentoo.org> lam-mpi-7.0.4-r1.ebuild:
Added local use flag for f77.
diff --git a/sys-cluster/lam-mpi/files/digest-lam-mpi-7.1 b/sys-cluster/lam-mpi/files/digest-lam-mpi-7.1
new file mode 100644
index 000000000000..522a21adbf5b
--- /dev/null
+++ b/sys-cluster/lam-mpi/files/digest-lam-mpi-7.1
@@ -0,0 +1 @@
+MD5 6465152e043ffedd2bed146142659be8 lam-7.1.tar.bz2 7542937
diff --git a/sys-cluster/lam-mpi/lam-mpi-7.1.ebuild b/sys-cluster/lam-mpi/lam-mpi-7.1.ebuild
new file mode 100644
index 000000000000..5d1c181e2be9
--- /dev/null
+++ b/sys-cluster/lam-mpi/lam-mpi-7.1.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/lam-mpi/lam-mpi-7.1.ebuild,v 1.1 2004/09/23 09:07:40 spyderous Exp $
+
+IUSE="crypt"
+
+MY_P=${P/-mpi}
+S=${WORKDIR}/${MY_P}
+
+DESCRIPTION="the LAM MPI parallel computing environment"
+SRC_URI="http://www.lam-mpi.org/download/files/${MY_P}.tar.bz2"
+HOMEPAGE="http://www.lam-mpi.org"
+
+DEPEND="virtual/libc"
+# we need ssh if we want to use it instead of rsh
+RDEPEND="${DEPEND}
+ crypt? ( net-misc/openssh )
+ !crypt? ( net-misc/netkit-rsh )
+ !sys-cluster/mpich"
+
+SLOT="6"
+KEYWORDS="~x86"
+LICENSE="as-is"
+
+src_unpack() {
+ unpack ${A}
+
+ cd ${S}/romio/util/
+ sed -i "s|docdir=\"\$datadir/lam/doc\"|docdir=\"${D}/usr/share/doc/${PF}\"|" romioinstall.in
+}
+
+src_compile() {
+
+ local myconf
+
+ if use crypt; then
+ myconf="--with-rsh=ssh"
+ else
+ myconf="--with-rsh=rsh"
+ fi
+
+ econf \
+ --sysconfdir=/etc/lam-mpi \
+ --enable-shared \
+ --enable-long-long \
+ --enable-threads=posix \
+ --enable-languages=c,c++,f77 \
+ --disable-checking \
+ --enable-cstdio=stdio \
+ --with-system-zlib \
+ --without-fc \
+ ${myconf} || die
+
+ # sometimes emake doesn't finish since it gets ahead of itself :)
+
+ make || die
+}
+
+src_install () {
+
+ make DESTDIR="${D}" install || die
+
+ #need to correct the produced absolute symlink
+ cd ${D}/usr/include
+ rm mpi++.h
+ ln -sf mpi2c++/mpi++.h mpi++.h
+
+ # There are a bunch more tex docs we could make and install too,
+ # but they might be replicated in the pdf.
+ dodoc README HISTORY LICENSE VERSION
+ cd ${S}/doc
+ dodoc {user,install}.pdf
+}