summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Bronder <jsbronder@gentoo.org>2009-08-13 01:41:11 +0000
committerJustin Bronder <jsbronder@gentoo.org>2009-08-13 01:41:11 +0000
commit8e380d4677adbc3187df1a0c9857437f8ea69b4a (patch)
treef8ac463555592793615130750854db9cf6cb71c4 /sys-cluster/openmpi
parentFix reading of memory (bug #281249). (diff)
downloadgentoo-2-8e380d4677adbc3187df1a0c9857437f8ea69b4a.tar.gz
gentoo-2-8e380d4677adbc3187df1a0c9857437f8ea69b4a.tar.bz2
gentoo-2-8e380d4677adbc3187df1a0c9857437f8ea69b4a.zip
Bump EAPI. Add the vt use flag for VampirTrace. Add blocker against dev-libs/libotf when vt is enabled #265710.
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'sys-cluster/openmpi')
-rw-r--r--sys-cluster/openmpi/ChangeLog8
-rw-r--r--sys-cluster/openmpi/metadata.xml1
-rw-r--r--sys-cluster/openmpi/openmpi-1.3.3.ebuild108
3 files changed, 116 insertions, 1 deletions
diff --git a/sys-cluster/openmpi/ChangeLog b/sys-cluster/openmpi/ChangeLog
index d4f00c81513c..f61d770ed1ff 100644
--- a/sys-cluster/openmpi/ChangeLog
+++ b/sys-cluster/openmpi/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-cluster/openmpi
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/openmpi/ChangeLog,v 1.50 2009/07/05 14:41:08 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/openmpi/ChangeLog,v 1.51 2009/08/13 01:41:11 jsbronder Exp $
+
+*openmpi-1.3.3 (13 Aug 2009)
+
+ 13 Aug 2009; Justin Bronder <jsbronder@gentoo.org> +openmpi-1.3.3.ebuild:
+ Bump EAPI. Add the vt use flag for VampirTrace. Add blocker against
+ dev-libs/libotf when vt is enabled #265710.
05 Jul 2009; Markus Meier <maekke@gentoo.org> openmpi-1.2.9.ebuild:
amd64 stable, bug #266555
diff --git a/sys-cluster/openmpi/metadata.xml b/sys-cluster/openmpi/metadata.xml
index 55fde8d86d3f..55ecc51ff6d4 100644
--- a/sys-cluster/openmpi/metadata.xml
+++ b/sys-cluster/openmpi/metadata.xml
@@ -11,5 +11,6 @@
<flag name='pbs'>Add support for the Portable Batch System (PBS)</flag>
<flag name='romio'>Build the ROMIO MPI-IO component</flag>
<flag name='mpi-threads'>Enable MPI_THREAD_MULTIPLE</flag>
+ <flag name='vt'>Enable bundled VampirTrace support</flag>
</use>
</pkgmetadata>
diff --git a/sys-cluster/openmpi/openmpi-1.3.3.ebuild b/sys-cluster/openmpi/openmpi-1.3.3.ebuild
new file mode 100644
index 000000000000..f5e309d28174
--- /dev/null
+++ b/sys-cluster/openmpi/openmpi-1.3.3.ebuild
@@ -0,0 +1,108 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/openmpi/openmpi-1.3.3.ebuild,v 1.1 2009/08/13 01:41:11 jsbronder Exp $
+
+EAPI=2
+inherit eutils multilib flag-o-matic toolchain-funcs fortran
+
+MY_P=${P/-mpi}
+S=${WORKDIR}/${MY_P}
+
+DESCRIPTION="A high-performance message passing library (MPI)"
+HOMEPAGE="http://www.open-mpi.org"
+SRC_URI="http://www.open-mpi.org/software/ompi/v1.3/downloads/${MY_P}.tar.bz2"
+LICENSE="BSD"
+SLOT="0"
+RESTRICT="mpi-threads? ( test )"
+KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="+cxx fortran heterogeneous ipv6 mpi-threads pbs romio threads vt"
+RDEPEND="pbs? ( sys-cluster/torque )
+ vt? ( !dev-libs/libotf )
+ !sys-cluster/mpich
+ !sys-cluster/lam-mpi
+ !sys-cluster/mpich2
+ !sys-cluster/mpiexec"
+DEPEND="${RDEPEND}"
+
+pkg_setup() {
+ if use mpi-threads; then
+ ewarn
+ ewarn "WARNING: use of MPI_THREAD_MULTIPLE is still disabled by"
+ ewarn "default and officially unsupported by upstream."
+ ewarn "You may stop now and set USE=-mpi-threads"
+ ewarn
+ epause 5
+ fi
+
+ elog
+ elog "OpenMPI has an overwhelming count of configuration options."
+ elog "Don't forget the EXTRA_ECONF environment variable can let you"
+ elog "specify configure options if you find them necessary."
+ elog
+
+ if use fortran; then
+ FORTRAN="g77 gfortran ifc"
+ fortran_pkg_setup
+ fi
+}
+
+src_prepare() {
+ # Necessary for scalibility, see
+ # http://www.open-mpi.org/community/lists/users/2008/09/6514.php
+ if use threads; then
+ echo 'oob_tcp_listen_mode = listen_thread' \
+ >> opal/etc/openmpi-mca-params.conf
+ fi
+}
+
+src_configure() {
+ local myconf="
+ --sysconfdir=/etc/${PN}
+ --without-xgrid
+ --enable-pretty-print-stacktrace
+ --enable-orterun-prefix-by-default
+ --without-slurm"
+
+ if use mpi-threads; then
+ myconf="${myconf}
+ --enable-mpi-threads
+ --enable-progress-threads"
+ fi
+
+ if use fortran; then
+ if [[ "${FORTRANC}" = "g77" ]]; then
+ myconf="${myconf} --disable-mpi-f90"
+ elif [[ "${FORTRANC}" = "gfortran" ]]; then
+ # Because that's just a pain in the butt.
+ myconf="${myconf} --with-wrapper-fflags=-I/usr/include"
+ elif [[ "${FORTRANC}" = if* ]]; then
+ # Enabled here as gfortran compile times are huge with this enabled.
+ myconf="${myconf} --with-mpi-f90-size=medium"
+ fi
+ else
+ myconf="${myconf}
+ --disable-mpi-f90
+ --disable-mpi-f77"
+ fi
+
+ ! use vt && myconf="${myconf} --enable-contrib-no-build=vt"
+
+ econf ${myconf} \
+ $(use_enable cxx mpi-cxx) \
+ $(use_enable romio io-romio) \
+ $(use_enable heterogeneous) \
+ $(use_with pbs tm) \
+ $(use_enable ipv6) \
+ || die "econf failed"
+}
+
+src_install () {
+ emake DESTDIR="${D}" install || die "make install failed"
+ dodoc README AUTHORS NEWS VERSION
+}
+
+src_test() {
+ # Doesn't work with the default src_test as the dry run (-n) fails.
+ cd "${S}"
+ emake -j1 check || die "emake check failed"
+}