summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonnie Berkholz <dberkholz@gentoo.org>2006-09-25 17:25:32 +0000
committerDonnie Berkholz <dberkholz@gentoo.org>2006-09-25 17:25:32 +0000
commit1f443d59ddcfca27c8e19b84ad012af243448161 (patch)
tree0d32c1bebf84569ee67a33a390bbbcb0f213b398 /sys-cluster/openpbs
parentStable on ppc wrt bug 149054 (diff)
downloadgentoo-2-1f443d59ddcfca27c8e19b84ad012af243448161.tar.gz
gentoo-2-1f443d59ddcfca27c8e19b84ad012af243448161.tar.bz2
gentoo-2-1f443d59ddcfca27c8e19b84ad012af243448161.zip
Fix for gcc4 from SuSE.
(Portage version: 2.1.2_pre1-r2)
Diffstat (limited to 'sys-cluster/openpbs')
-rw-r--r--sys-cluster/openpbs/ChangeLog6
-rw-r--r--sys-cluster/openpbs/files/2.3.16-gcc4.patch22
-rw-r--r--sys-cluster/openpbs/openpbs-2.3.16-r3.ebuild8
3 files changed, 33 insertions, 3 deletions
diff --git a/sys-cluster/openpbs/ChangeLog b/sys-cluster/openpbs/ChangeLog
index b36053e31178..69b799e42897 100644
--- a/sys-cluster/openpbs/ChangeLog
+++ b/sys-cluster/openpbs/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-cluster/openpbs
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/openpbs/ChangeLog,v 1.27 2006/09/25 03:05:07 dberkholz Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/openpbs/ChangeLog,v 1.28 2006/09/25 17:25:32 dberkholz Exp $
+
+ 25 Sep 2006; Donnie Berkholz <dberkholz@gentoo.org>;
+ +files/2.3.16-gcc4.patch, openpbs-2.3.16-r3.ebuild:
+ Fix for gcc4 from SuSE.
25 Sep 2006; Donnie Berkholz <dberkholz@gentoo.org>;
openpbs-2.3.16-r3.ebuild:
diff --git a/sys-cluster/openpbs/files/2.3.16-gcc4.patch b/sys-cluster/openpbs/files/2.3.16-gcc4.patch
new file mode 100644
index 000000000000..fc810d0bf268
--- /dev/null
+++ b/sys-cluster/openpbs/files/2.3.16-gcc4.patch
@@ -0,0 +1,22 @@
+--- src/include/attribute.h
++++ src/include/attribute.h
+@@ -211,6 +211,8 @@
+ };
+ typedef struct attribute_def attribute_def;
+
++extern struct attribute_def node_attr_def[]; /* node attributes defs */
++
+ /* Defines for type of Attribute based on data type */
+
+ #define ATR_TYPE_LONG 1 /* Long integer, also Boolean */
+--- src/include/pbs_nodes.h
++++ src/include/pbs_nodes.h
+@@ -196,7 +194,7 @@
+ ND_ATR_LAST /* WARNING: Must be the highest valued enum */
+ };
+
+-extern struct attribute_def node_attr_def[]; /* node attributes defs */
++/* extern struct attribute_def node_attr_def[]; */ /* node attributes defs */
+ extern struct pbsnode **pbsndmast; /* array of ptr to nodes */
+ extern struct pbsnode **pbsndlist; /* array of ptr to nodes */
+ extern int svr_totnodes; /* number of nodes (hosts) */
diff --git a/sys-cluster/openpbs/openpbs-2.3.16-r3.ebuild b/sys-cluster/openpbs/openpbs-2.3.16-r3.ebuild
index 65f5eaae27d0..1bd974c69acf 100644
--- a/sys-cluster/openpbs/openpbs-2.3.16-r3.ebuild
+++ b/sys-cluster/openpbs/openpbs-2.3.16-r3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/openpbs/openpbs-2.3.16-r3.ebuild,v 1.5 2006/09/25 03:05:07 dberkholz Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/openpbs/openpbs-2.3.16-r3.ebuild,v 1.6 2006/09/25 17:25:32 dberkholz Exp $
inherit eutils
@@ -45,13 +45,17 @@ src_unpack() {
epatch ${FILESDIR}/openpbs-gcc32.patch
# this thing doesn't use make install, but rather it's own install script
# fix it here so the install dirs are set to the ${D} directory
- cd buildutils
+ pushd buildutils
mv pbs_mkdirs.in pbs_mkdirs.in-orig
sed -e "s|prefix=@prefix@|prefix=\${D}@prefix@| ; \
s|PBS_SERVER_HOME=@PBS_SERVER_HOME@|PBS_SERVER_HOME=\${D}@PBS_SERVER_HOME@| ; \
s|PBS_DEFAULT_FILE=@PBS_DEFAULT_FILE@|PBS_DEFAULT_FILE=\${D}@PBS_DEFAULT_FILE@| ; \
s|PBS_ENVIRON=@PBS_ENVIRON@|PBS_ENVIRON=\${D}@PBS_ENVIRON@|" \
pbs_mkdirs.in-orig > pbs_mkdirs.in
+ popd
+
+ # Patch from SuSE srpm, found on rpmfind.net
+ epatch ${FILESDIR}/${PV}-gcc4.patch
}
src_compile() {