summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexys Jacob <ultrabug@gentoo.org>2011-07-08 13:47:33 +0000
committerAlexys Jacob <ultrabug@gentoo.org>2011-07-08 13:47:33 +0000
commit9eb9e49bf504e8e8a4fe5a6de39cd7aada927eeb (patch)
tree116be8aebea7d449aaa2dbadfc8d3817adca3a3b /sys-cluster/pacemaker
parentx86 stable per bug 374229 (diff)
downloadgentoo-2-9eb9e49bf504e8e8a4fe5a6de39cd7aada927eeb.tar.gz
gentoo-2-9eb9e49bf504e8e8a4fe5a6de39cd7aada927eeb.tar.bz2
gentoo-2-9eb9e49bf504e8e8a4fe5a6de39cd7aada927eeb.zip
Version bump.
(Portage version: 2.1.10.3/cvs/Linux x86_64)
Diffstat (limited to 'sys-cluster/pacemaker')
-rw-r--r--sys-cluster/pacemaker/ChangeLog8
-rw-r--r--sys-cluster/pacemaker/files/pacemaker-1.1.5-autotools.patch271
-rw-r--r--sys-cluster/pacemaker/pacemaker-1.1.5.ebuild86
3 files changed, 364 insertions, 1 deletions
diff --git a/sys-cluster/pacemaker/ChangeLog b/sys-cluster/pacemaker/ChangeLog
index 21ef18ee4373..2daa6b5e8b33 100644
--- a/sys-cluster/pacemaker/ChangeLog
+++ b/sys-cluster/pacemaker/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-cluster/pacemaker
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/pacemaker/ChangeLog,v 1.12 2011/07/05 07:28:53 ultrabug Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/pacemaker/ChangeLog,v 1.13 2011/07/08 13:47:33 ultrabug Exp $
+
+*pacemaker-1.1.5 (08 Jul 2011)
+
+ 08 Jul 2011; Ultrabug <ultrabug@gentoo.org> +pacemaker-1.1.5.ebuild,
+ +files/pacemaker-1.1.5-autotools.patch:
+ Version bump.
*pacemaker-1.0.11 (05 Jul 2011)
diff --git a/sys-cluster/pacemaker/files/pacemaker-1.1.5-autotools.patch b/sys-cluster/pacemaker/files/pacemaker-1.1.5-autotools.patch
new file mode 100644
index 000000000000..b4098eed2af4
--- /dev/null
+++ b/sys-cluster/pacemaker/files/pacemaker-1.1.5-autotools.patch
@@ -0,0 +1,271 @@
+--- a/configure.ac
++++ b/configure.ac
+@@ -1354,6 +1354,7 @@
+ if
+ $PKGCONFIG --exists $SERVICELOG
+ then
++ PKG_CHECK_MODULES([SERVICELOG], [servicelog-1])
+ SERVICELOG_EXISTS="yes"
+ fi
+ AC_MSG_RESULT($SERVICELOG_EXISTS)
+@@ -1366,6 +1367,7 @@
+ if
+ $PKGCONFIG --exists $OPENIPMI $SERVICELOG
+ then
++ PKG_CHECK_MODULES([OPENIPMI_SERVICELOG],[OpenIPMI OpenIPMIposix])
+ OPENIPMI_SERVICELOG_EXISTS="yes"
+ fi
+ AC_MSG_RESULT($OPENIPMI_SERVICELOG_EXISTS)
+--- a/mcp/Makefile.am
++++ b/mcp/Makefile.am
+@@ -34,7 +34,7 @@
+ noinst_HEADERS =
+
+ pacemakerd_SOURCES = pacemaker.c corosync.c
+-pacemakerd_LDADD = $(CLUSTERLIBS) $(top_builddir)/lib/common/libcrmcommon.la -lcfg -lconfdb
++pacemakerd_LDADD = $(top_builddir)/lib/common/libcrmcommon.la $(CLUSTERLIBS) -lcfg -lconfdb
+
+ %.8: %
+ echo Creating $@
+--- a/crmd/Makefile.am
++++ b/crmd/Makefile.am
+@@ -41,14 +41,13 @@
+ cib.c pengine.c tengine.c lrm.c \
+ utils.c misc.c te_events.c te_actions.c te_utils.c te_callbacks.c
+
+-crmd_LDADD = $(CLUSTERLIBS) -llrm \
+- $(top_builddir)/lib/fencing/libstonithd.la \
++crmd_LDADD = $(top_builddir)/lib/fencing/libstonithd.la \
+ $(top_builddir)/lib/transition/libtransitioner.la \
+ $(top_builddir)/lib/pengine/libpe_rules.la \
+ $(top_builddir)/lib/cib/libcib.la \
+ $(top_builddir)/lib/common/libcrmcluster.la \
+- $(top_builddir)/lib/common/libcrmcommon.la
+-
++ $(top_builddir)/lib/common/libcrmcommon.la \
++ $(CLUSTERLIBS) -llrm
+ if BUILD_XML_HELP
+ man8_MANS = crmd.8
+
+--- a/lib/common/Makefile.am
++++ b/lib/common/Makefile.am
+@@ -38,7 +38,7 @@
+ endif
+
+ libcrmcluster_la_LDFLAGS = -version-info 1:0:0
+-libcrmcluster_la_LIBADD = $(CLUSTERLIBS) libcrmcommon.la
++libcrmcluster_la_LIBADD = libcrmcommon.la $(CLUSTERLIBS)
+ libcrmcluster_la_DEPENDENCIES = libcrmcommon.la
+
+ # Can't use -Wcast-qual here because glib insists on pretending things are const
+@@ -51,7 +51,8 @@
+
+ libcrmcommon_la_SOURCES = ipc.c utils.c xml.c iso8601.c iso8601_fields.c remote.c mainloop.c
+
+-libcrmcommon_la_LDFLAGS = -version-info 2:0:0 $(GNUTLSLIBS)
++libcrmcommon_la_LDFLAGS = -version-info 2:0:0
++libcrmcommon_la_LIBADD = $(GNUTLSLIBS)
+
+ clean-generic:
+ rm -f *.log *.debug *.xml *~
+--- a/lib/plugins/lrm/Makefile.am
++++ b/lib/plugins/lrm/Makefile.am
+@@ -29,8 +29,8 @@
+ plugin_LTLIBRARIES = stonith.la
+
+ stonith_la_SOURCES = raexecstonith.c
+-stonith_la_LDFLAGS = -lpils -export-dynamic -module -avoid-version \
+- $(top_builddir)/lib/fencing/libstonithd.la -llrm
++stonith_la_LDFLAGS = -export-dynamic -module -avoid-version
++stonith_la_LIBADD = $(top_builddir)/lib/fencing/libstonithd.la -lpils -llrm
+
+ install-exec-local:
+ $(mkinstalldirs) $(DESTDIR)$(lrmdir)
+--- a/lib/fencing/Makefile.am
++++ b/lib/fencing/Makefile.am
+@@ -25,8 +25,8 @@
+ lib_LTLIBRARIES = libstonithd.la
+
+ libstonithd_la_SOURCES = st_client.c
+-libstonithd_la_LDFLAGS = -version-info 1:0:0 \
+- -lplumb -lstonith $(CLUSTERLIBS) \
+- $(top_builddir)/lib/common/libcrmcommon.la
++libstonithd_la_LDFLAGS = -version-info 1:0:0
++libstonithd_la_LIBADD = $(top_builddir)/lib/common/libcrmcommon.la \
++ -lplumb -lstonith $(CLUSTERLIBS)
+
+ AM_CFLAGS = $(INCLUDES)
+--- a/cib/Makefile.am
++++ b/cib/Makefile.am
+@@ -47,8 +47,8 @@
+ cib_SOURCES = io.c messages.c notify.c \
+ callbacks.c main.c remote.c common.c
+
+-cib_LDADD = $(COMMONLIBS) $(CRYPTOLIB) $(CLUSTERLIBS) \
+- $(top_builddir)/lib/common/libcrmcluster.la
++cib_LDADD = $(top_builddir)/lib/common/libcrmcluster.la \
++ $(COMMONLIBS) $(CRYPTOLIB) $(CLUSTERLIBS)
+
+ cibmon_SOURCES = cibmon.c
+ cibmon_LDADD = $(COMMONLIBS)
+--- a/tools/Makefile.am
++++ b/tools/Makefile.am
+@@ -62,8 +62,8 @@
+ noinst_HEADERS =
+
+ crmadmin_SOURCES = crmadmin.c
+-crmadmin_LDADD = $(COMMONLIBS) $(CLUSTERLIBS) \
+- $(top_builddir)/lib/pengine/libpe_status.la
++crmadmin_LDADD = $(top_builddir)/lib/pengine/libpe_status.la \
++ $(COMMONLIBS) $(CLUSTERLIBS)
+
+ crm_uuid_SOURCES = crm_uuid.c
+ crm_uuid_LDADD = $(top_builddir)/lib/common/libcrmcluster.la
+@@ -75,45 +75,45 @@
+ crm_shadow_LDADD = $(COMMONLIBS)
+
+ crm_node_SOURCES = ccm_epoche.c
+-crm_node_LDADD = $(COMMONLIBS) $(CLUSTERLIBS) \
+- $(top_builddir)/lib/common/libcrmcluster.la
++crm_node_LDADD = $(top_builddir)/lib/common/libcrmcluster.la \
++ $(COMMONLIBS) $(CLUSTERLIBS)
+
+ crm_simulate_SOURCES = crm_inject.c
+ crm_simulate_CFLAGS = -I$(top_srcdir)/pengine
+
+-crm_simulate_LDADD = $(COMMONLIBS) \
+- $(top_builddir)/lib/pengine/libpe_status.la \
++crm_simulate_LDADD = $(top_builddir)/lib/pengine/libpe_status.la \
+ $(top_builddir)/pengine/libpengine.la \
+ $(top_builddir)/lib/cib/libcib.la \
+- $(top_builddir)/lib/transition/libtransitioner.la
++ $(top_builddir)/lib/transition/libtransitioner.la \
++ $(COMMONLIBS)
+
+ crm_diff_SOURCES = xml_diff.c
+ crm_diff_LDADD = $(COMMONLIBS)
+
+ crm_mon_SOURCES = crm_mon.c
+-crm_mon_LDADD = $(COMMONLIBS) $(SNMPLIBS) $(ESMTPLIBS) -llrm \
+- $(top_builddir)/lib/pengine/libpe_status.la
++crm_mon_LDADD = $(top_builddir)/lib/pengine/libpe_status.la \
++ $(COMMONLIBS) $(SNMPLIBS) $(ESMTPLIBS) -llrm
+
+ # Arguments could be made that this should live in crm/pengine
+ crm_verify_SOURCES = crm_verify.c
+-crm_verify_LDADD = $(COMMONLIBS) \
+- $(top_builddir)/lib/pengine/libpe_status.la \
+- $(top_builddir)/pengine/libpengine.la
++crm_verify_LDADD = $(top_builddir)/lib/pengine/libpe_status.la \
++ $(top_builddir)/pengine/libpengine.la \
++ $(COMMONLIBS)
+
+ crm_attribute_SOURCES = crm_attribute.c
+ crm_attribute_LDADD = $(COMMONLIBS)
+
+ crm_resource_SOURCES = crm_resource.c
+-crm_resource_LDADD = $(COMMONLIBS) \
+- $(top_builddir)/lib/pengine/libpe_rules.la \
++crm_resource_LDADD = $(top_builddir)/lib/pengine/libpe_rules.la \
+ $(top_builddir)/lib/pengine/libpe_status.la \
+- $(top_builddir)/pengine/libpengine.la
++ $(top_builddir)/pengine/libpengine.la \
++ $(COMMONLIBS)
+
+ iso8601_SOURCES = test.iso8601.c
+ iso8601_LDADD = $(COMMONLIBS)
+
+ attrd_SOURCES = attrd.c
+-attrd_LDADD = $(COMMONLIBS) $(top_builddir)/lib/common/libcrmcluster.la
++attrd_LDADD = $(top_builddir)/lib/common/libcrmcluster.la $(COMMONLIBS)
+
+ #pingd_SOURCES = pingd.c
+ #pingd_LDADD = $(COMMONLIBS)
+@@ -123,14 +123,14 @@
+
+ if BUILD_SERVICELOG
+ notifyServicelogEvent_SOURCES = notifyServicelogEvent.c
+-notifyServicelogEvent_CFLAGS = `pkg-config --cflags servicelog-1`
+-notifyServicelogEvent_LDFLAGS = `pkg-config --libs servicelog-1` $(top_builddir)/lib/common/libcrmcommon.la
++notifyServicelogEvent_CFLAGS = $(SERVICELOG_CFLAGS)
++notifyServicelogEvent_LDADD = $(top_builddir)/lib/common/libcrmcommon.la $(SERVICELOG_LIBS)
+ endif
+
+ if BUILD_OPENIPMI_SERVICELOG
+ ipmiservicelogd_SOURCES = ipmiservicelogd.c
+-ipmiservicelogd_CFLAGS = `pkg-config --cflags OpenIPMI OpenIPMIposix servicelog-1`
+-ipmiservicelogd_LDFLAGS = `pkg-config --libs OpenIPMI OpenIPMIposix servicelog-1` $(top_builddir)/lib/common/libcrmcommon.la
++ipmiservicelogd_CFLAGS = $(OPENIPMI_SERVICELOG_CFLAGS) $(SERVICELOG_CFLAGS)
++ipmiservicelogd_LDFLAGS = $(top_builddir)/lib/common/libcrmcommon.la $(OPENIPMI_SERVICELOG_LIBS) $(SERVICELOG_LIBS)
+ endif
+
+ %.8: % crm_attribute
+--- a/extra/Makefile.am
++++ b/extra/Makefile.am
+@@ -20,5 +20,5 @@
+
+ SUBDIRS = resources
+
+-mibdir = $(datadir)/snmp/mibs
++mibdir = $(datadir)/$(PACKAGE)/snmp/mibs
+ mib_DATA = PCMK-MIB.txt
+--- a/fencing/Makefile.am 2011-02-25 09:58:45.621572915 +0100
++++ b/fencing/Makefile.am 2011-02-25 10:00:39.024820006 +0100
+@@ -42,23 +42,23 @@
+
+ stonith_test_SOURCES = test.c
+
+-stonith_test_LDADD = $(CRYPTOLIB) $(CLUSTERLIBS) \
+- $(top_builddir)/lib/common/libcrmcommon.la \
++stonith_test_LDADD = $(top_builddir)/lib/common/libcrmcommon.la \
+ $(top_builddir)/lib/common/libcrmcluster.la \
+- $(top_builddir)/lib/fencing/libstonithd.la
++ $(top_builddir)/lib/fencing/libstonithd.la \
++ $(CRYPTOLIB) $(CLUSTERLIBS)
+
+ stonith_admin_SOURCES = admin.c
+
+-stonith_admin_LDADD = $(CRYPTOLIB) $(CLUSTERLIBS) \
++stonith_admin_LDADD = $(top_builddir)/lib/common/libcrmcommon.la \
+ $(top_builddir)/lib/cib/libcib.la \
+ $(top_builddir)/lib/pengine/libpe_status.la \
+- $(top_builddir)/lib/common/libcrmcommon.la \
+ $(top_builddir)/lib/common/libcrmcluster.la \
+- $(top_builddir)/lib/fencing/libstonithd.la
++ $(top_builddir)/lib/fencing/libstonithd.la \
++ $(CRYPTOLIB) $(CLUSTERLIBS)
+
+ stonithd_SOURCES = main.c commands.c remote.c
+
+-stonithd_LDADD = $(CRYPTOLIB) $(CLUSTERLIBS) \
+- $(top_builddir)/lib/common/libcrmcommon.la \
++stonithd_LDADD = $(top_builddir)/lib/common/libcrmcommon.la \
+ $(top_builddir)/lib/common/libcrmcluster.la \
+- $(top_builddir)/lib/fencing/libstonithd.la
++ $(top_builddir)/lib/fencing/libstonithd.la \
++ $(CRYPTOLIB) $(CLUSTERLIBS)
+--- a/pengine/Makefile.am
++++ b/pengine/Makefile.am
+@@ -71,16 +71,17 @@
+ libpengine_la_SOURCES = pengine.c allocate.c utils.c constraints.c \
+ native.c group.c clone.c master.c graph.c
+-libpengine_la_LIBADD = $(top_builddir)/lib/pengine/libpe_status.la
++libpengine_la_LIBADD = $(top_builddir)/lib/pengine/libpe_status.la \
++ $(top_builddir)/lib/cib/libcib.la
+
+ pengine_SOURCES = main.c
+-pengine_LDADD = $(COMMONLIBS) $(top_builddir)/lib/cib/libcib.la
++pengine_LDADD = $(top_builddir)/lib/cib/libcib.la $(COMMONLIBS)
+ # libcib for get_object_root()
+ # $(top_builddir)/lib/hbclient/libhbclient.la
+
+ ptest_SOURCES = ptest.c
+-ptest_LDADD = $(COMMONLIBS) \
+- $(top_builddir)/lib/cib/libcib.la \
+- $(top_builddir)/lib/transition/libtransitioner.la
++ptest_LDADD = $(top_builddir)/lib/cib/libcib.la \
++ $(top_builddir)/lib/transition/libtransitioner.la \
++ $(COMMONLIBS)
+
+ install-exec-local:
+ $(mkinstalldirs) $(DESTDIR)/$(PE_STATE_DIR)
diff --git a/sys-cluster/pacemaker/pacemaker-1.1.5.ebuild b/sys-cluster/pacemaker/pacemaker-1.1.5.ebuild
new file mode 100644
index 000000000000..3c0247b032d6
--- /dev/null
+++ b/sys-cluster/pacemaker/pacemaker-1.1.5.ebuild
@@ -0,0 +1,86 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/pacemaker/pacemaker-1.1.5.ebuild,v 1.1 2011/07/08 13:47:33 ultrabug Exp $
+
+EAPI=3
+
+inherit autotools base eutils flag-o-matic multilib python
+
+MY_PN="Pacemaker"
+MY_P="${MY_PN}-${PV}"
+PYTHON_DEPEND="2"
+
+DESCRIPTION="Pacemaker CRM"
+HOMEPAGE="http://www.linux-ha.org/wiki/Pacemaker"
+SRC_URI="http://hg.clusterlabs.org/${PN}/1.1/archive/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~x86"
+IUSE="acl heartbeat smtp snmp static-libs"
+
+RDEPEND="
+ dev-libs/libxslt
+ sys-cluster/corosync
+ sys-cluster/cluster-glue
+ sys-cluster/resource-agents
+ heartbeat? ( >=sys-cluster/heartbeat-3.0.0 )
+ smtp? ( net-libs/libesmtp )
+ snmp? ( net-analyzer/net-snmp )
+"
+DEPEND="${RDEPEND}"
+
+PATCHES=(
+ "${FILESDIR}/${P}-autotools.patch"
+)
+
+S=${WORKDIR}/${MY_PN}-1-1-${MY_P}
+
+pkg_setup() {
+ python_set_active_version 2
+ python_pkg_setup
+}
+
+src_prepare() {
+ base_src_prepare
+ sed -i -e "/ggdb3/d" configure.ac || die
+ eautoreconf
+}
+
+src_configure() {
+ local myopts=""
+ use heartbeat || myopts="--with-ais"
+ # appends lib to localstatedir automatically
+ econf \
+ --localstatedir=/var \
+ --disable-dependency-tracking \
+ --disable-fatal-warnings \
+ --with-cs-quorum \
+ --without-cman \
+ $(use_with acl) \
+ $(use_with heartbeat) \
+ $(use_with smtp esmtp) \
+ $(use_with snmp) \
+ $(use_enable static-libs static) \
+ ${myopts}
+}
+
+src_install() {
+ base_src_install
+ newinitd "${FILESDIR}/pacemaker.initd" pacemaker || die
+ insinto /etc/corosync/service.d
+ newins "${FILESDIR}/pacemaker.service" pacemaker || die
+}
+
+pkg_postinst() {
+ elog "This version of Pacemaker uses the new MCP feature"
+ elog "and the v1 plugin for CoroSync. Read [1] for more info."
+ elog
+ elog "To start the Pacemaker Cluster Manager, run:"
+ elog "/etc/init.d/pacemaker start"
+ elog
+ elog "[1] http://theclusterguy.clusterlabs.org/post/907043024/introducing-the-pacemaker-master-control-process-for"
+ elog
+ elog "Note: sys-cluster/openais is no longer a hard dependency of ${P},"
+ elog "so you may need to install it yourself to suit your needs."
+}