summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Bronder <jsbronder@gentoo.org>2009-11-02 15:40:02 +0000
committerJustin Bronder <jsbronder@gentoo.org>2009-11-02 15:40:02 +0000
commitf0c6cbbdc0a49d4e82e8eca90a618a82cae0db4e (patch)
treec62889cd6c6488c93d43cbc985a820329c29b1f5 /sys-cluster/torque
parentbump (diff)
downloadgentoo-2-f0c6cbbdc0a49d4e82e8eca90a618a82cae0db4e.tar.gz
gentoo-2-f0c6cbbdc0a49d4e82e8eca90a618a82cae0db4e.tar.bz2
gentoo-2-f0c6cbbdc0a49d4e82e8eca90a618a82cae0db4e.zip
Allow enabling of the DRMAA library as suggested by Nick Loman.
(Portage version: 2.2_rc40/cvs/Linux x86_64)
Diffstat (limited to 'sys-cluster/torque')
-rw-r--r--sys-cluster/torque/ChangeLog6
-rw-r--r--sys-cluster/torque/metadata.xml6
-rw-r--r--sys-cluster/torque/torque-2.3.7.ebuild5
3 files changed, 11 insertions, 6 deletions
diff --git a/sys-cluster/torque/ChangeLog b/sys-cluster/torque/ChangeLog
index d6cf4380c350..526ca9ef34dc 100644
--- a/sys-cluster/torque/ChangeLog
+++ b/sys-cluster/torque/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-cluster/torque
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/torque/ChangeLog,v 1.85 2009/09/23 20:44:14 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/torque/ChangeLog,v 1.86 2009/11/02 15:40:02 jsbronder Exp $
+
+ 02 Nov 2009; Justin Bronder <jsbronder@gentoo.org> torque-2.3.7.ebuild,
+ metadata.xml:
+ Allow enabling of the DRMAA library as suggested by Nick Loman.
23 Sep 2009; Patrick Lauer <patrick@gentoo.org> torque-2.3.6.ebuild,
torque-2.3.7.ebuild:
diff --git a/sys-cluster/torque/metadata.xml b/sys-cluster/torque/metadata.xml
index 00606fccee1c..c159e68d0f5d 100644
--- a/sys-cluster/torque/metadata.xml
+++ b/sys-cluster/torque/metadata.xml
@@ -6,8 +6,8 @@
<email>jsbronder@gentoo.org</email>
</maintainer>
<use>
- <flag name='cpusets'>Enable pbs_mom to utilize linux cpusets if
- available.</flag>
- <flag name='server'>Enable compilation of pbs_server and pbs_sched</flag>
+ <flag name='cpusets'>Enable pbs_mom to utilize linux cpusets if available.</flag>
+ <flag name='drmaa'>Enable the Distributed Resource Management Application API.</flag>
+ <flag name='server'>Enable compilation of pbs_server and pbs_sched.</flag>
</use>
</pkgmetadata>
diff --git a/sys-cluster/torque/torque-2.3.7.ebuild b/sys-cluster/torque/torque-2.3.7.ebuild
index ea7fe907c8c7..e0a6a9d0b9ca 100644
--- a/sys-cluster/torque/torque-2.3.7.ebuild
+++ b/sys-cluster/torque/torque-2.3.7.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/torque/torque-2.3.7.ebuild,v 1.2 2009/09/23 20:44:15 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/torque/torque-2.3.7.ebuild,v 1.3 2009/11/02 15:40:02 jsbronder Exp $
EAPI=2
inherit flag-o-matic eutils linux-info
@@ -13,7 +13,7 @@ LICENSE="openpbs"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
-IUSE="tk +crypt server +syslog doc cpusets kernel_linux"
+IUSE="tk +crypt drmaa server +syslog doc cpusets kernel_linux"
PROVIDE="virtual/pbs"
# ed is used by makedepend-sh
@@ -68,6 +68,7 @@ src_configure() {
$(use_enable tk gui) \
$(use_enable syslog) \
$(use_enable server) \
+ $(use_enable drmaa) \
--with-server-home=${PBS_SERVER_HOME} \
--with-environ=/etc/pbs_environment \
--with-default-server=${PBS_SERVER_NAME} \