summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarc Schiffbauer <mschiff@gentoo.org>2014-09-18 17:25:35 +0000
committerMarc Schiffbauer <mschiff@gentoo.org>2014-09-18 17:25:35 +0000
commit0025ae8bb804c0c3fcbb9270178adb8abdb242ac (patch)
tree31fb6dc449375814dbbdb0f2f29d1d36b2dc3d3f /sys-cluster
parentapp-text/xmlstarlet: Remove old (diff)
downloadgentoo-2-0025ae8bb804c0c3fcbb9270178adb8abdb242ac.tar.gz
gentoo-2-0025ae8bb804c0c3fcbb9270178adb8abdb242ac.tar.bz2
gentoo-2-0025ae8bb804c0c3fcbb9270178adb8abdb242ac.zip
ebuild added to tree.
(Portage version: 2.2.12-r1/cvs/Linux x86_64, signed Manifest commit with key 0x296C6CCA35A64134)
Diffstat (limited to 'sys-cluster')
-rw-r--r--sys-cluster/poolmon/ChangeLog10
-rw-r--r--sys-cluster/poolmon/files/poolmon.conf3
-rw-r--r--sys-cluster/poolmon/files/poolmon.init18
-rw-r--r--sys-cluster/poolmon/files/poolmon.logrotate6
-rw-r--r--sys-cluster/poolmon/metadata.xml8
-rw-r--r--sys-cluster/poolmon/poolmon-0.5.ebuild30
6 files changed, 75 insertions, 0 deletions
diff --git a/sys-cluster/poolmon/ChangeLog b/sys-cluster/poolmon/ChangeLog
new file mode 100644
index 000000000000..a6afb3c6ee0b
--- /dev/null
+++ b/sys-cluster/poolmon/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for sys-cluster/poolmon
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/poolmon/ChangeLog,v 1.1 2014/09/18 17:25:35 mschiff Exp $
+
+*poolmon-0.5 (18 Sep 2014)
+
+ 18 Sep 2014; Marc Schiffbauer <mschiff@gentoo.org> +files/poolmon.conf,
+ +files/poolmon.init, +files/poolmon.logrotate, +metadata.xml,
+ +poolmon-0.5.ebuild:
+ ebuild added to tree.
diff --git a/sys-cluster/poolmon/files/poolmon.conf b/sys-cluster/poolmon/files/poolmon.conf
new file mode 100644
index 000000000000..930a58c9c012
--- /dev/null
+++ b/sys-cluster/poolmon/files/poolmon.conf
@@ -0,0 +1,3 @@
+# /etc/conf.d/poolmon
+# set poolmon commandline options
+OPTIONS=""
diff --git a/sys-cluster/poolmon/files/poolmon.init b/sys-cluster/poolmon/files/poolmon.init
new file mode 100644
index 000000000000..8e2a9fec9bb4
--- /dev/null
+++ b/sys-cluster/poolmon/files/poolmon.init
@@ -0,0 +1,18 @@
+#!/sbin/runscript
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/poolmon/files/poolmon.init,v 1.1 2014/09/18 17:25:35 mschiff Exp $
+
+start() {
+ local pidfile=/run/poolmon.pid
+ ebegin "Starting poolmon"
+ start-stop-daemon --pidfile "${pidfile}" --exec /usr/bin/poolmon -- ${OPTIONS}
+ eend $?
+}
+
+stop() {
+ local pidfile=/run/poolmon.pid
+ ebegin "Stopping poolmon"
+ start-stop-daemon --stop --pidfile "${pidfile}"
+ eend $?
+}
diff --git a/sys-cluster/poolmon/files/poolmon.logrotate b/sys-cluster/poolmon/files/poolmon.logrotate
new file mode 100644
index 000000000000..5925635a70c1
--- /dev/null
+++ b/sys-cluster/poolmon/files/poolmon.logrotate
@@ -0,0 +1,6 @@
+/var/log/poolmon.log {
+ missingok
+ postrotate
+ /bin/kill -HUP `cat /run/poolmon.pid 2> /dev/null` 2>/dev/null || true
+ endscript
+}
diff --git a/sys-cluster/poolmon/metadata.xml b/sys-cluster/poolmon/metadata.xml
new file mode 100644
index 000000000000..ea7bd021a21e
--- /dev/null
+++ b/sys-cluster/poolmon/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>mschiff@gentoo.org</email>
+ <name>Marc Schiffbauer</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/sys-cluster/poolmon/poolmon-0.5.ebuild b/sys-cluster/poolmon/poolmon-0.5.ebuild
new file mode 100644
index 000000000000..e6f03ba4bbab
--- /dev/null
+++ b/sys-cluster/poolmon/poolmon-0.5.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/poolmon/poolmon-0.5.ebuild,v 1.1 2014/09/18 17:25:35 mschiff Exp $
+
+EAPI=5
+
+DESCRIPTION="A director mailserver pool monitoring script for Dovecot"
+HOMEPAGE="https://github.com/brandond/poolmon"
+SRC_URI="https://github.com/brandond/${PN}/archive/${PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="
+ dev-perl/IO-Socket-SSL
+ net-mail/dovecot
+ "
+
+src_install() {
+ exeinto /usr/bin
+ doexe poolmon
+ dodoc README
+ newinitd "${FILESDIR}"/poolmon.init poolmon
+ newconfd "${FILESDIR}"/poolmon.conf poolmon
+ insinto /etc/logrotate.d/
+ newins "${FILESDIR}"/poolmon.logrotate poolmon
+}