summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2012-06-21 14:43:30 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2012-06-21 14:43:30 +0000
commit01e9171e4f686ef6e25b37f7b154f4b6a1fd1d70 (patch)
treed403b9eafe6ba432d7e4a3a77da4dd579374e038 /sys-cluster
parentStable for amd64, wrt bug #412947 (diff)
downloadgentoo-2-01e9171e4f686ef6e25b37f7b154f4b6a1fd1d70.tar.gz
gentoo-2-01e9171e4f686ef6e25b37f7b154f4b6a1fd1d70.tar.bz2
gentoo-2-01e9171e4f686ef6e25b37f7b154f4b6a1fd1d70.zip
Add patch to fix building with GCC 4.7 (fix bug #422553).
(Portage version: 2.2.0_alpha110/cvs/Linux x86_64)
Diffstat (limited to 'sys-cluster')
-rw-r--r--sys-cluster/gearmand/ChangeLog6
-rw-r--r--sys-cluster/gearmand/files/gearmand-0.33+gcc-4.7.patch12
-rw-r--r--sys-cluster/gearmand/gearmand-0.33.ebuild3
3 files changed, 19 insertions, 2 deletions
diff --git a/sys-cluster/gearmand/ChangeLog b/sys-cluster/gearmand/ChangeLog
index 56620a2c5d88..82f18f4c9797 100644
--- a/sys-cluster/gearmand/ChangeLog
+++ b/sys-cluster/gearmand/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-cluster/gearmand
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/gearmand/ChangeLog,v 1.13 2012/06/04 06:56:29 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/gearmand/ChangeLog,v 1.14 2012/06/21 14:43:30 flameeyes Exp $
+
+ 21 Jun 2012; Diego E. Pettenò <flameeyes@gentoo.org>
+ +files/gearmand-0.33+gcc-4.7.patch, gearmand-0.33.ebuild:
+ Add patch to fix building with GCC 4.7 (fix bug #422553).
*gearmand-0.33 (04 Jun 2012)
diff --git a/sys-cluster/gearmand/files/gearmand-0.33+gcc-4.7.patch b/sys-cluster/gearmand/files/gearmand-0.33+gcc-4.7.patch
new file mode 100644
index 000000000000..459952313d99
--- /dev/null
+++ b/sys-cluster/gearmand/files/gearmand-0.33+gcc-4.7.patch
@@ -0,0 +1,12 @@
+Index: gearmand-0.33/util/logfile.cc
+===================================================================
+--- gearmand-0.33.orig/util/logfile.cc
++++ gearmand-0.33/util/logfile.cc
+@@ -49,6 +49,7 @@
+ #include <sstream>
+ #include <sys/stat.h>
+ #include <sys/types.h>
++#include <unistd.h>
+
+ namespace datadifferential {
+ namespace util {
diff --git a/sys-cluster/gearmand/gearmand-0.33.ebuild b/sys-cluster/gearmand/gearmand-0.33.ebuild
index 28360de4e481..eea8af24dd60 100644
--- a/sys-cluster/gearmand/gearmand-0.33.ebuild
+++ b/sys-cluster/gearmand/gearmand-0.33.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/gearmand/gearmand-0.33.ebuild,v 1.1 2012/06/04 06:56:29 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/gearmand/gearmand-0.33.ebuild,v 1.2 2012/06/21 14:43:30 flameeyes Exp $
EAPI=4
@@ -30,6 +30,7 @@ pkg_setup() {
}
src_prepare() {
+ epatch "${FILESDIR}"/${P}+gcc-4.7.patch
elibtoolize
}