summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2013-08-02 18:33:11 +0000
committerMatthew Thode <prometheanfire@gentoo.org>2013-08-02 18:33:11 +0000
commit0b7572d940d98ea7622114ee5596880b53643722 (patch)
treede1fca341f87d96d1dc4bb45425f5245720441a2 /sys-cluster
parentstable/grizzly for cinder (diff)
downloadgentoo-2-0b7572d940d98ea7622114ee5596880b53643722.tar.gz
gentoo-2-0b7572d940d98ea7622114ee5596880b53643722.tar.bz2
gentoo-2-0b7572d940d98ea7622114ee5596880b53643722.zip
stable/grizzly ebuild for quantum now
(Portage version: 2.1.12.2/cvs/Linux x86_64, signed Manifest commit with key 0x2471eb3e40ac5ac3)
Diffstat (limited to 'sys-cluster')
-rw-r--r--sys-cluster/quantum/ChangeLog8
-rw-r--r--sys-cluster/quantum/quantum-2013.1.9999.ebuild80
-rw-r--r--sys-cluster/quantum/quantum-9999.ebuild14
3 files changed, 97 insertions, 5 deletions
diff --git a/sys-cluster/quantum/ChangeLog b/sys-cluster/quantum/ChangeLog
index eacbb8430123..58e2d9ccd40a 100644
--- a/sys-cluster/quantum/ChangeLog
+++ b/sys-cluster/quantum/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-cluster/quantum
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/quantum/ChangeLog,v 1.15 2013/07/24 00:28:42 prometheanfire Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/quantum/ChangeLog,v 1.16 2013/08/02 18:33:11 prometheanfire Exp $
+
+*quantum-2013.1.9999 (02 Aug 2013)
+
+ 02 Aug 2013; Matthew Thode <prometheanfire@gentoo.org>
+ +quantum-2013.1.9999.ebuild, quantum-9999.ebuild:
+ stable/grizzly ebuild for quantum now
24 Jul 2013; Matthew Thode <prometheanfire@gentoo.org>
quantum-2012.2.4-r1.ebuild, quantum-2013.1.2-r2.ebuild:
diff --git a/sys-cluster/quantum/quantum-2013.1.9999.ebuild b/sys-cluster/quantum/quantum-2013.1.9999.ebuild
new file mode 100644
index 000000000000..e6ac40674a9d
--- /dev/null
+++ b/sys-cluster/quantum/quantum-2013.1.9999.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/quantum/quantum-2013.1.9999.ebuild,v 1.1 2013/08/02 18:33:11 prometheanfire Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1 git-2
+
+#restricted due to packages missing and bad depends in the test ==webob-1.0.8
+RESTRICT="test"
+DESCRIPTION="Quantum is a virtual network service for Openstack."
+HOMEPAGE="https://launchpad.net/quantum"
+EGIT_REPO_URI="https://github.com/openstack/quantum.git"
+EGIT_BRANCH="stable/grizzly"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/cliff[${PYTHON_USEDEP}]
+ dev-python/configobj[${PYTHON_USEDEP}] )
+ dev-python/coverage[${PYTHON_USEDEP}]
+ >=dev-python/mock-1.0[${PYTHON_USEDEP}]
+ =dev-python/mox-0.5.3-r1[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/nosehtmloutput[${PYTHON_USEDEP}]
+ dev-python/nosexcover
+ dev-python/openstack-nose-plugin[${PYTHON_USEDEP}]
+ =dev-python/pep8-1.3.3
+ >=dev-python/sphinx-1.1.2[${PYTHON_USEDEP}]
+ =dev-python/webtest-1.3.3
+ virtual/python-unittest2[${PYTHON_USEDEP}]"
+RDEPEND=">=dev-python/pastedeploy-1.5.0-r1[${PYTHON_USEDEP}]
+ >=dev-python/alembic-0.4.1[${PYTHON_USEDEP}]
+ dev-python/paste[${PYTHON_USEDEP}]
+ >=dev-python/routes-1.12.3[${PYTHON_USEDEP}]
+ >=dev-python/amqplib-0.6.1-r1[${PYTHON_USEDEP}]
+ >=dev-python/anyjson-0.2.4[${PYTHON_USEDEP}]
+ >=dev-python/eventlet-0.9.17[${PYTHON_USEDEP}]
+ >=dev-python/greenlet-0.3.1[${PYTHON_USEDEP}]
+ dev-python/httplib2[${PYTHON_USEDEP}]
+ >=dev-python/iso8601-0.1.4[${PYTHON_USEDEP}]
+ >=dev-python/kombu-1.0.4-r1[${PYTHON_USEDEP}]
+ dev-python/netaddr
+ =dev-python/pyparsing-1.5.7[${PYTHON_USEDEP}]
+ >=dev-python/python-keystoneclient-0.2.0[${PYTHON_USEDEP}]
+ dev-python/python-novaclient[${PYTHON_USEDEP}]
+ >=dev-python/python-quantumclient-2.2.0[${PYTHON_USEDEP}]
+ <=dev-python/python-quantumclient-3.0.0[${PYTHON_USEDEP}]
+ dev-python/pyudev
+ >dev-python/sqlalchemy-0.7.8
+ <=dev-python/sqlalchemy-0.7.99
+ >=dev-python/webob-1.2[${PYTHON_USEDEP}]
+ >=dev-python/oslo-config-1.1.0[${PYTHON_USEDEP}]
+ virtual/python-argparse[${PYTHON_USEDEP}]
+ net-misc/openvswitch"
+
+python_install() {
+ distutils-r1_python_install
+ keepdir /etc/quantum
+ insinto /etc/quantum
+
+ doins "etc/api-paste.ini"
+ doins "etc/dhcp_agent.ini"
+ doins "etc/l3_agent.ini"
+ doins "etc/policy.json"
+ doins "etc/quantum.conf"
+ doins "etc/rootwrap.conf"
+ insinto /etc
+ doins -r "etc/quantum/"
+
+ #remove the etc stuff from usr...
+ rm -R "${D}/usr/etc/"
+
+ insinto "/usr/lib64/python2.7/site-packages/quantum/db/migration/alembic_migrations/"
+ doins -r "quantum/db/migration/alembic_migrations/versions"
+}
diff --git a/sys-cluster/quantum/quantum-9999.ebuild b/sys-cluster/quantum/quantum-9999.ebuild
index d19b5f0f835f..1687d73e6a57 100644
--- a/sys-cluster/quantum/quantum-9999.ebuild
+++ b/sys-cluster/quantum/quantum-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/quantum/quantum-9999.ebuild,v 1.1 2013/04/11 07:31:24 prometheanfire Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/quantum/quantum-9999.ebuild,v 1.2 2013/08/02 18:33:11 prometheanfire Exp $
EAPI=5
PYTHON_COMPAT=( python2_7 )
@@ -12,6 +12,7 @@ RESTRICT="test"
DESCRIPTION="Quantum is a virtual network service for Openstack."
HOMEPAGE="https://launchpad.net/quantum"
EGIT_REPO_URI="https://github.com/openstack/quantum.git"
+EGIT_BRANCH="master"
LICENSE="Apache-2.0"
SLOT="0"
@@ -36,14 +37,15 @@ RDEPEND=">=dev-python/pastedeploy-1.5.0-r1[${PYTHON_USEDEP}]
>=dev-python/alembic-0.4.1[${PYTHON_USEDEP}]
dev-python/paste[${PYTHON_USEDEP}]
>=dev-python/routes-1.12.3[${PYTHON_USEDEP}]
- =dev-python/amqplib-0.6.1
+ >=dev-python/amqplib-0.6.1-r1[${PYTHON_USEDEP}]
>=dev-python/anyjson-0.2.4[${PYTHON_USEDEP}]
>=dev-python/eventlet-0.9.17[${PYTHON_USEDEP}]
>=dev-python/greenlet-0.3.1[${PYTHON_USEDEP}]
dev-python/httplib2[${PYTHON_USEDEP}]
>=dev-python/iso8601-0.1.4[${PYTHON_USEDEP}]
- =dev-python/kombu-1.0.4-r1[${PYTHON_USEDEP}]
+ >=dev-python/kombu-1.0.4-r1[${PYTHON_USEDEP}]
dev-python/netaddr
+ =dev-python/pyparsing-1.5.7[${PYTHON_USEDEP}]
>=dev-python/python-keystoneclient-0.2.0[${PYTHON_USEDEP}]
dev-python/python-novaclient[${PYTHON_USEDEP}]
>=dev-python/python-quantumclient-2.2.0[${PYTHON_USEDEP}]
@@ -53,7 +55,8 @@ RDEPEND=">=dev-python/pastedeploy-1.5.0-r1[${PYTHON_USEDEP}]
<=dev-python/sqlalchemy-0.7.99
>=dev-python/webob-1.2[${PYTHON_USEDEP}]
>=dev-python/oslo-config-1.1.0[${PYTHON_USEDEP}]
- virtual/python-argparse[${PYTHON_USEDEP}]"
+ virtual/python-argparse[${PYTHON_USEDEP}]
+ net-misc/openvswitch"
python_install() {
distutils-r1_python_install
@@ -71,4 +74,7 @@ python_install() {
#remove the etc stuff from usr...
rm -R "${D}/usr/etc/"
+
+ insinto "/usr/lib64/python2.7/site-packages/quantum/db/migration/alembic_migrations/"
+ doins -r "quantum/db/migration/alembic_migrations/versions"
}