summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Volkov <pva@gentoo.org>2012-07-17 05:35:02 +0000
committerPeter Volkov <pva@gentoo.org>2012-07-17 05:35:02 +0000
commit13571011e48c233130027984448ccd6ca58c4b59 (patch)
tree638480032a007d64809cdf85004cfc3cc245b8d7 /sys-cluster
parentVersion bump on LTS branch. (diff)
downloadgentoo-2-13571011e48c233130027984448ccd6ca58c4b59.tar.gz
gentoo-2-13571011e48c233130027984448ccd6ca58c4b59.tar.bz2
gentoo-2-13571011e48c233130027984448ccd6ca58c4b59.zip
Version bump, bug #419379, thank Dennis Schridde for report.
(Portage version: 2.1.11.6/cvs/Linux x86_64)
Diffstat (limited to 'sys-cluster')
-rw-r--r--sys-cluster/vzctl/ChangeLog8
-rw-r--r--sys-cluster/vzctl/vzctl-3.3.ebuild64
-rw-r--r--sys-cluster/vzctl/vzctl-9999.ebuild3
3 files changed, 73 insertions, 2 deletions
diff --git a/sys-cluster/vzctl/ChangeLog b/sys-cluster/vzctl/ChangeLog
index 3f7befbc1f96..611f104385e7 100644
--- a/sys-cluster/vzctl/ChangeLog
+++ b/sys-cluster/vzctl/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-cluster/vzctl
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/vzctl/ChangeLog,v 1.91 2012/07/01 18:18:15 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/vzctl/ChangeLog,v 1.92 2012/07/17 05:35:02 pva Exp $
+
+*vzctl-3.3 (17 Jul 2012)
+
+ 17 Jul 2012; Peter Volkov <pva@gentoo.org> +vzctl-3.3.ebuild,
+ vzctl-9999.ebuild:
+ Version bump, bug #419379, thank Dennis Schridde for report.
01 Jul 2012; Raúl Porcel <armin76@gentoo.org> vzctl-3.0.29.3.ebuild,
vzctl-3.0.30.2.ebuild:
diff --git a/sys-cluster/vzctl/vzctl-3.3.ebuild b/sys-cluster/vzctl/vzctl-3.3.ebuild
new file mode 100644
index 000000000000..564f94c72acd
--- /dev/null
+++ b/sys-cluster/vzctl/vzctl-3.3.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/vzctl/vzctl-3.3.ebuild,v 1.1 2012/07/17 05:35:02 pva Exp $
+
+EAPI="4"
+
+inherit bash-completion-r1 eutils
+
+DESCRIPTION="OpenVZ ConTainers control utility"
+HOMEPAGE="http://openvz.org/"
+SRC_URI="http://download.openvz.org/utils/${PN}/${PV}/src/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ net-firewall/iptables
+ sys-apps/ed
+ sys-apps/iproute2
+ sys-fs/vzquota
+ sys-cluster/ploop"
+
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ # Set default OSTEMPLATE on gentoo added
+ sed -e 's:=redhat-:=gentoo-:' -i etc/dists/default || die
+ sed -e '/udevdir/{s|$(sysconfdir)|/lib|}' -i etc/udev/Makefile.in || die
+}
+
+src_configure() {
+ econf \
+ --localstatedir=/var \
+ --enable-udev \
+ --enable-bashcomp \
+ --enable-logrotate
+}
+
+src_install() {
+ emake DESTDIR="${D}" install install-gentoo
+
+ # install the bash-completion script into the right location
+ rm -rf "${ED}"/etc/bash_completion.d
+ newbashcomp etc/bash_completion.d/vzctl.sh ${PN}
+
+ # We need to keep some dirs
+ keepdir /vz/{dump,lock,root,private,template/cache}
+ keepdir /etc/vz/names /var/lib/vzctl/veip
+}
+
+pkg_postinst() {
+ ewarn "To avoid loosing network to CTs on iface down/up, please, add the"
+ ewarn "following code to /etc/conf.d/net:"
+ ewarn " postup() {"
+ ewarn " /usr/sbin/vzifup-post \${IFACE}"
+ ewarn " }"
+
+ ewarn "Starting with 3.0.25 there is new vzeventd service to reboot CTs."
+ ewarn "Please, drop /usr/share/vzctl/scripts/vpsnetclean and"
+ ewarn "/usr/share/vzctl/scripts/vpsreboot from crontab and use"
+ ewarn "/etc/init.d/vzeventd."
+}
diff --git a/sys-cluster/vzctl/vzctl-9999.ebuild b/sys-cluster/vzctl/vzctl-9999.ebuild
index 1b2d3010b0b1..ec79cf7a2f76 100644
--- a/sys-cluster/vzctl/vzctl-9999.ebuild
+++ b/sys-cluster/vzctl/vzctl-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/vzctl/vzctl-9999.ebuild,v 1.9 2012/03/31 05:09:25 pva Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/vzctl/vzctl-9999.ebuild,v 1.10 2012/07/17 05:35:02 pva Exp $
EAPI="4"
@@ -28,6 +28,7 @@ src_prepare() {
# Set default OSTEMPLATE on gentoo
sed -e 's:=redhat-:=gentoo-:' -i etc/dists/default || die
eautoreconf
+ sed -e '/udevdir/{s|$(sysconfdir)|/lib|}' -i etc/udev/Makefile.in || die
}
src_configure() {