summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Shvetsov <alexxy@gentoo.org>2011-08-31 17:26:17 +0000
committerAlexey Shvetsov <alexxy@gentoo.org>2011-08-31 17:26:17 +0000
commit1949142e9caa305e45243db2c7c4442457e51afd (patch)
tree2b4e388ffeca8580e6c5304d68f4ffb61f093248 /sys-cluster
parentVersion bump for bug #381169 (diff)
downloadgentoo-2-1949142e9caa305e45243db2c7c4442457e51afd.tar.gz
gentoo-2-1949142e9caa305e45243db2c7c4442457e51afd.tar.bz2
gentoo-2-1949142e9caa305e45243db2c7c4442457e51afd.zip
[sys-cluster/openmpi] Version bump
(Portage version: 2.2.0_alpha51/cvs/Linux x86_64)
Diffstat (limited to 'sys-cluster')
-rw-r--r--sys-cluster/openmpi/ChangeLog10
-rw-r--r--sys-cluster/openmpi/openmpi-1.5.4.ebuild121
2 files changed, 130 insertions, 1 deletions
diff --git a/sys-cluster/openmpi/ChangeLog b/sys-cluster/openmpi/ChangeLog
index a8583b5c3e1d..18a7e2ae0f6d 100644
--- a/sys-cluster/openmpi/ChangeLog
+++ b/sys-cluster/openmpi/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for sys-cluster/openmpi
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/openmpi/ChangeLog,v 1.91 2011/07/10 17:03:37 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/openmpi/ChangeLog,v 1.92 2011/08/31 17:26:17 alexxy Exp $
+
+ 31 Aug 2011; Alexey Shvetsov <alexxy@gentoo.org> +openmpi-1.5.4.ebuild:
+ Version bump
+
+*openmpi-1.5.4 (31 Aug 2011)
+
+ 31 Aug 2011; Alexey Shvetsov <alexxy@gentoo.org> +openmpi-1.5.4.ebuild:
+ Version bump
10 Jul 2011; Alexis Ballier <aballier@gentoo.org> openmpi-1.5.3-r2.ebuild:
keyword ~x86-fbsd, bug #372885
diff --git a/sys-cluster/openmpi/openmpi-1.5.4.ebuild b/sys-cluster/openmpi/openmpi-1.5.4.ebuild
new file mode 100644
index 000000000000..6233adb7e5ed
--- /dev/null
+++ b/sys-cluster/openmpi/openmpi-1.5.4.ebuild
@@ -0,0 +1,121 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/openmpi/openmpi-1.5.4.ebuild,v 1.1 2011/08/31 17:26:17 alexxy Exp $
+
+EAPI=4
+inherit eutils fortran-2 multilib flag-o-matic toolchain-funcs
+
+MY_P=${P/-mpi}
+S=${WORKDIR}/${MY_P}
+
+DESCRIPTION="A high-performance message passing library (MPI)"
+HOMEPAGE="http://www.open-mpi.org"
+SRC_URI="http://www.open-mpi.org/software/ompi/v1.5/downloads/${MY_P}.tar.bz2"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux"
+IUSE="+cxx elibc_FreeBSD fortran heterogeneous infiniband ipv6 mpi-threads pbs
+ romio sctp slurm threads vt"
+
+REQUIRED_USE="^^ (
+ ( !slurm !pbs )
+ ( slurm !pbs )
+ ( !slurm pbs )
+ )"
+
+RDEPEND="
+ fortran? ( virtual/fortran )
+ pbs? ( sys-cluster/torque )
+ infiniband? ( sys-infiniband/openib )
+ sctp? ( net-misc/lksctp-tools )
+ vt? (
+ !dev-libs/libotf
+ !app-text/lcdf-typetools
+ )
+ elibc_FreeBSD? ( dev-libs/libexecinfo )
+ >=sys-apps/hwloc-1.1.1
+ !sys-cluster/mpich
+ !sys-cluster/lam-mpi
+ !sys-cluster/mpich2
+ !sys-cluster/mpiexec"
+DEPEND="${RDEPEND}"
+
+pkg_setup() {
+ use fortran && fortran-2_pkg_setup
+ if use mpi-threads; then
+ echo
+ ewarn "WARNING: use of MPI_THREAD_MULTIPLE is still disabled by"
+ ewarn "default and officially unsupported by upstream."
+ ewarn "You may stop now and set USE=-mpi-threads"
+ echo
+ fi
+
+ echo
+ elog "OpenMPI has an overwhelming count of configuration options."
+ elog "Don't forget the EXTRA_ECONF environment variable can let you"
+ elog "specify configure options if you find them necessary."
+ echo
+}
+
+src_prepare() {
+ # Necessary for scalibility, see
+ # http://www.open-mpi.org/community/lists/users/2008/09/6514.php
+ if use threads; then
+ echo 'oob_tcp_listen_mode = listen_thread' \
+ >> opal/etc/openmpi-mca-params.conf
+ fi
+
+ epatch "${FILESDIR}"/openmpi-r24328.patch
+}
+
+src_configure() {
+ local myconf=(
+ --sysconfdir="${EPREFIX}/etc/${PN}"
+ --enable-pretty-print-stacktrace
+ --enable-orterun-prefix-by-default
+ --with-hwloc="${EPREFIX}/usr"
+ )
+
+ if use mpi-threads; then
+ myconf+=(
+ --enable-mpi-thread-multiple
+ --enable-opal-multi-threads
+ )
+ fi
+
+ if use fortran; then
+ if [[ $(tc-getFC) =~ g77 ]]; then
+ myconf+=(--disable-mpi-f90)
+ elif [[ $(tc-getFC) =~ if ]]; then
+ # Enabled here as gfortran compile times are huge with this enabled.
+ myconf+=(--with-mpi-f90-size=medium)
+ fi
+ else
+ myconf+=(--disable-mpi-f90 --disable-mpi-f77)
+ fi
+
+ ! use vt && myconf+=(--enable-contrib-no-build=vt)
+
+ econf "${myconf[@]}" \
+ $(use_enable cxx mpi-cxx) \
+ $(use_enable romio io-romio) \
+ $(use_enable heterogeneous) \
+ $(use_with pbs tm) \
+ $(use_with slurm) \
+ $(use_enable ipv6) \
+ $(use_with infiniband openib) \
+ $(use_with sctp sctp)
+}
+
+src_install () {
+ emake DESTDIR="${D}" install || die "make install failed"
+ # From USE=vt see #359917
+ rm "${D}"/usr/share/libtool &> /dev/null
+ dodoc README AUTHORS NEWS VERSION || die
+}
+
+src_test() {
+ # Doesn't work with the default src_test as the dry run (-n) fails.
+ cd "${S}"
+ emake -j1 check || die "emake check failed"
+}