summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Bronder <jsbronder@gentoo.org>2010-01-20 02:30:42 +0000
committerJustin Bronder <jsbronder@gentoo.org>2010-01-20 02:30:42 +0000
commit3d013f814bd41862665937ee99e22c19793fa5fb (patch)
tree503e83c5daf9e34c8a86d5454af410636afb18b5 /sys-cluster
parentMarking eselect-opengl-1.1.1-r2 ppc64 for bug 301271 (diff)
downloadgentoo-2-3d013f814bd41862665937ee99e22c19793fa5fb.tar.gz
gentoo-2-3d013f814bd41862665937ee99e22c19793fa5fb.tar.bz2
gentoo-2-3d013f814bd41862665937ee99e22c19793fa5fb.zip
cleanup sys-cluster/openmpi
(Portage version: 2.2_rc61/cvs/Linux x86_64)
Diffstat (limited to 'sys-cluster')
-rw-r--r--sys-cluster/openmpi/ChangeLog6
-rw-r--r--sys-cluster/openmpi/openmpi-1.2.9-r1.ebuild109
-rw-r--r--sys-cluster/openmpi/openmpi-1.3.3.ebuild108
-rw-r--r--sys-cluster/openmpi/openmpi-1.4.ebuild109
4 files changed, 5 insertions, 327 deletions
diff --git a/sys-cluster/openmpi/ChangeLog b/sys-cluster/openmpi/ChangeLog
index a8794e597cf9..2742ba09bd90 100644
--- a/sys-cluster/openmpi/ChangeLog
+++ b/sys-cluster/openmpi/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-cluster/openmpi
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/openmpi/ChangeLog,v 1.58 2010/01/20 02:24:37 jsbronder Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/openmpi/ChangeLog,v 1.59 2010/01/20 02:30:42 jsbronder Exp $
+
+ 20 Jan 2010; Justin Bronder <jsbronder@gentoo.org>
+ -openmpi-1.2.9-r1.ebuild, -openmpi-1.3.3.ebuild, -openmpi-1.4.ebuild:
+ cleanup sys-cluster/openmpi
*openmpi-1.4.1 (20 Jan 2010)
diff --git a/sys-cluster/openmpi/openmpi-1.2.9-r1.ebuild b/sys-cluster/openmpi/openmpi-1.2.9-r1.ebuild
deleted file mode 100644
index 672f74b36e04..000000000000
--- a/sys-cluster/openmpi/openmpi-1.2.9-r1.ebuild
+++ /dev/null
@@ -1,109 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/openmpi/openmpi-1.2.9-r1.ebuild,v 1.1 2009/08/18 00:32:27 jsbronder Exp $
-
-EAPI=1
-inherit eutils multilib flag-o-matic toolchain-funcs fortran
-
-MY_P=${P/-mpi}
-S=${WORKDIR}/${MY_P}
-
-DESCRIPTION="A high-performance message passing library (MPI)"
-HOMEPAGE="http://www.open-mpi.org"
-SRC_URI="http://www.open-mpi.org/software/ompi/v1.2/downloads/${MY_P}.tar.bz2"
-LICENSE="BSD"
-SLOT="0"
-RESTRICT="mpi-threads? ( test )"
-KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~sparc ~x86"
-IUSE="+cxx fortran heterogeneous ipv6 mpi-threads pbs romio threads"
-RDEPEND="pbs? ( sys-cluster/torque )
- !sys-cluster/mpich
- !sys-cluster/lam-mpi
- !sys-cluster/mpich2"
-DEPEND="${RDEPEND}"
-
-pkg_setup() {
- if use mpi-threads; then
- ewarn
- ewarn "WARNING: use of MPI_THREAD_MULTIPLE is still disabled by"
- ewarn "default and officially unsupported by upstream."
- ewarn "You may stop now and set USE=-mpi-threads"
- ewarn
- epause 5
- fi
-
- elog
- elog "OpenMPI has an overwhelming count of configuration options."
- elog "Don't forget the EXTRA_ECONF environment variable can let you"
- elog "specify configure options if you find them necessary."
- elog
-
- if use fortran; then
- FORTRAN="g77 gfortran ifc"
- fortran_pkg_setup
- fi
-}
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
- # Necessary for scalibility, see
- # http://www.open-mpi.org/community/lists/users/2008/09/6514.php
- if use threads; then
- echo 'oob_tcp_listen_mode = listen_thread' \
- >> opal/etc/openmpi-mca-params.conf
- fi
-}
-
-src_compile() {
- local myconf="
- --sysconfdir=/etc/${PN}
- --without-xgrid
- --enable-pretty-print-stacktrace
- --enable-orterun-prefix-by-default
- --without-slurm"
-
- if use mpi-threads; then
- myconf="${myconf}
- --enable-mpi-threads
- --with-progress-threads"
- fi
-
- if use fortran; then
- if [[ "${FORTRANC}" = "g77" ]]; then
- myconf="${myconf} --disable-mpi-f90"
- elif [[ "${FORTRANC}" = "gfortran" ]]; then
- # Because that's just a pain in the butt.
- myconf="${myconf} --with-wrapper-fflags=-I/usr/include --with-wrapper-fcflags=-I/usr/include"
- elif [[ "${FORTRANC}" = if* ]]; then
- # Enabled here as gfortran compile times are huge with this enabled.
- myconf="${myconf} --with-mpi-f90-size=medium"
- fi
- else
- myconf="${myconf}
- --disable-mpi-f90
- --disable-mpi-f77"
- fi
-
- econf ${myconf} \
- $(use_enable cxx mpi-cxx) \
- $(use_enable romio io-romio) \
- $(use_enable heterogeneous) \
- $(use_with pbs tm) \
- $(use_enable ipv6) \
- || die "econf failed"
-
- emake || die "emake failed"
-}
-
-src_install () {
- emake DESTDIR="${D}" install || die "make install failed"
- dodoc README AUTHORS NEWS VERSION
-}
-
-src_test() {
- # Doesn't work with the default src_test as the dry run (-n) fails.
- cd "${S}"
- emake -j1 check || die "emake check failed"
-}
diff --git a/sys-cluster/openmpi/openmpi-1.3.3.ebuild b/sys-cluster/openmpi/openmpi-1.3.3.ebuild
deleted file mode 100644
index ae5ec93ca4a6..000000000000
--- a/sys-cluster/openmpi/openmpi-1.3.3.ebuild
+++ /dev/null
@@ -1,108 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/openmpi/openmpi-1.3.3.ebuild,v 1.3 2009/08/18 00:34:21 jsbronder Exp $
-
-EAPI=2
-inherit eutils multilib flag-o-matic toolchain-funcs fortran
-
-MY_P=${P/-mpi}
-S=${WORKDIR}/${MY_P}
-
-DESCRIPTION="A high-performance message passing library (MPI)"
-HOMEPAGE="http://www.open-mpi.org"
-SRC_URI="http://www.open-mpi.org/software/ompi/v1.3/downloads/${MY_P}.tar.bz2"
-LICENSE="BSD"
-SLOT="0"
-RESTRICT="mpi-threads? ( test )"
-KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~sparc ~x86"
-IUSE="+cxx fortran heterogeneous ipv6 mpi-threads pbs romio threads vt"
-RDEPEND="pbs? ( sys-cluster/torque )
- vt? (
- !dev-libs/libotf
- !app-text/lcdf-typetools
- )
- !sys-cluster/mpich
- !sys-cluster/lam-mpi
- !sys-cluster/mpich2
- !sys-cluster/mpiexec"
-DEPEND="${RDEPEND}"
-
-pkg_setup() {
- if use mpi-threads; then
- ewarn
- ewarn "WARNING: use of MPI_THREAD_MULTIPLE is still disabled by"
- ewarn "default and officially unsupported by upstream."
- ewarn "You may stop now and set USE=-mpi-threads"
- ewarn
- epause 5
- fi
-
- elog
- elog "OpenMPI has an overwhelming count of configuration options."
- elog "Don't forget the EXTRA_ECONF environment variable can let you"
- elog "specify configure options if you find them necessary."
- elog
-
- if use fortran; then
- FORTRAN="g77 gfortran ifc"
- fortran_pkg_setup
- fi
-}
-
-src_prepare() {
- # Necessary for scalibility, see
- # http://www.open-mpi.org/community/lists/users/2008/09/6514.php
- if use threads; then
- echo 'oob_tcp_listen_mode = listen_thread' \
- >> opal/etc/openmpi-mca-params.conf
- fi
-}
-
-src_configure() {
- local myconf="
- --sysconfdir=/etc/${PN}
- --without-xgrid
- --enable-pretty-print-stacktrace
- --enable-orterun-prefix-by-default
- --without-slurm"
-
- if use mpi-threads; then
- myconf="${myconf}
- --enable-mpi-threads
- --enable-progress-threads"
- fi
-
- if use fortran; then
- if [[ "${FORTRANC}" = "g77" ]]; then
- myconf="${myconf} --disable-mpi-f90"
- elif [[ "${FORTRANC}" = if* ]]; then
- # Enabled here as gfortran compile times are huge with this enabled.
- myconf="${myconf} --with-mpi-f90-size=medium"
- fi
- else
- myconf="${myconf}
- --disable-mpi-f90
- --disable-mpi-f77"
- fi
-
- ! use vt && myconf="${myconf} --enable-contrib-no-build=vt"
-
- econf ${myconf} \
- $(use_enable cxx mpi-cxx) \
- $(use_enable romio io-romio) \
- $(use_enable heterogeneous) \
- $(use_with pbs tm) \
- $(use_enable ipv6) \
- || die "econf failed"
-}
-
-src_install () {
- emake DESTDIR="${D}" install || die "make install failed"
- dodoc README AUTHORS NEWS VERSION
-}
-
-src_test() {
- # Doesn't work with the default src_test as the dry run (-n) fails.
- cd "${S}"
- emake -j1 check || die "emake check failed"
-}
diff --git a/sys-cluster/openmpi/openmpi-1.4.ebuild b/sys-cluster/openmpi/openmpi-1.4.ebuild
deleted file mode 100644
index 4a74ca5eddd5..000000000000
--- a/sys-cluster/openmpi/openmpi-1.4.ebuild
+++ /dev/null
@@ -1,109 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/openmpi/openmpi-1.4.ebuild,v 1.2 2009/12/10 22:08:10 aballier Exp $
-
-EAPI=2
-inherit eutils multilib flag-o-matic toolchain-funcs fortran
-
-MY_P=${P/-mpi}
-S=${WORKDIR}/${MY_P}
-
-DESCRIPTION="A high-performance message passing library (MPI)"
-HOMEPAGE="http://www.open-mpi.org"
-SRC_URI="http://www.open-mpi.org/software/ompi/v1.4/downloads/${MY_P}.tar.bz2"
-LICENSE="BSD"
-SLOT="0"
-RESTRICT="mpi-threads? ( test )"
-KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
-IUSE="+cxx elibc_FreeBSD fortran heterogeneous ipv6 mpi-threads pbs romio threads vt"
-RDEPEND="pbs? ( sys-cluster/torque )
- vt? (
- !dev-libs/libotf
- !app-text/lcdf-typetools
- )
- elibc_FreeBSD? ( dev-libs/libexecinfo )
- !sys-cluster/mpich
- !sys-cluster/lam-mpi
- !sys-cluster/mpich2
- !sys-cluster/mpiexec"
-DEPEND="${RDEPEND}"
-
-pkg_setup() {
- if use mpi-threads; then
- ewarn
- ewarn "WARNING: use of MPI_THREAD_MULTIPLE is still disabled by"
- ewarn "default and officially unsupported by upstream."
- ewarn "You may stop now and set USE=-mpi-threads"
- ewarn
- epause 5
- fi
-
- elog
- elog "OpenMPI has an overwhelming count of configuration options."
- elog "Don't forget the EXTRA_ECONF environment variable can let you"
- elog "specify configure options if you find them necessary."
- elog
-
- if use fortran; then
- FORTRAN="g77 gfortran ifc"
- fortran_pkg_setup
- fi
-}
-
-src_prepare() {
- # Necessary for scalibility, see
- # http://www.open-mpi.org/community/lists/users/2008/09/6514.php
- if use threads; then
- echo 'oob_tcp_listen_mode = listen_thread' \
- >> opal/etc/openmpi-mca-params.conf
- fi
-}
-
-src_configure() {
- local myconf="
- --sysconfdir=/etc/${PN}
- --without-xgrid
- --enable-pretty-print-stacktrace
- --enable-orterun-prefix-by-default
- --without-slurm"
-
- if use mpi-threads; then
- myconf="${myconf}
- --enable-mpi-threads
- --enable-progress-threads"
- fi
-
- if use fortran; then
- if [[ "${FORTRANC}" = "g77" ]]; then
- myconf="${myconf} --disable-mpi-f90"
- elif [[ "${FORTRANC}" = if* ]]; then
- # Enabled here as gfortran compile times are huge with this enabled.
- myconf="${myconf} --with-mpi-f90-size=medium"
- fi
- else
- myconf="${myconf}
- --disable-mpi-f90
- --disable-mpi-f77"
- fi
-
- ! use vt && myconf="${myconf} --enable-contrib-no-build=vt"
-
- econf ${myconf} \
- $(use_enable cxx mpi-cxx) \
- $(use_enable romio io-romio) \
- $(use_enable heterogeneous) \
- $(use_with pbs tm) \
- $(use_enable ipv6) \
- || die "econf failed"
-}
-
-src_install () {
- emake DESTDIR="${D}" install || die "make install failed"
- dodoc README AUTHORS NEWS VERSION
-}
-
-src_test() {
- # Doesn't work with the default src_test as the dry run (-n) fails.
- cd "${S}"
- emake -j1 check || die "emake check failed"
-}