summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Imhof <tantive@gentoo.org>2004-06-08 23:34:40 +0000
committerMichael Imhof <tantive@gentoo.org>2004-06-08 23:34:40 +0000
commit5030f87ac89b3770b9981059e1089928c3fec29d (patch)
treedae420623a455a013fcd3d4f30b0a0bfbefe7df2 /sys-cluster
parentVersion bump (Manifest recommit) (diff)
downloadgentoo-2-5030f87ac89b3770b9981059e1089928c3fec29d.tar.gz
gentoo-2-5030f87ac89b3770b9981059e1089928c3fec29d.tar.bz2
gentoo-2-5030f87ac89b3770b9981059e1089928c3fec29d.zip
Inital import. Closes #51316.
Diffstat (limited to 'sys-cluster')
-rw-r--r--sys-cluster/feedbackd-agent/ChangeLog10
-rw-r--r--sys-cluster/feedbackd-agent/Manifest3
-rw-r--r--sys-cluster/feedbackd-agent/feedbackd-agent-0.3.1.ebuild46
-rw-r--r--sys-cluster/feedbackd-agent/files/compile-gnu-source.patch11
-rw-r--r--sys-cluster/feedbackd-agent/files/digest-feedbackd-agent-0.3.11
5 files changed, 71 insertions, 0 deletions
diff --git a/sys-cluster/feedbackd-agent/ChangeLog b/sys-cluster/feedbackd-agent/ChangeLog
new file mode 100644
index 000000000000..344bc1f41052
--- /dev/null
+++ b/sys-cluster/feedbackd-agent/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for sys-cluster/feedbackd-agent
+# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/feedbackd-agent/ChangeLog,v 1.1 2004/06/08 23:34:40 tantive Exp $
+
+*feedbackd-agent-0.3.1 (09 Jun 2004)
+
+ 09 Jun 2004; Michael Imhof <tantive@gentoo.org> feedbackd-agent-0.3.1.ebuild,
+ files/compile-gnu-source.patch:
+ Inital import. Closes #51316.
+
diff --git a/sys-cluster/feedbackd-agent/Manifest b/sys-cluster/feedbackd-agent/Manifest
new file mode 100644
index 000000000000..203d7f439d43
--- /dev/null
+++ b/sys-cluster/feedbackd-agent/Manifest
@@ -0,0 +1,3 @@
+MD5 925a21f3c3e1ac85564545cc6d7c355b feedbackd-agent-0.3.1.ebuild 1176
+MD5 560fedeed92761d71d6662879450213e files/compile-gnu-source.patch 346
+MD5 7ca761c8ea4dcc887a66cdb55cdde95d files/digest-feedbackd-agent-0.3.1 73
diff --git a/sys-cluster/feedbackd-agent/feedbackd-agent-0.3.1.ebuild b/sys-cluster/feedbackd-agent/feedbackd-agent-0.3.1.ebuild
new file mode 100644
index 000000000000..43fc9a39afd7
--- /dev/null
+++ b/sys-cluster/feedbackd-agent/feedbackd-agent-0.3.1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/feedbackd-agent/feedbackd-agent-0.3.1.ebuild,v 1.1 2004/06/08 23:34:40 tantive Exp $
+
+inherit eutils
+
+DESCRIPTION="Feedbackd is a client/server system that provides dynamic feedback of server
+load in a Linux Virtual Server (LVS)-based cluster. Monitor plugins are used to
+measure the health of each server, allowing a flexible way to report load back
+to the load balancer. It also facilitates the addition and removal of servers
+from the cluster.
+
+This is the agent process for feedbackd, which is run on the real server."
+
+HOMEPAGE="http://www.redfishsoftware.com.au/projects/feedbackd/"
+LICENSE="GPL-2"
+DEPEND="virtual/glibc
+ >=dev-libs/libxml2
+ >=dev-lang/perl"
+
+SRC_URI="http://aleron.dl.sourceforge.net/sourceforge/feedbackd/${P}.tar.gz"
+
+SLOT="0"
+KEYWORDS="~x86"
+S="${WORKDIR}/${P}"
+
+src_compile() {
+
+ epatch ${FILESDIR}/compile-gnu-source.patch
+
+ CFLAGS="${CFLAGS/-O?/} -O2" \
+ econf \
+ --sysconfdir=/etc \
+ --localstatedir=/var \
+ --with-xml-config=/usr/bin/xml2-config \
+ --with-perl=/usr/bin/perl \
+ || die "bad ./configure"
+
+ cd "${S}"
+ make || die
+}
+
+src_install() {
+ einstall || die
+ dodoc AUTHORS COPYING ChangeLog INSTALL NEWS README || die
+}
diff --git a/sys-cluster/feedbackd-agent/files/compile-gnu-source.patch b/sys-cluster/feedbackd-agent/files/compile-gnu-source.patch
new file mode 100644
index 000000000000..819cedba6494
--- /dev/null
+++ b/sys-cluster/feedbackd-agent/files/compile-gnu-source.patch
@@ -0,0 +1,11 @@
+--- feedbackd-agent-0.3.1/src/plugins/Makefile.in.chris 2004-05-17 22:33:07.000000000 +0200
++++ feedbackd-agent-0.3.1/src/plugins/Makefile.in 2004-05-17 22:33:20.000000000 +0200
+@@ -46,7 +46,7 @@
+ AWK = @AWK@
+ CC = @CC@
+ CCDEPMODE = @CCDEPMODE@
+-CFLAGS = @CFLAGS@
++CFLAGS = @CFLAGS@ -D_GNU_SOURCE
+ CPP = @CPP@
+ CPPFLAGS = @CPPFLAGS@
+ CXX = @CXX@
diff --git a/sys-cluster/feedbackd-agent/files/digest-feedbackd-agent-0.3.1 b/sys-cluster/feedbackd-agent/files/digest-feedbackd-agent-0.3.1
new file mode 100644
index 000000000000..02277ce92691
--- /dev/null
+++ b/sys-cluster/feedbackd-agent/files/digest-feedbackd-agent-0.3.1
@@ -0,0 +1 @@
+MD5 e293c59e8701b4aa9f85ffe5fc303229 feedbackd-agent-0.3.1.tar.gz 233043