summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2014-08-28 16:55:33 +0000
committerMichał Górny <mgorny@gentoo.org>2014-08-28 16:55:33 +0000
commit51ef68155a319d9d0cbca12ad42785eced95600e (patch)
treea85eb57ce77027f0b49fd99e055b44934374ba34 /sys-cluster
parentTyping error. built, not build. (diff)
downloadgentoo-2-51ef68155a319d9d0cbca12ad42785eced95600e.tar.gz
gentoo-2-51ef68155a319d9d0cbca12ad42785eced95600e.tar.bz2
gentoo-2-51ef68155a319d9d0cbca12ad42785eced95600e.zip
Install the bash completion file to the correct location using bash-completion-r1. Remove USE=bash-completion since the file needs to be installed unconditionally.
(Portage version: 2.2.11_p165/cvs/Linux x86_64, signed Manifest commit with key EFB4464E!)
Diffstat (limited to 'sys-cluster')
-rw-r--r--sys-cluster/drbd/ChangeLog7
-rw-r--r--sys-cluster/drbd/drbd-8.4.3.ebuild12
2 files changed, 12 insertions, 7 deletions
diff --git a/sys-cluster/drbd/ChangeLog b/sys-cluster/drbd/ChangeLog
index 4bb2959d59c3..6a27997c1b8e 100644
--- a/sys-cluster/drbd/ChangeLog
+++ b/sys-cluster/drbd/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-cluster/drbd
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/drbd/ChangeLog,v 1.132 2014/07/30 19:39:48 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/drbd/ChangeLog,v 1.133 2014/08/28 16:55:33 mgorny Exp $
+
+ 28 Aug 2014; Michał Górny <mgorny@gentoo.org> drbd-8.4.3.ebuild:
+ Install the bash completion file to the correct location using bash-
+ completion-r1. Remove USE=bash-completion since the file needs to be installed
+ unconditionally.
30 Jul 2014; Samuli Suominen <ssuominen@gentoo.org> drbd-8.3.13.ebuild:,
Use shorter get_udevdir() instead of the longer deprecated udev_get_udevdir()
diff --git a/sys-cluster/drbd/drbd-8.4.3.ebuild b/sys-cluster/drbd/drbd-8.4.3.ebuild
index 28596981ced6..95b630ac4ea7 100644
--- a/sys-cluster/drbd/drbd-8.4.3.ebuild
+++ b/sys-cluster/drbd/drbd-8.4.3.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/drbd/drbd-8.4.3.ebuild,v 1.5 2014/07/30 19:34:00 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/drbd/drbd-8.4.3.ebuild,v 1.6 2014/08/28 16:55:33 mgorny Exp $
EAPI=4
-inherit eutils multilib versionator udev
+inherit bash-completion-r1 eutils multilib versionator udev
LICENSE="GPL-2"
@@ -13,7 +13,7 @@ SRC_URI="http://oss.linbit.com/drbd/$(get_version_component_range 1-2 ${PV})/${P
HOMEPAGE="http://www.drbd.org"
KEYWORDS="~amd64 ~x86"
-IUSE="bash-completion heartbeat pacemaker +udev xen"
+IUSE="heartbeat pacemaker +udev xen"
SLOT="0"
src_prepare() {
@@ -27,8 +27,8 @@ src_prepare() {
sed -e "s:@prefix@/lib:@prefix@/$(get_libdir):" \
-e "s:(DESTDIR)/lib:(DESTDIR)/$(get_libdir):" \
-i user/{,legacy/}Makefile.in || die
- # correct install paths
- sed -i -e "s:\$(sysconfdir)/bash_completion.d:/usr/share/bash-completion:" \
+ # correct install paths (really correct this time)
+ sed -i -e "s:\$(sysconfdir)/bash_completion.d:$(get_bashcompdir):" \
scripts/Makefile.in || die
# don't participate in user survey bug 360483
sed -i -e '/usage-count/ s/yes/no/' scripts/drbd.conf.example || die
@@ -45,7 +45,7 @@ src_configure() {
$(use_with xen) \
$(use_with pacemaker) \
$(use_with heartbeat) \
- $(use_with bash-completion bashcompletion) \
+ --with-bashcompletion \
--with-distro=gentoo
}