summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2012-10-14 19:40:20 +0000
committerJustin Lecher <jlec@gentoo.org>2012-10-14 19:40:20 +0000
commit628ca495f9876c23b85d4e306712a0c60be74af2 (patch)
tree4eff8cef17e15289734a62fa899721b0569d62d3 /sys-cluster
parentPrepare for fortran2.eclass update (diff)
downloadgentoo-2-628ca495f9876c23b85d4e306712a0c60be74af2.tar.gz
gentoo-2-628ca495f9876c23b85d4e306712a0c60be74af2.tar.bz2
gentoo-2-628ca495f9876c23b85d4e306712a0c60be74af2.zip
Prepare for fortran2.eclass update
(Portage version: 2.2.0_alpha137/cvs/Linux x86_64)
Diffstat (limited to 'sys-cluster')
-rw-r--r--sys-cluster/openmpi/ChangeLog7
-rw-r--r--sys-cluster/openmpi/openmpi-1.4.3.ebuild8
-rw-r--r--sys-cluster/openmpi/openmpi-1.4.4.ebuild10
-rw-r--r--sys-cluster/openmpi/openmpi-1.5.5.ebuild8
-rw-r--r--sys-cluster/openmpi/openmpi-1.6-r1.ebuild8
-rw-r--r--sys-cluster/openmpi/openmpi-1.6.1.ebuild8
6 files changed, 38 insertions, 11 deletions
diff --git a/sys-cluster/openmpi/ChangeLog b/sys-cluster/openmpi/ChangeLog
index d15f9ec828ff..c0214cd4c7ed 100644
--- a/sys-cluster/openmpi/ChangeLog
+++ b/sys-cluster/openmpi/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-cluster/openmpi
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/openmpi/ChangeLog,v 1.111 2012/10/07 17:53:28 alexxy Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/openmpi/ChangeLog,v 1.112 2012/10/14 19:40:20 jlec Exp $
+
+ 14 Oct 2012; Justin Lecher <jlec@gentoo.org> openmpi-1.4.3.ebuild,
+ openmpi-1.4.4.ebuild, openmpi-1.5.5.ebuild, openmpi-1.6-r1.ebuild,
+ openmpi-1.6.1.ebuild:
+ Prepare for fortran2.eclass update
*openmpi-1.6.2 (07 Oct 2012)
diff --git a/sys-cluster/openmpi/openmpi-1.4.3.ebuild b/sys-cluster/openmpi/openmpi-1.4.3.ebuild
index 2aaf6a381287..66b5df422017 100644
--- a/sys-cluster/openmpi/openmpi-1.4.3.ebuild
+++ b/sys-cluster/openmpi/openmpi-1.4.3.ebuild
@@ -1,12 +1,14 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/openmpi/openmpi-1.4.3.ebuild,v 1.15 2012/06/25 18:28:11 jsbronder Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/openmpi/openmpi-1.4.3.ebuild,v 1.16 2012/10/14 19:40:20 jlec Exp $
EAPI=3
+
+FORTRAN_NEEDED=fortran
+
inherit eutils fortran-2 multilib flag-o-matic toolchain-funcs
MY_P=${P/-mpi}
-S=${WORKDIR}/${MY_P}
DESCRIPTION="A high-performance message passing library (MPI)"
HOMEPAGE="http://www.open-mpi.org"
@@ -28,6 +30,8 @@ RDEPEND="
!sys-cluster/mpiexec"
DEPEND="${RDEPEND}"
+S=${WORKDIR}/${MY_P}
+
pkg_setup() {
use fortran && fortran-2_pkg_setup
if use mpi-threads; then
diff --git a/sys-cluster/openmpi/openmpi-1.4.4.ebuild b/sys-cluster/openmpi/openmpi-1.4.4.ebuild
index b70de5f990dd..72f0b70c8651 100644
--- a/sys-cluster/openmpi/openmpi-1.4.4.ebuild
+++ b/sys-cluster/openmpi/openmpi-1.4.4.ebuild
@@ -1,19 +1,23 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/openmpi/openmpi-1.4.4.ebuild,v 1.2 2012/06/25 18:28:11 jsbronder Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/openmpi/openmpi-1.4.4.ebuild,v 1.3 2012/10/14 19:40:20 jlec Exp $
EAPI=3
+
+FORTRAN_NEEDED=fortran
+
inherit eutils fortran-2 multilib flag-o-matic toolchain-funcs
MY_P=${P/-mpi}
-S=${WORKDIR}/${MY_P}
DESCRIPTION="A high-performance message passing library (MPI)"
HOMEPAGE="http://www.open-mpi.org"
SRC_URI="http://www.open-mpi.org/software/ompi/v1.4/downloads/${MY_P}.tar.bz2"
+
LICENSE="BSD"
SLOT="0"
RESTRICT="mpi-threads? ( test )"
+
KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
IUSE="+cxx elibc_FreeBSD fortran heterogeneous ipv6 mpi-threads pbs romio threads vt"
RDEPEND="
@@ -28,6 +32,8 @@ RDEPEND="
!sys-cluster/mpiexec"
DEPEND="${RDEPEND}"
+S=${WORKDIR}/${MY_P}
+
pkg_setup() {
use fortran && fortran-2_pkg_setup
if use mpi-threads; then
diff --git a/sys-cluster/openmpi/openmpi-1.5.5.ebuild b/sys-cluster/openmpi/openmpi-1.5.5.ebuild
index bb20dba7e115..08d917dcab51 100644
--- a/sys-cluster/openmpi/openmpi-1.5.5.ebuild
+++ b/sys-cluster/openmpi/openmpi-1.5.5.ebuild
@@ -1,12 +1,14 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/openmpi/openmpi-1.5.5.ebuild,v 1.3 2012/06/25 18:28:11 jsbronder Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/openmpi/openmpi-1.5.5.ebuild,v 1.4 2012/10/14 19:40:20 jlec Exp $
EAPI=4
+
+FORTRAN_NEEDED=fortran
+
inherit eutils fortran-2 multilib flag-o-matic toolchain-funcs versionator
MY_P=${P/-mpi}
-S=${WORKDIR}/${MY_P}
IUSE_OPENMPI_FABRICS="
openmpi_fabrics_dapl
@@ -68,6 +70,8 @@ RDEPEND="
"
DEPEND="${RDEPEND}"
+S=${WORKDIR}/${MY_P}
+
pkg_setup() {
use fortran && fortran-2_pkg_setup
if use mpi-threads; then
diff --git a/sys-cluster/openmpi/openmpi-1.6-r1.ebuild b/sys-cluster/openmpi/openmpi-1.6-r1.ebuild
index 25566a065ccf..3b8a2b4e3126 100644
--- a/sys-cluster/openmpi/openmpi-1.6-r1.ebuild
+++ b/sys-cluster/openmpi/openmpi-1.6-r1.ebuild
@@ -1,12 +1,14 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/openmpi/openmpi-1.6-r1.ebuild,v 1.2 2012/06/25 18:28:11 jsbronder Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/openmpi/openmpi-1.6-r1.ebuild,v 1.3 2012/10/14 19:40:20 jlec Exp $
EAPI=4
+
+FORTRAN_NEEDED=fortran
+
inherit eutils fortran-2 multilib flag-o-matic toolchain-funcs versionator
MY_P=${P/-mpi}
-S=${WORKDIR}/${MY_P}
IUSE_OPENMPI_FABRICS="
openmpi_fabrics_dapl
@@ -68,6 +70,8 @@ RDEPEND="
"
DEPEND="${RDEPEND}"
+S=${WORKDIR}/${MY_P}
+
pkg_setup() {
use fortran && fortran-2_pkg_setup
if use mpi-threads; then
diff --git a/sys-cluster/openmpi/openmpi-1.6.1.ebuild b/sys-cluster/openmpi/openmpi-1.6.1.ebuild
index edb3b3956d82..26c97d9994bc 100644
--- a/sys-cluster/openmpi/openmpi-1.6.1.ebuild
+++ b/sys-cluster/openmpi/openmpi-1.6.1.ebuild
@@ -1,12 +1,14 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/openmpi/openmpi-1.6.1.ebuild,v 1.1 2012/09/24 22:06:01 jsbronder Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/openmpi/openmpi-1.6.1.ebuild,v 1.2 2012/10/14 19:40:20 jlec Exp $
EAPI=4
+
+FORTRAN_NEEDED=fortran
+
inherit eutils fortran-2 multilib flag-o-matic toolchain-funcs versionator
MY_P=${P/-mpi}
-S=${WORKDIR}/${MY_P}
IUSE_OPENMPI_FABRICS="
openmpi_fabrics_dapl
@@ -69,6 +71,8 @@ RDEPEND="
DEPEND="${RDEPEND}"
# TODO: Newer releases of Vampir use otf2 which would resolve the above blockers.
+S=${WORKDIR}/${MY_P}
+
pkg_setup() {
use fortran && fortran-2_pkg_setup
if use mpi-threads; then