summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Bronder <jsbronder@gentoo.org>2013-03-08 05:02:15 +0000
committerJustin Bronder <jsbronder@gentoo.org>2013-03-08 05:02:15 +0000
commit6f08b8db1303795e95209bf0cd954c6c8927cf1e (patch)
tree76db6e93285e491ef59db90426fd0b5cb6e63104 /sys-cluster
parentAdd epatch_user, as suggested by Ben Kohler in bug #459208 (diff)
downloadgentoo-2-6f08b8db1303795e95209bf0cd954c6c8927cf1e.tar.gz
gentoo-2-6f08b8db1303795e95209bf0cd954c6c8927cf1e.tar.bz2
gentoo-2-6f08b8db1303795e95209bf0cd954c6c8927cf1e.zip
Fix #453154 correctly.
(Portage version: 2.1.11.50/cvs/Linux x86_64, signed Manifest commit with key 4D7043C9)
Diffstat (limited to 'sys-cluster')
-rw-r--r--sys-cluster/torque/ChangeLog8
-rw-r--r--sys-cluster/torque/files/tcl8.6.patch (renamed from sys-cluster/torque/files/torque-2.5.12-tcl8.6.patch)35
-rw-r--r--sys-cluster/torque/files/torque-2.5.9-tcl8.6.patch66
-rw-r--r--sys-cluster/torque/files/torque-3.0.6-tcl8.6.patch66
-rw-r--r--sys-cluster/torque/torque-2.5.12.ebuild4
-rw-r--r--sys-cluster/torque/torque-2.5.9-r1.ebuild4
-rw-r--r--sys-cluster/torque/torque-3.0.6-r1.ebuild4
7 files changed, 41 insertions, 146 deletions
diff --git a/sys-cluster/torque/ChangeLog b/sys-cluster/torque/ChangeLog
index 97fe89e87920..b41263e0d101 100644
--- a/sys-cluster/torque/ChangeLog
+++ b/sys-cluster/torque/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-cluster/torque
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/torque/ChangeLog,v 1.149 2013/03/08 03:27:01 jsbronder Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/torque/ChangeLog,v 1.150 2013/03/08 05:02:15 jsbronder Exp $
+
+ 08 Mar 2013; Justin Bronder <jsbronder@gentoo.org> +files/tcl8.6.patch,
+ torque-2.5.9-r1.ebuild, -files/torque-2.5.9-tcl8.6.patch,
+ torque-2.5.12.ebuild, -files/torque-2.5.12-tcl8.6.patch,
+ torque-3.0.6-r1.ebuild, -files/torque-3.0.6-tcl8.6.patch:
+ Fix #453154 correctly.
08 Mar 2013; Justin Bronder <jsbronder@gentoo.org> torque-2.5.9-r1.ebuild,
torque-2.5.12.ebuild, torque-3.0.6-r1.ebuild:
diff --git a/sys-cluster/torque/files/torque-2.5.12-tcl8.6.patch b/sys-cluster/torque/files/tcl8.6.patch
index c8ce7191cf65..0361dbfead0a 100644
--- a/sys-cluster/torque/files/torque-2.5.12-tcl8.6.patch
+++ b/sys-cluster/torque/files/tcl8.6.patch
@@ -1,12 +1,30 @@
- src/cmds/qstat.c | 8 ++++----
- src/scheduler.tcl/pbs_tclWrap.c | 6 +++---
- 2 files changed, 7 insertions(+), 7 deletions(-)
+From 061f15e06d6cf85e951cd321360067de5f0b2ce0 Mon Sep 17 00:00:00 2001
+From: Justin Bronder <jsbronder@gmail.com>
+Date: Thu, 7 Mar 2013 22:33:04 -0500
+Subject: [PATCH] support tcl-8.6
+
+---
+ src/cmds/qstat.c | 13 +++++++++----
+ src/scheduler.tcl/pbs_tclWrap.c | 6 +++---
+ 2 files changed, 12 insertions(+), 7 deletions(-)
diff --git a/src/cmds/qstat.c b/src/cmds/qstat.c
-index 5f85de7..a782151 100644
+index 5f85de7..7f289ba 100644
--- a/src/cmds/qstat.c
+++ b/src/cmds/qstat.c
-@@ -1856,7 +1856,7 @@ tcl_init(void)
+@@ -88,6 +88,11 @@
+ #if TCL_QSTAT
+ #include <sys/stat.h>
+ #include <tcl.h>
++#if TCL_MAJOR_VERSION <=8 && TCL_MINOR_VERSION < 6
++#define Tcl_GetStringResult(x) x->result
++#define Tcl_GetErrorLine(x) x->errorLine
++#define Tcl_SetResult(x, y, z) x->result = y
++#endif
+ #if TCLX
+ #include <tclExtend.h>
+ #endif
+@@ -1856,7 +1861,7 @@ tcl_init(void)
if (Tcl_Init(interp) == TCL_ERROR)
{
fprintf(stderr, "Tcl_Init error: %s",
@@ -15,7 +33,7 @@ index 5f85de7..a782151 100644
}
#if TCLX
-@@ -1869,7 +1869,7 @@ tcl_init(void)
+@@ -1869,7 +1874,7 @@ tcl_init(void)
{
#endif
fprintf(stderr, "Tclx_Init error: %s",
@@ -24,7 +42,7 @@ index 5f85de7..a782151 100644
}
#endif /* TCLX */
-@@ -1980,10 +1980,10 @@ void tcl_run(
+@@ -1980,10 +1985,10 @@ void tcl_run(
trace = (char *)Tcl_GetVar(interp, "errorInfo", 0);
if (trace == NULL)
@@ -64,3 +82,6 @@ index e859ae5..194c24b 100644
msg = pbs_geterrmsg(connector);
sprintf(log_buffer, "%s (%d)", msg ? msg : fail, pbs_errno);
log_err(-1, argv[0], log_buffer);
+--
+1.7.12.4
+
diff --git a/sys-cluster/torque/files/torque-2.5.9-tcl8.6.patch b/sys-cluster/torque/files/torque-2.5.9-tcl8.6.patch
deleted file mode 100644
index c8ce7191cf65..000000000000
--- a/sys-cluster/torque/files/torque-2.5.9-tcl8.6.patch
+++ /dev/null
@@ -1,66 +0,0 @@
- src/cmds/qstat.c | 8 ++++----
- src/scheduler.tcl/pbs_tclWrap.c | 6 +++---
- 2 files changed, 7 insertions(+), 7 deletions(-)
-
-diff --git a/src/cmds/qstat.c b/src/cmds/qstat.c
-index 5f85de7..a782151 100644
---- a/src/cmds/qstat.c
-+++ b/src/cmds/qstat.c
-@@ -1856,7 +1856,7 @@ tcl_init(void)
- if (Tcl_Init(interp) == TCL_ERROR)
- {
- fprintf(stderr, "Tcl_Init error: %s",
-- interp->result);
-+ Tcl_GetStringResult(interp));
- }
-
- #if TCLX
-@@ -1869,7 +1869,7 @@ tcl_init(void)
- {
- #endif
- fprintf(stderr, "Tclx_Init error: %s",
-- interp->result);
-+ Tcl_GetStringResult(interp));
- }
-
- #endif /* TCLX */
-@@ -1980,10 +1980,10 @@ void tcl_run(
- trace = (char *)Tcl_GetVar(interp, "errorInfo", 0);
-
- if (trace == NULL)
-- trace = interp->result;
-+ trace = Tcl_GetStringResult(interp);
-
- fprintf(stderr, "%s: TCL error @ line %d: %s\n",
-- script, interp->errorLine, trace);
-+ script, Tcl_GetErrorLine(interp), trace);
- }
-
- Tcl_DeleteInterp(interp);
-diff --git a/src/scheduler.tcl/pbs_tclWrap.c b/src/scheduler.tcl/pbs_tclWrap.c
-index e859ae5..194c24b 100644
---- a/src/scheduler.tcl/pbs_tclWrap.c
-+++ b/src/scheduler.tcl/pbs_tclWrap.c
-@@ -924,7 +924,7 @@ char *argv[];
-
- if (argc != 2)
- {
-- sprintf(interp->result,
-+ sprintf(Tcl_GetStringResult(interp),
- "%s: wrong # args: job_id", argv[0]);
- return TCL_ERROR;
- }
-@@ -936,11 +936,11 @@ char *argv[];
- return TCL_OK;
- }
-
-- interp->result = "0";
-+ Tcl_SetResult(interp, "0", TCL_STATIC);
-
- if (pbs_rerunjob(connector, argv[1], extend))
- {
-- interp->result = "-1";
-+ Tcl_SetResult(interp, "-1", TCL_STATIC);
- msg = pbs_geterrmsg(connector);
- sprintf(log_buffer, "%s (%d)", msg ? msg : fail, pbs_errno);
- log_err(-1, argv[0], log_buffer);
diff --git a/sys-cluster/torque/files/torque-3.0.6-tcl8.6.patch b/sys-cluster/torque/files/torque-3.0.6-tcl8.6.patch
deleted file mode 100644
index c8ce7191cf65..000000000000
--- a/sys-cluster/torque/files/torque-3.0.6-tcl8.6.patch
+++ /dev/null
@@ -1,66 +0,0 @@
- src/cmds/qstat.c | 8 ++++----
- src/scheduler.tcl/pbs_tclWrap.c | 6 +++---
- 2 files changed, 7 insertions(+), 7 deletions(-)
-
-diff --git a/src/cmds/qstat.c b/src/cmds/qstat.c
-index 5f85de7..a782151 100644
---- a/src/cmds/qstat.c
-+++ b/src/cmds/qstat.c
-@@ -1856,7 +1856,7 @@ tcl_init(void)
- if (Tcl_Init(interp) == TCL_ERROR)
- {
- fprintf(stderr, "Tcl_Init error: %s",
-- interp->result);
-+ Tcl_GetStringResult(interp));
- }
-
- #if TCLX
-@@ -1869,7 +1869,7 @@ tcl_init(void)
- {
- #endif
- fprintf(stderr, "Tclx_Init error: %s",
-- interp->result);
-+ Tcl_GetStringResult(interp));
- }
-
- #endif /* TCLX */
-@@ -1980,10 +1980,10 @@ void tcl_run(
- trace = (char *)Tcl_GetVar(interp, "errorInfo", 0);
-
- if (trace == NULL)
-- trace = interp->result;
-+ trace = Tcl_GetStringResult(interp);
-
- fprintf(stderr, "%s: TCL error @ line %d: %s\n",
-- script, interp->errorLine, trace);
-+ script, Tcl_GetErrorLine(interp), trace);
- }
-
- Tcl_DeleteInterp(interp);
-diff --git a/src/scheduler.tcl/pbs_tclWrap.c b/src/scheduler.tcl/pbs_tclWrap.c
-index e859ae5..194c24b 100644
---- a/src/scheduler.tcl/pbs_tclWrap.c
-+++ b/src/scheduler.tcl/pbs_tclWrap.c
-@@ -924,7 +924,7 @@ char *argv[];
-
- if (argc != 2)
- {
-- sprintf(interp->result,
-+ sprintf(Tcl_GetStringResult(interp),
- "%s: wrong # args: job_id", argv[0]);
- return TCL_ERROR;
- }
-@@ -936,11 +936,11 @@ char *argv[];
- return TCL_OK;
- }
-
-- interp->result = "0";
-+ Tcl_SetResult(interp, "0", TCL_STATIC);
-
- if (pbs_rerunjob(connector, argv[1], extend))
- {
-- interp->result = "-1";
-+ Tcl_SetResult(interp, "-1", TCL_STATIC);
- msg = pbs_geterrmsg(connector);
- sprintf(log_buffer, "%s (%d)", msg ? msg : fail, pbs_errno);
- log_err(-1, argv[0], log_buffer);
diff --git a/sys-cluster/torque/torque-2.5.12.ebuild b/sys-cluster/torque/torque-2.5.12.ebuild
index 2eba649607d3..678ebc0ad442 100644
--- a/sys-cluster/torque/torque-2.5.12.ebuild
+++ b/sys-cluster/torque/torque-2.5.12.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/torque/torque-2.5.12.ebuild,v 1.3 2013/03/08 03:27:01 jsbronder Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/torque/torque-2.5.12.ebuild,v 1.4 2013/03/08 05:02:15 jsbronder Exp $
EAPI=4
@@ -34,7 +34,7 @@ RDEPEND="${DEPEND_COMMON}
DOCS=( Release_Notes )
-PATCHES=( "${FILESDIR}"/${P}-tcl8.6.patch )
+PATCHES=( "${FILESDIR}"/tcl8.6.patch )
AUTOTOOLS_IN_SOURCE_BUILD=1
diff --git a/sys-cluster/torque/torque-2.5.9-r1.ebuild b/sys-cluster/torque/torque-2.5.9-r1.ebuild
index 26c44f2eba2f..65df53940821 100644
--- a/sys-cluster/torque/torque-2.5.9-r1.ebuild
+++ b/sys-cluster/torque/torque-2.5.9-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/torque/torque-2.5.9-r1.ebuild,v 1.2 2013/03/08 03:27:01 jsbronder Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/torque/torque-2.5.9-r1.ebuild,v 1.3 2013/03/08 05:02:15 jsbronder Exp $
EAPI=4
@@ -34,7 +34,7 @@ RDEPEND="${DEPEND_COMMON}
DOCS=( Release_Notes )
-PATCHES=( "${FILESDIR}"/${P}-tcl8.6.patch )
+PATCHES=( "${FILESDIR}"/tcl8.6.patch )
pkg_setup() {
PBS_SERVER_HOME="${PBS_SERVER_HOME:-/var/spool/torque}"
diff --git a/sys-cluster/torque/torque-3.0.6-r1.ebuild b/sys-cluster/torque/torque-3.0.6-r1.ebuild
index a9b821eaec87..17ee11b545b8 100644
--- a/sys-cluster/torque/torque-3.0.6-r1.ebuild
+++ b/sys-cluster/torque/torque-3.0.6-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/torque/torque-3.0.6-r1.ebuild,v 1.3 2013/03/08 03:27:01 jsbronder Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/torque/torque-3.0.6-r1.ebuild,v 1.4 2013/03/08 05:02:15 jsbronder Exp $
EAPI=4
@@ -37,7 +37,7 @@ RDEPEND="${DEPEND_COMMON}
DOCS=( Release_Notes )
-PATCHES=( "${FILESDIR}"/${P}-tcl8.6.patch )
+PATCHES=( "${FILESDIR}"/tcl8.6.patch )
AUTOTOOLS_IN_SOURCE_BUILD=1