summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Bronder <jsbronder@gentoo.org>2010-06-17 01:41:16 +0000
committerJustin Bronder <jsbronder@gentoo.org>2010-06-17 01:41:16 +0000
commit94d8165850d88efbd1ca9b6cba6044ea6002990d (patch)
tree1b3651d25346ac8140c4305aee251297d741ae2c /sys-cluster
parentAutomated update of use.local.desc (diff)
downloadgentoo-2-94d8165850d88efbd1ca9b6cba6044ea6002990d.tar.gz
gentoo-2-94d8165850d88efbd1ca9b6cba6044ea6002990d.tar.bz2
gentoo-2-94d8165850d88efbd1ca9b6cba6044ea6002990d.zip
sys-cluster/openmpi cleanup
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'sys-cluster')
-rw-r--r--sys-cluster/openmpi/ChangeLog5
-rw-r--r--sys-cluster/openmpi/openmpi-1.2.9.ebuild109
2 files changed, 4 insertions, 110 deletions
diff --git a/sys-cluster/openmpi/ChangeLog b/sys-cluster/openmpi/ChangeLog
index fed53a00f32d..a99a55304227 100644
--- a/sys-cluster/openmpi/ChangeLog
+++ b/sys-cluster/openmpi/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for sys-cluster/openmpi
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/openmpi/ChangeLog,v 1.65 2010/05/23 18:26:18 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/openmpi/ChangeLog,v 1.66 2010/06/17 01:41:16 jsbronder Exp $
+
+ 17 Jun 2010; Justin Bronder <jsbronder@gentoo.org> -openmpi-1.2.9.ebuild:
+ sys-cluster/openmpi cleanup
23 May 2010; Pacho Ramos <pacho@gentoo.org> openmpi-1.4.1.ebuild:
stable amd64, bug 307627
diff --git a/sys-cluster/openmpi/openmpi-1.2.9.ebuild b/sys-cluster/openmpi/openmpi-1.2.9.ebuild
deleted file mode 100644
index c3ddf4ca866c..000000000000
--- a/sys-cluster/openmpi/openmpi-1.2.9.ebuild
+++ /dev/null
@@ -1,109 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/openmpi/openmpi-1.2.9.ebuild,v 1.7 2009/07/05 14:41:08 maekke Exp $
-
-EAPI=1
-inherit eutils multilib flag-o-matic toolchain-funcs fortran
-
-MY_P=${P/-mpi}
-S=${WORKDIR}/${MY_P}
-
-DESCRIPTION="A high-performance message passing library (MPI)"
-HOMEPAGE="http://www.open-mpi.org"
-SRC_URI="http://www.open-mpi.org/software/ompi/v1.2/downloads/${MY_P}.tar.bz2"
-LICENSE="BSD"
-SLOT="0"
-RESTRICT="mpi-threads? ( test )"
-KEYWORDS="alpha amd64 ppc ppc64 sparc x86"
-IUSE="+cxx fortran heterogeneous ipv6 mpi-threads pbs romio threads"
-RDEPEND="pbs? ( sys-cluster/torque )
- !sys-cluster/mpich
- !sys-cluster/lam-mpi
- !sys-cluster/mpich2"
-DEPEND="${RDEPEND}"
-
-pkg_setup() {
- if use mpi-threads; then
- ewarn
- ewarn "WARNING: use of MPI_THREAD_MULTIPLE is still disabled by"
- ewarn "default and officially unsupported by upstream."
- ewarn "You may stop now and set USE=-mpi-threads"
- ewarn
- epause 5
- fi
-
- elog
- elog "OpenMPI has an overwhelming count of configuration options."
- elog "Don't forget the EXTRA_ECONF environment variable can let you"
- elog "specify configure options if you find them necessary."
- elog
-
- if use fortran; then
- FORTRAN="g77 gfortran ifc"
- fortran_pkg_setup
- fi
-}
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
- # Necessary for scalibility, see
- # http://www.open-mpi.org/community/lists/users/2008/09/6514.php
- if use threads; then
- echo 'oob_tcp_listen_mode = listen_thread' \
- >> opal/etc/openmpi-mca-params.conf
- fi
-}
-
-src_compile() {
- local myconf="
- --sysconfdir=/etc/${PN}
- --without-xgrid
- --enable-pretty-print-stacktrace
- --enable-orterun-prefix-by-default
- --without-slurm"
-
- if use mpi-threads; then
- myconf="${myconf}
- --enable-mpi-threads
- --with-progress-threads"
- fi
-
- if use fortran; then
- if [[ "${FORTRANC}" = "g77" ]]; then
- myconf="${myconf} --disable-mpi-f90"
- elif [[ "${FORTRANC}" = "gfortran" ]]; then
- # Because that's just a pain in the butt.
- myconf="${myconf} --with-wrapper-fflags=-I/usr/include"
- elif [[ "${FORTRANC}" = if* ]]; then
- # Enabled here as gfortran compile times are huge with this enabled.
- myconf="${myconf} --with-mpi-f90-size=medium"
- fi
- else
- myconf="${myconf}
- --disable-mpi-f90
- --disable-mpi-f77"
- fi
-
- econf ${myconf} \
- $(use_enable cxx mpi-cxx) \
- $(use_enable romio io-romio) \
- $(use_enable heterogeneous) \
- $(use_with pbs tm) \
- $(use_enable ipv6) \
- || die "econf failed"
-
- emake || die "emake failed"
-}
-
-src_install () {
- emake DESTDIR="${D}" install || die "make install failed"
- dodoc README AUTHORS NEWS VERSION
-}
-
-src_test() {
- # Doesn't work with the default src_test as the dry run (-n) fails.
- cd "${S}"
- emake -j1 check || die "emake check failed"
-}