summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexys Jacob <ultrabug@gentoo.org>2011-02-28 12:52:49 +0000
committerAlexys Jacob <ultrabug@gentoo.org>2011-02-28 12:52:49 +0000
commit9d02367a73092a9832b6b954d881f4ef5e176153 (patch)
tree0071c975e2fd75226a5c02b45378bdd44cd2a564 /sys-cluster
parentFixed prefix support and support for multilib. Bug #356467 and #350092 (diff)
downloadgentoo-2-9d02367a73092a9832b6b954d881f4ef5e176153.tar.gz
gentoo-2-9d02367a73092a9832b6b954d881f4ef5e176153.tar.bz2
gentoo-2-9d02367a73092a9832b6b954d881f4ef5e176153.zip
create symlinks for ocf libs wrt #356677
(Portage version: 2.1.9.40/cvs/Linux x86_64)
Diffstat (limited to 'sys-cluster')
-rw-r--r--sys-cluster/resource-agents/ChangeLog8
-rw-r--r--sys-cluster/resource-agents/files/1.0.4-dosymlinks.patch25
-rw-r--r--sys-cluster/resource-agents/resource-agents-1.0.4-r1.ebuild62
3 files changed, 94 insertions, 1 deletions
diff --git a/sys-cluster/resource-agents/ChangeLog b/sys-cluster/resource-agents/ChangeLog
index e0ae4113e807..09dbd2b8bca0 100644
--- a/sys-cluster/resource-agents/ChangeLog
+++ b/sys-cluster/resource-agents/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-cluster/resource-agents
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/resource-agents/ChangeLog,v 1.9 2011/02/22 12:41:35 ultrabug Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/resource-agents/ChangeLog,v 1.10 2011/02/28 12:52:49 ultrabug Exp $
+
+*resource-agents-1.0.4-r1 (28 Feb 2011)
+
+ 28 Feb 2011; Ultrabug <ultrabug@gentoo.org> +files/1.0.4-dosymlinks.patch,
+ +resource-agents-1.0.4-r1.ebuild:
+ create symlinks for ocf libs wrt #356677
*resource-agents-1.0.4 (22 Feb 2011)
diff --git a/sys-cluster/resource-agents/files/1.0.4-dosymlinks.patch b/sys-cluster/resource-agents/files/1.0.4-dosymlinks.patch
new file mode 100644
index 000000000000..3fe17fcd90f7
--- /dev/null
+++ b/sys-cluster/resource-agents/files/1.0.4-dosymlinks.patch
@@ -0,0 +1,25 @@
+--- a/configure.in 2011-02-28 11:51:26.198614376 +0100
++++ b/configure.in 2011-02-28 11:59:10.201953304 +0100
+@@ -79,6 +79,7 @@
+ dnl ===============================================
+ dnl Helpers
+ dnl ===============================================
++AC_PROG_LN_S
+ cc_supports_flag() {
+ local CFLAGS="$@"
+ AC_MSG_CHECKING(whether $CC supports "$@")
+--- a/Makefile.am 2011-02-28 11:51:26.188614089 +0100
++++ b/Makefile.am 2011-02-28 13:36:15.860697714 +0100
+@@ -24,6 +24,12 @@
+ install-exec-local:
+ $(INSTALL) -d -m 1755 $(DESTDIR)$(HA_RSCTMPDIR)
+
++ $(LN_S) ../../lib/heartbeat/ocf-binaries $(DESTDIR)${OCF_RA_DIR}/heartbeat/.ocf-binaries
++ $(LN_S) ../../lib/heartbeat/ocf-directories $(DESTDIR)${OCF_RA_DIR}/heartbeat/.ocf-directories
++ $(LN_S) ../../lib/heartbeat/ocf-returncodes $(DESTDIR)${OCF_RA_DIR}/heartbeat/.ocf-returncodes
++ $(LN_S) ../../lib/heartbeat/ocf-shellfuncs $(DESTDIR)${OCF_RA_DIR}/heartbeat/.ocf-shellfuncs
++
++
+ dist-clean-local:
+ rm -f autoconf automake autoheader $(TARFILE)
+
diff --git a/sys-cluster/resource-agents/resource-agents-1.0.4-r1.ebuild b/sys-cluster/resource-agents/resource-agents-1.0.4-r1.ebuild
new file mode 100644
index 000000000000..f52f681a75a9
--- /dev/null
+++ b/sys-cluster/resource-agents/resource-agents-1.0.4-r1.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/resource-agents/resource-agents-1.0.4-r1.ebuild,v 1.1 2011/02/28 12:52:49 ultrabug Exp $
+
+EAPI="2"
+
+MY_P="${P/resource-}"
+inherit autotools multilib eutils base
+
+DESCRIPTION="Resources pack for Heartbeat / Pacemaker"
+HOMEPAGE="http://www.linux-ha.org/wiki/Resource_Agents"
+SRC_URI="http://hg.linux-ha.org/agents/archive/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~x86"
+IUSE="doc libnet"
+
+DEPEND="sys-apps/iproute2
+ sys-cluster/cluster-glue
+ !<sys-cluster/heartbeat-3.0
+ libnet? ( <net-libs/libnet-1.1.5 )"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/Cluster-Resource-Agents-${MY_P}"
+
+PATCHES=(
+ "${FILESDIR}/1.0.3-docs.patch"
+ "${FILESDIR}/1.0.3-respect_cflags.patch"
+ "${FILESDIR}/1.0.4-dosymlinks.patch"
+)
+
+src_prepare() {
+ base_src_prepare
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --disable-dependency-tracking \
+ --disable-fatal-warnings \
+ --localstatedir=/var \
+ --docdir=/usr/share/doc/${PF} \
+ --libdir=/usr/$(get_libdir) \
+ --with-ocf-root=/usr/$(get_libdir)/ocf \
+ $(use_enable doc) \
+ $(use_enable libnet)
+}
+
+src_install() {
+ base_src_install
+ rm -rf "${D}"/etc/init.d/ldirectord || die
+}
+
+pkg_postinst() {
+ elog "To use Resource Agents installed in /usr/$(get_libdir)/ocf/resource.d"
+ elog "you have to emerge required runtime dependencies manually."
+ elog ""
+ elog "Description and dependencies of all Agents can be found on"
+ elog "http://www.linux-ha.org/wiki/Resource_Agents"
+ elog "or in the documentation of this package."
+}