summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2014-08-01 05:14:51 +0000
committerMatthew Thode <prometheanfire@gentoo.org>2014-08-01 05:14:51 +0000
commitbca9c2039c856940521e3678a3bd0057ee6422e3 (patch)
treeda76a558bf57f5a4c48f30fa8047e10760fbe245 /sys-cluster
parentupdating git master cinder (diff)
downloadgentoo-2-bca9c2039c856940521e3678a3bd0057ee6422e3.tar.gz
gentoo-2-bca9c2039c856940521e3678a3bd0057ee6422e3.tar.bz2
gentoo-2-bca9c2039c856940521e3678a3bd0057ee6422e3.zip
updating git master neutron
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 0x2471eb3e40ac5ac3)
Diffstat (limited to 'sys-cluster')
-rw-r--r--sys-cluster/neutron/ChangeLog5
-rw-r--r--sys-cluster/neutron/neutron-9999.ebuild117
2 files changed, 81 insertions, 41 deletions
diff --git a/sys-cluster/neutron/ChangeLog b/sys-cluster/neutron/ChangeLog
index 01a2453a4c7b..ab88be1c76e3 100644
--- a/sys-cluster/neutron/ChangeLog
+++ b/sys-cluster/neutron/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for sys-cluster/neutron
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/neutron/ChangeLog,v 1.37 2014/07/26 23:01:46 prometheanfire Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/neutron/ChangeLog,v 1.38 2014/08/01 05:14:51 prometheanfire Exp $
+
+ 01 Aug 2014; Matthew Thode <prometheanfire@gentoo.org> neutron-9999.ebuild:
+ updating git master neutron
26 Jul 2014; Matthew Thode <prometheanfire@gentoo.org>
neutron-2014.1.1.ebuild, neutron-2014.1.9999.ebuild, neutron-9999.ebuild:
diff --git a/sys-cluster/neutron/neutron-9999.ebuild b/sys-cluster/neutron/neutron-9999.ebuild
index 61842b79be13..af59ebaa501a 100644
--- a/sys-cluster/neutron/neutron-9999.ebuild
+++ b/sys-cluster/neutron/neutron-9999.ebuild
@@ -1,14 +1,12 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/neutron/neutron-9999.ebuild,v 1.12 2014/07/26 23:01:44 prometheanfire Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/neutron/neutron-9999.ebuild,v 1.13 2014/08/01 05:14:51 prometheanfire Exp $
EAPI=5
PYTHON_COMPAT=( python2_7 )
inherit distutils-r1 git-2 user
-#restricted due to packages missing and bad depends in the test ==webob-1.0.8
-RESTRICT="test"
DESCRIPTION="A virtual network service for Openstack."
HOMEPAGE="https://launchpad.net/neutron"
EGIT_REPO_URI="https://github.com/openstack/neutron.git"
@@ -16,41 +14,45 @@ EGIT_REPO_URI="https://github.com/openstack/neutron.git"
LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS=""
-IUSE="+dhcp +l3 +metadata +openvswitch +server test sqlite mysql postgres"
+IUSE="+dhcp doc +l3 +metadata +openvswitch +server test sqlite mysql postgres"
REQUIRED_USE="|| ( mysql postgres sqlite )"
#the cliff dep is as below because it depends on pyparsing, which only has 2.7 OR 3.2, not both
DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ >=dev-python/pbr-0.6[${PYTHON_USEDEP}]
+ <dev-python/pbr-1.0[${PYTHON_USEDEP}]
app-admin/sudo
- test? ( dev-python/cliff[${PYTHON_USEDEP}]
- dev-python/configobj[${PYTHON_USEDEP}]
- dev-python/coverage[${PYTHON_USEDEP}]
+ test? ( >=dev-python/hacking-0.8.0[${PYTHON_USEDEP}]
+ <dev-python/hacking-0.9[${PYTHON_USEDEP}]
+ >=dev-python/cliff-1.4.3[${PYTHON_USEDEP}]
+ >=dev-python/coverage-3.6[${PYTHON_USEDEP}]
+ >=dev-python/fixtures-0.3.14[${PYTHON_USEDEP}]
>=dev-python/mock-1.0[${PYTHON_USEDEP}]
- ~dev-python/mox-0.5.3[${PYTHON_USEDEP}]
- dev-python/nose[${PYTHON_USEDEP}]
- dev-python/nosehtmloutput[${PYTHON_USEDEP}]
- dev-python/nosexcover[${PYTHON_USEDEP}]
- dev-python/openstack-nose-plugin[${PYTHON_USEDEP}]
- ~dev-python/pep8-1.4.5[${PYTHON_USEDEP}]
+ >=dev-python/subunit-0.0.18[${PYTHON_USEDEP}]
>=dev-python/sphinx-1.1.2[${PYTHON_USEDEP}]
- ~dev-python/webtest-1.3.3[${PYTHON_USEDEP}] )"
-RDEPEND=">=dev-python/pastedeploy-1.5.0-r1[${PYTHON_USEDEP}]
- >=dev-python/alembic-0.4.1[${PYTHON_USEDEP}]
- dev-python/paste[${PYTHON_USEDEP}]
+ <dev-python/sphinx-1.2[${PYTHON_USEDEP}]
+ >=dev-python/testrepository-0.0.18[${PYTHON_USEDEP}]
+ >=dev-python/testtools-0.9.34[${PYTHON_USEDEP}]
+ >=dev-python/webtest-2.0[${PYTHON_USEDEP}]
+ dev-python/configobj[${PYTHON_USEDEP}] )"
+
+RDEPEND="dev-python/paste[${PYTHON_USEDEP}]
+ >=dev-python/pastedeploy-1.5.0-r1[${PYTHON_USEDEP}]
>=dev-python/routes-1.12.3[${PYTHON_USEDEP}]
>=dev-python/amqplib-0.6.1-r1[${PYTHON_USEDEP}]
- >=dev-python/anyjson-0.2.4[${PYTHON_USEDEP}]
- >=dev-python/eventlet-0.9.17[${PYTHON_USEDEP}]
- >=dev-python/greenlet-0.3.1[${PYTHON_USEDEP}]
- dev-python/httplib2[${PYTHON_USEDEP}]
- >=dev-python/iso8601-0.1.4[${PYTHON_USEDEP}]
- >=dev-python/kombu-1.0.4-r1[${PYTHON_USEDEP}]
- dev-python/netaddr[${PYTHON_USEDEP}]
- >=dev-python/python-keystoneclient-0.2.0[${PYTHON_USEDEP}]
- dev-python/python-novaclient[${PYTHON_USEDEP}]
- >=dev-python/python-neutronclient-2.3.0[${PYTHON_USEDEP}]
+ >=dev-python/anyjson-0.3.3[${PYTHON_USEDEP}]
+ >=dev-python/Babel-1.3[${PYTHON_USEDEP}]
+ >=dev-python/eventlet-0.13.0[${PYTHON_USEDEP}]
+ >=dev-python/greenlet-0.3.2[${PYTHON_USEDEP}]
+ >=dev-python/httplib2-0.7.5[${PYTHON_USEDEP}]
+ >=dev-python/requests-1.1[${PYTHON_USEDEP}]
+ >=dev-python/iso8601-0.1.9[${PYTHON_USEDEP}]
+ dev-python/jsonrpclib[${PYTHON_USEDEP}]
+ dev-python/jinja[${PYTHON_USEDEP}]
+ >=dev-python/kombu-2.4.8[${PYTHON_USEDEP}]
+ >=dev-python/netaddr-0.7.6[${PYTHON_USEDEP}]
+ >=dev-python/python-neutronclient-2.3.4[${PYTHON_USEDEP}]
<=dev-python/python-neutronclient-3.0.0[${PYTHON_USEDEP}]
- dev-python/pyudev[${PYTHON_USEDEP}]
sqlite? (
>=dev-python/sqlalchemy-0.8.0[sqlite,${PYTHON_USEDEP}]
!~dev-python/sqlalchemy-0.9.5[sqlite,${PYTHON_USEDEP}]
@@ -68,18 +70,56 @@ RDEPEND=">=dev-python/pastedeploy-1.5.0-r1[${PYTHON_USEDEP}]
!~dev-python/sqlalchemy-0.9.5[${PYTHON_USEDEP}]
<=dev-python/sqlalchemy-0.9.99[${PYTHON_USEDEP}]
)
- >=dev-python/webob-1.2[${PYTHON_USEDEP}]
- >=dev-python/oslo-config-1.1.0[${PYTHON_USEDEP}]
- <dev-python/oslo-config-1.2.0[${PYTHON_USEDEP}]
- net-misc/bridge-utils
- net-misc/openvswitch
+ >=dev-python/webob-1.2.3[${PYTHON_USEDEP}]
+ >=dev-python/python-keystoneclient-0.7.0[${PYTHON_USEDEP}]
+ >=dev-python/alembic-0.4.1[${PYTHON_USEDEP}]
+ >=dev-python/six-1.5.2[${PYTHON_USEDEP}]
+ >=dev-python/stevedore-0.14[${PYTHON_USEDEP}]
+ >=dev-python/oslo-config-1.2.0[${PYTHON_USEDEP}]
+ dev-python/oslo-rootwrap[${PYTHON_USEDEP}]
+ >=dev-python/python-novaclient-2.17.0[${PYTHON_USEDEP}]
+ dev-python/pyudev[${PYTHON_USEDEP}]
+ sys-apps/iproute2
+ openvswitch? ( net-misc/openvswitch )
dhcp? ( net-dns/dnsmasq[dhcp-tools] )"
+PATCHES=( "${FILESDIR}/sphinx_mapping.patch" )
+
pkg_setup() {
enewgroup neutron
enewuser neutron -1 -1 /var/lib/neutron neutron
}
+pkg_config() {
+ fperms 0700 /var/log/neutron
+ fowners neutron:neutron /var/log neutron
+}
+
+src_prepare() {
+ #it's /bin/ip not /sbin/ip
+ sed -i 's/sbin\/ip\,/bin\/ip\,/g' etc/neutron/rootwrap.d/*
+ distutils-r1_src_prepare
+}
+
+python_compile_all() {
+ use doc && make -C doc html
+}
+
+python_test() {
+ # https://bugs.launchpad.net/neutron/+bug/1234857
+ # https://bugs.launchpad.net/swift/+bug/1249727
+ # https://bugs.launchpad.net/neutron/+bug/1251657
+ # turn multiprocessing off, testr will use it --parallel
+ local DISTUTILS_NO_PARALLEL_BUILD=1
+ # Move tests out that attempt net connection, have failures
+ mv $(find . -name test_ovs_tunnel.py) . || die
+ sed -e 's:test_app_using_ipv6_and_ssl:_&:' \
+ -e 's:test_start_random_port_with_ipv6:_&:' \
+ -i neutron/tests/unit/test_wsgi.py || die
+ testr init
+ testr run --parallel || die "failed testsuite under python2.7"
+}
+
python_install() {
distutils-r1_python_install
newconfd "${FILESDIR}/neutron-confd" "neutron"
@@ -92,14 +132,11 @@ python_install() {
use openvswitch && dosym /etc/init.d/neutron /etc/init.d/neutron-openvswitch-agent
diropts -m 750
- dodir /var/log/neutron /var/log/quantum
+ dodir /var/log/neutron /var/log/neutron
fowners neutron:neutron /var/log/neutron
keepdir /etc/neutron
insinto /etc/neutron
- #it's /bin/ip not /sbin/ip
- sed -i 's/sbin\/ip\,/bin\/ip\,/g' "etc/quantum/rootwrap.d/*"
-
doins "etc/api-paste.ini"
doins "etc/dhcp_agent.ini"
doins "etc/l3_agent.ini"
@@ -120,7 +157,7 @@ python_install() {
doins "${FILESDIR}/neutron-sudoers"
}
-pkg_config() {
- fperms 0700 /var/log/neutron
- fowners neutron:neutron /var/log neutron
+python_install_all() {
+ use doc && local HTML_DOCS=( doc/build/html/. )
+ distutils-r1_python_install_all
}