summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKacper Kowalik <xarthisius@gentoo.org>2010-06-26 16:32:39 +0000
committerKacper Kowalik <xarthisius@gentoo.org>2010-06-26 16:32:39 +0000
commitbdd1b13828c80cdb39dbe79ed5bc6853e169f376 (patch)
tree6d1a01c7fda8beecc490fee1629c71600b78e6a1 /sys-cluster
parentStable on amd64 wrt bug #325577 (diff)
downloadgentoo-2-bdd1b13828c80cdb39dbe79ed5bc6853e169f376.tar.gz
gentoo-2-bdd1b13828c80cdb39dbe79ed5bc6853e169f376.tar.bz2
gentoo-2-bdd1b13828c80cdb39dbe79ed5bc6853e169f376.zip
Initial import. Ebuild written by Tomáš Chvátal <scarabeus@gentoo.org>
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'sys-cluster')
-rw-r--r--sys-cluster/openais/ChangeLog10
-rw-r--r--sys-cluster/openais/metadata.xml14
-rw-r--r--sys-cluster/openais/openais-1.1.3.ebuild45
3 files changed, 69 insertions, 0 deletions
diff --git a/sys-cluster/openais/ChangeLog b/sys-cluster/openais/ChangeLog
new file mode 100644
index 000000000000..9a6afd987866
--- /dev/null
+++ b/sys-cluster/openais/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for sys-cluster/openais
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/openais/ChangeLog,v 1.8 2010/06/26 16:32:39 xarthisius Exp $
+
+*openais-1.1.3 (26 Jun 2010)
+
+ 26 Jun 2010; Kacper Kowalik <xarthisius@gentoo.org> +openais-1.1.3.ebuild,
+ +metadata.xml:
+ Initial import. Ebuild written by Tomáš Chvátal <scarabeus@gentoo.org>
+
diff --git a/sys-cluster/openais/metadata.xml b/sys-cluster/openais/metadata.xml
new file mode 100644
index 000000000000..6a8261ba697c
--- /dev/null
+++ b/sys-cluster/openais/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>ha-cluster</herd>
+ <longdescription>
+ The OpenAIS Standards Based Cluster Framework is an OSI Certified implementation of
+ the Service Availability Forum Application Interface Specification (AIS).
+ The Application Interface Specification is a software API and policies which are
+ used to develop applications that maintain service during faults.
+ Restarting and failover of applications is also provided for those
+ deploying applications which may not be modified. The OpenAIS software is built
+ to operate as plugins to the Corosync Cluster Engine.
+ </longdescription>
+</pkgmetadata>
diff --git a/sys-cluster/openais/openais-1.1.3.ebuild b/sys-cluster/openais/openais-1.1.3.ebuild
new file mode 100644
index 000000000000..efa83a296d27
--- /dev/null
+++ b/sys-cluster/openais/openais-1.1.3.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/openais/openais-1.1.3.ebuild,v 1.1 2010/06/26 16:32:39 xarthisius Exp $
+
+EAPI="2"
+
+inherit autotools base
+
+DESCRIPTION="Open Application Interface Specification cluster framework"
+HOMEPAGE="http://www.openais.org/"
+SRC_URI="ftp://ftp:${PN}.org@${PN}.org/downloads/${P}/${P}.tar.gz"
+
+LICENSE="BSD public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="sys-cluster/corosync"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+DOCS=( "${S}/AUTHORS" "${S}/README.amf" )
+
+src_prepare() {
+ # respect CFLAGS
+ sed -i -e "s/\$OPT_CFLAGS \$GDB_FLAGS//" configure.ac || die
+ # respect LDFLAGS
+ sed -i -e "s/\$(CFLAGS) -shared/\$(CFLAGS) \$(LDFLAGS) -shared/" \
+ services/Makefile.am || die
+ # don't install docs
+ sed -i -e "/^dist_doc/d" Makefile.am || die
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --disable-dependency-tracking \
+ --docdir=/usr/share/doc/${PF}
+ --localstatedir=/var
+}
+
+src_install() {
+ base_src_install
+ rm -rf "${D}"/etc/init.d/openais || die
+}