summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKacper Kowalik <xarthisius@gentoo.org>2011-01-22 23:18:44 +0000
committerKacper Kowalik <xarthisius@gentoo.org>2011-01-22 23:18:44 +0000
commitcf5813dac3063a45329a0f4322fd47e61978c822 (patch)
treebda0aefdfc00d903b21d10e5b6e0779e907129ef /sys-cluster
parentppc64 stable wrt #345463 (diff)
downloadgentoo-2-cf5813dac3063a45329a0f4322fd47e61978c822.tar.gz
gentoo-2-cf5813dac3063a45329a0f4322fd47e61978c822.tar.bz2
gentoo-2-cf5813dac3063a45329a0f4322fd47e61978c822.zip
Drop old.
(Portage version: 2.1.9.25/cvs/Linux ppc64)
Diffstat (limited to 'sys-cluster')
-rw-r--r--sys-cluster/torque/ChangeLog5
-rw-r--r--sys-cluster/torque/torque-2.3.6.ebuild222
2 files changed, 4 insertions, 223 deletions
diff --git a/sys-cluster/torque/ChangeLog b/sys-cluster/torque/ChangeLog
index 37847bafa73f..80b877b51568 100644
--- a/sys-cluster/torque/ChangeLog
+++ b/sys-cluster/torque/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for sys-cluster/torque
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/torque/ChangeLog,v 1.107 2011/01/22 23:16:02 xarthisius Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/torque/ChangeLog,v 1.108 2011/01/22 23:18:44 xarthisius Exp $
+
+ 22 Jan 2011; Kacper Kowalik <xarthisius@gentoo.org> -torque-2.3.6.ebuild:
+ Drop old.
22 Jan 2011; Kacper Kowalik <xarthisius@gentoo.org> torque-2.3.13.ebuild:
ppc64 stable wrt #345463
diff --git a/sys-cluster/torque/torque-2.3.6.ebuild b/sys-cluster/torque/torque-2.3.6.ebuild
deleted file mode 100644
index 7f56aad8c071..000000000000
--- a/sys-cluster/torque/torque-2.3.6.ebuild
+++ /dev/null
@@ -1,222 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/torque/torque-2.3.6.ebuild,v 1.10 2010/08/05 03:18:42 jsbronder Exp $
-
-inherit flag-o-matic eutils linux-info
-
-DESCRIPTION="Resource manager and queuing system based on OpenPBS"
-HOMEPAGE="http://www.clusterresources.com/products/torque/"
-SRC_URI="http://www.clusterresources.com/downloads/${PN}/${P}.tar.gz"
-
-LICENSE="openpbs"
-
-SLOT="0"
-KEYWORDS="alpha amd64 hppa ia64 ~mips ppc ppc64 sparc x86"
-IUSE="tk crypt server syslog doc cpusets kernel_linux"
-PROVIDE="virtual/pbs"
-
-# ed is used by makedepend-sh
-DEPEND_COMMON="sys-libs/ncurses
- sys-libs/readline
- tk? ( dev-lang/tk )
- syslog? ( virtual/logger )
- !virtual/pbs
- !sys-cluster/openpbs-common
- !games-util/qstat"
-
-DEPEND="${DEPEND_COMMON}
- sys-apps/ed"
-
-RDEPEND="${DEPEND_COMMON}
- crypt? ( net-misc/openssh )
- !crypt? ( net-misc/netkit-rsh )"
-
-pkg_setup() {
- PBS_SERVER_HOME="${PBS_SERVER_HOME:-/var/spool/torque}"
-
- USE_CPUSETS="--disable-cpusets"
- if use cpusets; then
- if ! use kernel_linux; then
- einfo
- elog " Torque currently only has support for cpusets in linux."
- elog "Assuming you didn't really want this USE flag."
- einfo
- else
- linux-info_pkg_setup
- einfo
- elog " Torque support for cpusets is still in development, you may"
- elog "wish to disable it for production use."
- einfo
- if ! linux_config_exists || ! linux_chkconfig_present CPUSETS; then
- einfo
- elog " Torque support for cpusets will require that you recompile"
- elog "your kernel with CONFIG_CPUSETS enabled."
- einfo
- fi
- USE_CPUSETS="--enable-cpusets"
- fi
- fi
-}
-
-src_compile() {
- local myconf="--with-rcp=mom_rcp"
-
- use crypt && myconf="--with-rcp=scp"
-
- [ -n "${PBS_SERVER_NAME}" ] || PBS_SERVER_NAME=$(hostname -f)
-
- econf \
- $(use_enable tk gui) \
- $(use_enable syslog) \
- $(use_enable server) \
- --with-server-home=${PBS_SERVER_HOME} \
- --with-environ=/etc/pbs_environment \
- --with-default-server=${PBS_SERVER_NAME} \
- --disable-gcc-warnings \
- ${USE_CPUSETS} \
- ${myconf} \
- || die "econf failed"
- emake || die "emake failed"
-}
-
-# WARNING
-# OpenPBS is extremely stubborn about directory permissions. Sometimes it will
-# just fall over with the error message, but in some spots it will just ignore
-# you and fail strangely. Likewise it also barfs on our .keep files!
-pbs_createspool() {
- local root="$1"
- local s="$(dirname "${PBS_SERVER_HOME}")"
- local h="${PBS_SERVER_HOME}"
- local sp="${h}/server_priv"
- einfo "Building spool directory under ${D}${h}"
- local a d m
- local dir_spec="
- 0755:${h}/aux 0700:${h}/checkpoint
- 0755:${h}/mom_logs 0751:${h}/mom_priv 0751:${h}/mom_priv/jobs
- 1777:${h}/spool 1777:${h}/undelivered"
-
- if use server; then
- dir_spec="${dir_spec} 0755:${h}/sched_logs
- 0755:${h}/sched_priv/accounting 0755:${h}/server_logs
- 0750:${h}/server_priv 0755:${h}/server_priv/accounting
- 0750:${h}/server_priv/acl_groups 0750:${h}/server_priv/acl_hosts
- 0750:${h}/server_priv/acl_svr 0750:${h}/server_priv/acl_users
- 0750:${h}/server_priv/jobs 0750:${h}/server_priv/queues"
- fi
-
- for a in ${dir_spec}; do
- d="${a/*:}"
- m="${a/:*}"
- if [[ ! -d "${root}${d}" ]]; then
- install -d -m${m} "${root}${d}"
- else
- chmod ${m} "${root}${d}"
- fi
- # (#149226) If we're running in src_*, then keepdir
- if [[ "${root}" = "${D}" ]]; then
- keepdir ${d}
- fi
- done
-}
-
-src_install() {
- # Make directories first
- pbs_createspool "${D}"
-
- make DESTDIR="${D}" install || die "make install failed"
-
- dodoc CHANGELOG DEVELOPMENT README.* Release_Notes || die "dodoc failed"
- if use doc; then
- dodoc doc/admin_guide.ps doc/*.pdf || die "dodoc failed"
- fi
-
- # The build script isn't alternative install location friendly,
- # So we have to fix some hard-coded paths in tclIndex for xpbs* to work
- for file in `find "${D}" -iname tclIndex`; do
- sed -e "s/${D//\// }/ /" "${file}" > "${file}.new"
- mv "${file}.new" "${file}"
- done
-
- if use server; then
- newinitd "${FILESDIR}"/pbs_server-init.d pbs_server
- newinitd "${FILESDIR}"/pbs_sched-init.d pbs_sched
- fi
- newinitd "${FILESDIR}"/pbs_mom-init.d pbs_mom
- newconfd "${FILESDIR}"/torque-conf.d torque
- newenvd "${FILESDIR}"/torque-env.d 25torque
-}
-
-pkg_preinst() {
- if [[ -f "${ROOT}etc/pbs_environment" ]]; then
- cp "${ROOT}etc/pbs_environment" "${D}"/etc/pbs_environment
- fi
-
- if [ -n "${PBS_SERVER_NAME}" ]; then
- echo "${PBS_SERVER_NAME}" > "${D}${PBS_SERVER_HOME}/server_name"
- elif [[ -f "${ROOT}${PBS_SERVER_HOME}/server_name" ]]; then
- cp "${ROOT}${PBS_SERVER_HOME}/server_name" "${D}${PBS_SERVER_HOME}/server_name"
- fi
-
- # Fix up the env.d file to use our set server home.
- sed -i "s:/var/spool/torque:${PBS_SERVER_HOME}:g" "${D}"/etc/env.d/25torque
-}
-
-pkg_postinst() {
- pbs_createspool "${ROOT}"
- elog " If this is the first time torque has been installed, then you are not"
- elog "ready to start the server. Please refer to the documentation located at:"
- elog "http://www.clusterresources.com/wiki/doku.php?id=torque:torque_wiki"
-
- elog " For a basic setup, you may use emerge --config ${PN}"
-}
-
-# Either the correct PBS_SERVER_HOME and PBS_SERVER_NAME are set
-# or we use the default HOME and the localhost as the server.
-# root will be setup as the primary operator/manager, the local machine
-# will be added as a node and we'll create a simple queue, batch.
-pkg_config() {
- local h="$(echo "${ROOT}/${PBS_SERVER_HOME}" | sed 's:///*:/:g')"
- local rc=0
-
- ebegin "Configuring Torque"
- [ -n "${PBS_SERVER_NAME}" ] || PBS_SERVER_NAME=$(hostname -f)
- einfo "Using ${h} as the pbs homedir"
- einfo "Using ${PBS_SERVER_NAME} as the pbs_server"
-
- # Check for previous configuration and bail if found.
- if [ -e "${h}/server_priv/acl_svr/operators" ] \
- || [ -e "${h}/server_priv/nodes" ] \
- || [ -e "${h}/mom_priv/config" ]; then
- ewarn "Previous Torque configuration detected. Press any key to"
- ewarn "continue or press Control-C to abort now"
- read
- fi
-
- # pbs_mom configuration.
- echo "\$pbsserver ${PBS_SERVER_NAME}" > "${h}/mom_priv/config"
- echo "\$logevent 255" >> "${h}/mom_priv/config"
-
- if use server; then
- local qmgr="${ROOT}/usr/bin/qmgr -c"
- # pbs_server bails on repeated backslashes.
- if ! echo "y" | "${ROOT}"/usr/sbin/pbs_server -d "${h}" -t create; then
- eerror "Failed to start pbs_server"
- rc=1
- else
- ${qmgr} "set server operators = root@$(hostname -f)" ${PBS_SERVER_NAME}
- ${qmgr} "create queue batch" ${PBS_SERVER_NAME}
- ${qmgr} "set queue batch queue_type = Execution" ${PBS_SERVER_NAME}
- ${qmgr} "set queue batch started = True" ${PBS_SERVER_NAME}
- ${qmgr} "set queue batch enabled = True" ${PBS_SERVER_NAME}
- ${qmgr} "set server default_queue = batch" ${PBS_SERVER_NAME}
- ${qmgr} "set server resources_default.nodes = 1" ${PBS_SERVER_NAME}
- ${qmgr} "set server scheduling = True" ${PBS_SERVER_NAME}
-
- "${ROOT}"/usr/bin/qterm -t quick ${PBS_SERVER_NAME} || rc=1
-
- # Add the local machine as a node.
- echo "$(hostname -f) np=1" > "${h}/server_priv/nodes"
- fi
- fi
- eend ${rc}
-}